Mantis Bug Tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0005737opensim[REGION] OpenSim Corepublic2011-10-10 08:292011-12-28 06:24
Reporterkenvc 
Assigned To 
PrioritynormalSeverityminorReproducibilitysometimes
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Versionmaster (dev code) 
Target VersionFixed in Versionmaster (dev code) 
Summary0005737: OpenSim.Framework.Util: async_call_method thread terminated with exception The given key was not present
DescriptionNot sure how major this error is or specifically what caused it, but this error happens quite often.

See log file in additional information.
Additional InformationEnclosed log data:

2011-10-10 06:19:47,238 INFO - OpenSim.Framework.AgentCircuitData [AGENTCIRCUITDATA]: agentid=55238ddf-d369-4e3d-9244-880d0eb4abf3, child=True, startpos=<128, 128, 30>
2011-10-10 06:19:47,241 INFO - OpenSim.Framework.AgentCircuitData [AGENTCIRCUITDATA] unpacked appearance
2011-10-10 06:19:47,985 INFO - OpenSim.Region.Framework.Scenes.Scene [CONNECTION BEGIN]: Region White Sand Beach authenticated and authorized incoming child agent Sweet.JaneX @204.236.242.209 55238ddf-d369-4e3d-9244-880d0eb4abf3 (circuit code 1767939261)
2011-10-10 06:19:48,598 INFO - OpenSim.Framework.AgentData [CHILDAGENTDATAUPDATE] Unpack data
2011-10-10 06:19:54,004 WARN - OpenSim.Region.CoreModules.Avatar.AvatarFactory.AvatarFactoryModule [AVFACTORY]: Missing baked texture af742301-ee51-4e15-8be0-4bb44cf5e09a (8) for avatar Sweet.JaneX @204.236.242.209
2011-10-10 06:19:59,620 ERROR - OpenSim.Framework.Util [UTIL]: Continuing after async_call_method thread terminated with exception The given key was not present in the dictionary. at System.ThrowHelper.ThrowKeyNotFoundException()
   at System.Collections.Generic.Dictionary`2.get_Item(TKey key)
   at OpenSim.Services.Connectors.XInventoryServicesConnector.GetRootFolder(UUID principalID) in C:\Users\Ken\Desktop\opensim-rev16847\OpenSim\Services\Connectors\Inventory\XInventoryConnector.cs:line 139
   at OpenSim.Region.CoreModules.ServiceConnectorsOut.Inventory.RemoteXInventoryServicesConnector.GetRootFolder(UUID userID) in C:\Users\Ken\Desktop\opensim-rev16847\OpenSim\Region\CoreModules\ServiceConnectorsOut\Inventory\RemoteXInventoryServiceConnector.cs:line 185
   at OpenSim.Region.CoreModules.ServiceConnectorsOut.Inventory.HGInventoryBroker.GetRootFolder(UUID userID) in C:\Users\Ken\Desktop\opensim-rev16847\OpenSim\Region\CoreModules\ServiceConnectorsOut\Inventory\HGInventoryBroker.cs:line 323
   at OpenSim.Region.CoreModules.Avatar.AvatarFactory.AvatarFactoryModule.SetAppearanceAssets(UUID userID, AvatarAppearance appearance) in C:\Users\Ken\Desktop\opensim-rev16847\OpenSim\Region\CoreModules\Avatar\AvatarFactory\AvatarFactoryModule.cs:line 555
   at OpenSim.Region.CoreModules.Avatar.AvatarFactory.AvatarFactoryModule.SaveAppearance(UUID agentid) in C:\Users\Ken\Desktop\opensim-rev16847\OpenSim\Region\CoreModules\Avatar\AvatarFactory\AvatarFactoryModule.cs:line 430
   at OpenSim.Region.CoreModules.Avatar.AvatarFactory.AvatarFactoryModule.<>c__DisplayClassa.<HandleAppearanceUpdateTimer>b__5(Object o) in C:\Users\Ken\Desktop\opensim-rev16847\OpenSim\Region\CoreModules\Avatar\AvatarFactory\AvatarFactoryModule.cs:line 459
   at OpenSim.Framework.Util.<>c__DisplayClass3.<FireAndForget>b__0(Object o) in C:\Users\Ken\Desktop\opensim-rev16847\OpenSim\Framework\Util.cs:line 1555
2011-10-10 06:21:04,064 INFO - OpenSim.Services.Connectors.Hypergrid.UserAgentServiceConnector [USER AGENT CONNECTOR]: Posted CreateAgent request to remote sim http://204.236.242.209:9500/homeagent/55238ddf-d369-4e3d-9244-880d0eb4abf3/, [^] region hub-hg15i6, x=2042880 y=2042880
2011-10-10 06:21:05,136 INFO - OpenSim.Services.Connectors.Hypergrid.UserAgentServiceConnector [USER AGENT CONNECTOR]: DoCreateChildAgentCall reply was {"success":true}
2011-10-10 06:21:05,339 INFO - OpenSim.Framework.AgentData [CHILDAGENTDATAUPDATE] Pack data
2011-10-10 06:21:36,174 WARN - OpenSim.Region.CoreModules.Framework.EntityTransfer.EntityTransferModule [ENTITY TRANSFER MODULE]: Teleport of Sweet.JaneX @204.236.242.209 to hub-hg15i6 failed due to no callback from destination region. Returning avatar to source region.
2011-10-10 06:22:04,022 WARN - OpenSim.Region.ClientStack.LindenUDP.LLUDPServer [LLUDPSERVER]: Ack timeout, disconnecting 55238ddf-d369-4e3d-9244-880d0eb4abf3
2011-10-10 06:22:09,084 ERROR - OpenSim.OpenSim [WATCHDOG]: Timeout detected for thread "Outgoing Packets (White Sand Beach)". ThreadState=WaitSleepJoin. Last tick was 5070ms ago
TagsNo tags attached.
Git Revision or version numberrev 16847
Run Mode Grid (Multiple Regions per Sim)
Physics EngineODE
Environment.NET / Windows64
Mono VersionNone
ViewerN/A
Attached Files

- Relationships

-  Notes
(0020586)
kenvc (reporter)
2011-12-21 09:25

This error appears to be resolved in the latest dev master. Thanks Justin!

- Issue History
Date Modified Username Field Change
2011-10-10 08:29 kenvc New Issue
2011-10-10 08:29 kenvc Git Revision => rev 16847
2011-10-10 08:29 kenvc Run Mode => Grid (Multiple Regions per Sim)
2011-10-10 08:29 kenvc Physics Engine => ODE
2011-10-10 08:29 kenvc Environment => .NET / Windows64
2011-10-10 08:29 kenvc Mono Version => None
2011-10-10 08:29 kenvc Viewer => N/A
2011-12-21 09:25 kenvc Note Added: 0020586
2011-12-21 09:25 kenvc Status new => resolved
2011-12-21 09:25 kenvc Fixed in Version => master (dev code)
2011-12-28 06:24 makopoppo Status resolved => closed
2011-12-28 06:24 makopoppo Resolution open => fixed


Copyright © 2000 - 2012 MantisBT Group
Powered by Mantis Bugtracker