Mantis Bug Tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0005721opensim[REGION] OpenSim Corepublic2011-10-03 05:142011-11-28 07:12
ReporterMichelle Argus 
Assigned To 
PrioritynormalSeveritymajorReproducibilityalways
StatusclosedResolutionno change required 
PlatformOSOS Version
Product Versionmaster (dev code) 
Target VersionFixed in Version 
Summary0005721: Multiple Regions always have same estate owner
DescriptionWhen loading multiple regions to 1 sim, the estate owner (in Region/Estate)is always the owner of the first region listed and can change estate settings.

 In About Land -> Covenant the correct owner is listed.

I am using the xml regionfiles from web, so this might be an issue the ini-format does not have...
TagsNo tags attached.
Git Revision or version number961d9ce
Run Mode Grid (Multiple Regions per Sim)
Physics EngineBasicPhysics
Script Engine
EnvironmentMono / Linux64
Mono VersionNone
Viewer
Attached Files

- Relationships
related to 0005699patch included [Patch] Add God Permission for Agents Listed 

-  Notes
(0020089)
melanie (administrator)
2011-10-03 05:16

This is by design. The estate owner name is spoofed to be the name of the currently logged in god to allow the viewer to enable estate dialog features. It's a viewer limitation that we addressed that way. The covenant page lists the actual owner, the estate page lists the current user if they are a god.
(0020091)
Michelle Argus (reporter)
2011-10-03 06:17

Ahh, now i see. This is related to the patch Proposal in Mantis 5699 I already implemented. Still waiting for your responce on that one though ;)

Anyway, closing this mantis now...

- Issue History
Date Modified Username Field Change
2011-10-03 05:14 Michelle Argus New Issue
2011-10-03 05:14 Michelle Argus Git Revision => 961d9ce
2011-10-03 05:14 Michelle Argus Run Mode => Grid (Multiple Regions per Sim)
2011-10-03 05:14 Michelle Argus Physics Engine => BasicPhysics
2011-10-03 05:14 Michelle Argus Environment => Mono / Linux64
2011-10-03 05:14 Michelle Argus Mono Version => None
2011-10-03 05:16 melanie Note Added: 0020089
2011-10-03 06:15 Michelle Argus Relationship added related to 0005699
2011-10-03 06:17 Michelle Argus Note Added: 0020091
2011-10-03 06:18 Michelle Argus Status new => resolved
2011-10-03 06:18 Michelle Argus Resolution open => no change required
2011-10-03 06:18 Michelle Argus Assigned To => Michelle Argus
2011-11-28 07:12 makopoppo Status resolved => closed
2011-11-28 07:12 makopoppo Assigned To Michelle Argus =>


Copyright © 2000 - 2012 MantisBT Group
Powered by Mantis Bugtracker