Mantis Bug Tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0005715opensim[REGION] Specific OpenSim Modulepublic2011-09-28 12:152014-07-29 13:40
ReporterMichelle Argus 
Assigned Tojustincc 
PrioritynormalSeverityminorReproducibilityhave not tried
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Versionmaster (dev code) 
Target VersionFixed in Version 
Summary0005715: [Patch] Added access IP and missing password checks
DescriptionTo make the Remote Admin Module safer, the patch adds the option to list IP adresses in the ini. If used, only the listed IP's gain acess to the Remote Admin functions...

The Patch also includes
- Added password check to functions missing the full password check
- Replaced old style CheckStringParameters() were not implemented yet
TagsNo tags attached.
Git Revision or version number8caf3ed49ec3403843e25db018cc9db63e2ca643
Run ModeStandalone (1 Region) , Standalone (Multiple Regions) , Grid (1 Region per Sim) , Grid (Multiple Regions per Sim)
Physics EngineBasicPhysics
EnvironmentUnknown
Mono VersionNone
Viewer
Attached Filestxt file icon 001-[Remote Admin] Added-Access-IP-And-Missing-Password-Checks.txt [^] (25,307 bytes) 2011-09-28 12:15 [Show Content]
txt file icon 002-[Remote Admin] Added-Access-IP-And-Missing-Password-Checks.txt [^] (25,349 bytes) 2011-10-01 06:44 [Show Content]

- Relationships

-  Notes
(0020076)
justincc (administrator)
2011-09-30 17:00

I think the concept is good. A couple of comments.

* There is no e-mail in the patch from field. This stops my git from applying it.
* m_access_ip should be m_accessIp or possible m_accessIP.
* m_accessIp would be better implemented as a HashSet<string> rather than a List.
* There's no blank line between the FailIfRemoteAdminNotAllowed() method and the code above.
(0020080)
Pixel Tomsen (manager)
2011-10-01 02:23

nice michelle,

die kleinen Schoenheitsfehler nur berichtigen, dann kommt es sicher rein;-)
(0020083)
Michelle Argus (reporter)
2011-10-01 06:46

Added new patch 002 replacing 001

- changed m_access_ip to m_acessIP
- Added missing blank line
- HashSet failed on build, so kept list. Missing c experiance on that one^^
(0020119)
justincc (administrator)
2011-10-07 18:03

Thanks Michelle, applied as git master 29660fe.

I still cannot apply your patches directly in git. Whatever program you are using is not generating the correct format.

I made the HashSet change in 71d29de. It probably wouldn't compile for you because it needed a System.Core reference in prebuild.xml.

- Issue History
Date Modified Username Field Change
2011-09-28 12:15 Michelle Argus New Issue
2011-09-28 12:15 Michelle Argus File Added: 001-[Remote Admin] Added-Access-IP-And-Missing-Password-Checks.txt
2011-09-28 12:15 Michelle Argus Git Revision => 8caf3ed49ec3403843e25db018cc9db63e2ca643
2011-09-28 12:15 Michelle Argus Run Mode => Standalone (1 Region) , Standalone (Multiple Regions) , Grid (1 Region per Sim) , Grid (Multiple Regions per Sim)
2011-09-28 12:15 Michelle Argus Physics Engine => BasicPhysics
2011-09-28 12:15 Michelle Argus Environment => Unknown
2011-09-28 12:15 Michelle Argus Mono Version => None
2011-09-28 12:16 Michelle Argus Status new => patch included
2011-09-30 17:00 justincc Note Added: 0020076
2011-09-30 17:00 justincc Status patch included => patch feedback
2011-10-01 02:23 Pixel Tomsen Note Added: 0020080
2011-10-01 06:44 Michelle Argus File Added: 002-[Remote Admin] Added-Access-IP-And-Missing-Password-Checks.txt
2011-10-01 06:46 Michelle Argus Note Added: 0020083
2011-10-07 18:03 justincc Status patch feedback => resolved
2011-10-07 18:03 justincc Resolution open => fixed
2011-10-07 18:03 justincc Assigned To => justincc
2011-10-07 18:03 justincc Note Added: 0020119
2014-07-29 13:40 chi11ken Status resolved => closed


Copyright © 2000 - 2012 MantisBT Group
Powered by Mantis Bugtracker