Mantis Bug Tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000057opensim[GRID] Asset Servicepublic2007-11-29 02:232008-02-08 08:13
ReporterSakai 
Assigned To 
PriorityurgentSeveritycrashReproducibilityalways
StatusclosedResolutionfixed 
PlatformWINOSSVR2003OS Version
Product Version 
Target VersionFixed in Version 
Summary0000057: Asset Cache Error. Line 275/line 107
DescriptionAsset cache error....

unsure of the cause but this error throws up repeatedly...


Index was outside the bounds of the array. : at System.Collections.Generic.Di
ctionary`2.Insert(TKey key, TValue value, Boolean add)
   at System.Collections.Generic.Dictionary`2.Add(TKey key, TValue value)
   at OpenSim.Framework.Communications.Cache.AssetCache.ProcessTextureQueue() in
 C:\os4svn\trunk\OpenSim\Framework\Communications\Cache\AssetCache.cs:line 275
   at OpenSim.Framework.Communications.Cache.AssetCache.RunAssetManager() in C:\
os4svn\trunk\OpenSim\Framework\Communications\Cache\AssetCache.cs:line 107

Usually plagues only one region/sim and keeps returning at will (obviously there's a cause but i haven't ID'd it yet).

Does not effect surrounding SIMs but does stay online but unresponsive.

Causes error in windows as it keeps spinning the same error over and over.... (I think it keeps attempting the same cause over and over - probably needs an out).
Additional InformationThis issue is no longer valid from SVN 2631 onwards probably due to major changes in clientview.cs in a couple of earlier revisions.

However this may actually be similar to the error manifesting in Mantis 0000153.

Fixed or is maybe Mantis 153
TagsNo tags attached.
Git Revision or version number
Run Mode
Physics Engine
Environment
Mono Version
Viewer
Attached Files

- Relationships

-  Notes
(0000034)
Sakai (developer)
2007-11-29 02:34
edited on: 2007-11-29 10:50

IT IS also noted that as a result the Grid Server will crash without warning a few seconds after this occurance, (but not always).

(0000038)
Sakai (developer)
2007-11-29 21:16

It should also be noted after this texture uplaods are not available in the region while it loops this error however walking aroudn talking etc is ok (except while the error looping is going on cpu load is increased)
(0000049)
Sakai (developer)
2007-12-01 18:34
edited on: 2007-12-01 18:34

This issue still exists SVN 2541. (exact same error)

Index was outside the bounds of the array. : at System.Collections.Generic.Di
ctionary`2.Insert(TKey key, TValue value, Boolean add)
   at System.Collections.Generic.Dictionary`2.Add(TKey key, TValue value)
   at OpenSim.Framework.Communications.Cache.AssetCache.ProcessTextureQueue() in
 C:\os4svn\trunk\OpenSim\Framework\Communications\Cache\AssetCache.cs:line 275
   at OpenSim.Framework.Communications.Cache.AssetCache.RunAssetManager() in C:\
os4svn\trunk\OpenSim\Framework\Communications\Cache\AssetCache.cs:line 107

(0000055)
Sakai (developer)
2007-12-03 05:52

Issue still presists in 2550

- Issue History
Date Modified Username Field Change
2007-11-29 02:23 Sakai New Issue
2007-11-29 02:34 Sakai Note Added: 0000034
2007-11-29 02:44 Sakai Note Edited: 0000034
2007-11-29 07:48 Sakai Note Edited: 0000034
2007-11-29 10:50 Sakai Note Edited: 0000034
2007-11-29 21:16 Sakai Note Added: 0000038
2007-12-01 18:34 Sakai Note Added: 0000049
2007-12-01 18:34 Sakai Note Edited: 0000049
2007-12-03 05:52 Sakai Note Added: 0000055
2007-12-04 06:13 Sakai Priority normal => urgent
2007-12-04 06:13 Sakai Severity minor => crash
2007-12-09 17:05 Sakai Resolution open => fixed
2007-12-09 17:05 Sakai Additional Information Updated
2007-12-11 01:30 Sakai Status new => resolved
2007-12-11 01:30 Sakai Additional Information Updated
2008-02-08 08:13 sdague Status resolved => closed


Copyright © 2000 - 2012 MantisBT Group
Powered by Mantis Bugtracker