Mantis Bug Tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0005601opensim[REGION] Physics Enginespublic2011-07-22 13:222014-07-29 13:41
Reportercmickeyb 
Assigned ToRobert Adams 
PrioritynormalSeverityminorReproducibilityalways
StatusclosedResolutionfixed 
PlatformMonoOS0.7.5OS Versionr21457
Product Versionmaster (dev code) 
Target VersionFixed in Versionmaster (dev code) 
Summary0005601: bulletsim bouyancy doesn't seem to work
DescriptionScript-based setting of bouyancy doesn't seem to work with BulletSim.
Bouyant objects fall to the ground immediately.
TagsNo tags attached.
Git Revision or version numbera9b9c0f0351a6749bf55c29b2891fa40928b4c39
Run Mode Grid (Multiple Regions per Sim)
Physics EngineBulletSim
EnvironmentMono / Linux32, Mono / Linux64
Mono Version2.10
ViewerServer Side Physics
Attached Files

- Relationships

-  Notes
(0023213)
Allen Kerensky (reporter)
2012-12-08 09:44

Duplicated on my regions - running OSgrid's OpenSim release 0.7.5 r21314.

All else being equal:
With physics = ODE, Myriad Lite bullets will fly normally.

With physics = BulletSim, the Myriad Lite bullets fall straight down.

Verified with and without region/parcel push enabled/allowed.

The bullet script is based on the way old SL trick of setting bouyancy to 1.0 so it hovers while llRezObject provides the vector of push.

The bullet script used is here:
http://opensimulator.org/wiki/User:Allen_Kerensky/Myriad_Lite/Myriad_Lite_Bullet-Preview6.lsl [^]

The firearm script used is here:
http://opensimulator.org/wiki/User:Allen_Kerensky/Myriad_Lite/Myriad_Lite_Firearm-Preview6.lsl [^]

Other than this - so far BulletSim has been drop-in usable goodness.
I was able to walk all over my regions and not fall through things or any of the other usual physics-based weirdness.
I have not tried ground or flight vehicles yet.
(0023292)
Allen Kerensky (reporter)
2012-12-19 18:45

Just tested 0.7.5 r21457 from 2012-12-19 on Myriad regions.
Same issue as reported on 2012-12-08
(0023297)
cmickeyb (administrator)
2012-12-21 14:39

I can get an object to float correctly (or it appears to) but I cant act on it after that (no grab). This might be fixed but need to test when llApplyImpulse works.
(0023325)
Robert Adams (administrator)
2012-12-27 08:37

The problem was that Bullet resets an object's gravity when it is made part of the physical world. The order of world addition and gravity setting has been corrected.

- Issue History
Date Modified Username Field Change
2011-07-22 13:22 cmickeyb New Issue
2011-07-22 13:22 cmickeyb Git Revision => 3c09f918ada2ba32
2011-07-22 13:22 cmickeyb Run Mode => Grid (Multiple Regions per Sim)
2011-07-22 13:22 cmickeyb Physics Engine => Other
2011-07-22 13:22 cmickeyb Environment => Mono / Linux32
2011-07-22 13:22 cmickeyb Mono Version => 2.6.3
2012-12-08 09:44 Allen Kerensky Note Added: 0023213
2012-12-08 09:51 Allen Kerensky Git Revision or version number 3c09f918ada2ba32 => 583e44103c8eb552c437468cba84771c94592ae9
2012-12-08 09:51 Allen Kerensky Physics Engine Other => BulletSim
2012-12-08 09:51 Allen Kerensky Environment Mono / Linux32 => Mono / Linux32, Mono / Linux64
2012-12-08 09:51 Allen Kerensky Mono Version 2.6.3 => 2.10
2012-12-08 09:51 Allen Kerensky Viewer => Server Side Physics
2012-12-08 09:51 Allen Kerensky OS => 0.7.5
2012-12-08 09:51 Allen Kerensky OS Version => r21314
2012-12-08 09:51 Allen Kerensky Platform => Mono
2012-12-08 09:51 Allen Kerensky Description Updated View Revisions
2012-12-19 18:45 Allen Kerensky Git Revision or version number 583e44103c8eb552c437468cba84771c94592ae9 => a9b9c0f0351a6749bf55c29b2891fa40928b4c39
2012-12-19 18:45 Allen Kerensky Note Added: 0023292
2012-12-19 18:45 Allen Kerensky OS Version r21314 => r21457
2012-12-21 14:38 cmickeyb Assigned To => Robert Adams
2012-12-21 14:38 cmickeyb Status new => assigned
2012-12-21 14:39 cmickeyb Note Added: 0023297
2012-12-27 08:37 Robert Adams Note Added: 0023325
2012-12-27 08:37 Robert Adams Status assigned => resolved
2012-12-27 08:37 Robert Adams Fixed in Version => master (dev code)
2012-12-27 08:37 Robert Adams Resolution open => fixed
2014-07-29 13:41 chi11ken Status resolved => closed


Copyright © 2000 - 2012 MantisBT Group
Powered by Mantis Bugtracker