Mantis Bug Tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0005546opensim[REGION] OpenSim Corepublic2011-06-13 12:192011-06-17 08:55
Reporteraiaustin 
Assigned To 
PrioritynormalSeverityminorReproducibilityalways
StatusnewResolutionopen 
PlatformOSOS Version
Product Versionmaster (dev code) 
Target VersionFixed in Version 
Summary0005546: Error on map tile upload - Delegate for PrimsLoaded failed - continuing Parameter is not valid
DescriptionTesting Map tile upload version of 0.7.2 dev master on Openvue grid - noticing new error...

2011-06-13 20:15:06,152 ERROR - OpenSim.Region.Framework.Scenes.EventManager [EVENT MANAGER]: Delegate for PrimsLoaded failed - continuing Parameter is not valid. - at System.Drawing.Bitmap.LockBits(Rectangle rect, ImageLockMode flags, PixelFormat format, BitmapData bitmapData)

Additional Information2011-06-13 20:15:05,799 DEBUG - OpenSim.Region.CoreModules.ServiceConnectorsOut.MapImage.MapImageServiceModule [MAP IMAGE SERVICE MODULE]: upload maptile for Edinburgh University

2011-06-13 20:15:06,152 ERROR - OpenSim.Region.Framework.Scenes.EventManager [EVENT MANAGER]: Delegate for PrimsLoaded failed - continuing Parameter is not valid. - at System.Drawing.Bitmap.LockBits(Rectangle rect, ImageLockMode flags, PixelFormat format, BitmapData bitmapData)

   at System.Drawing.Bitmap.LockBits(Rectangle rect, ImageLockMode flags, PixelFormat format)

   at OpenSim.Region.CoreModules.World.Warp3DMap.TerrainSplat.Splat(Single[] heightmap, UUID[] textureIDs, Single[] startHeights, Single[] heightRanges, Vector3d regionPosition, IAssetService assetService, Boolean textureTerrain) in d:\Temp\OpenSim\Region\CoreModules\World\Warp3DMap\TerrainSplat.cs:line 250

   at OpenSim.Region.CoreModules.World.Warp3DMap.Warp3DImageModule.CreateTerrain(Warp3D renderer, Boolean textureTerrain) in d:\Temp\OpenSim\Region\CoreModules\World\Warp3DMap\MapImageModule.cs:line 321

   at OpenSim.Region.CoreModules.World.Warp3DMap.Warp3DImageModule.CreateMapTile(Viewport viewport, Boolean useTextures) in d:\Temp\OpenSim\Region\CoreModules\World\Warp3DMap\MapImageModule.cs:line 199

   at OpenSim.Region.CoreModules.World.Warp3DMap.Warp3DImageModule.CreateMapTile() in d:\Temp\OpenSim\Region\CoreModules\World\Warp3DMap\MapImageModule.cs:line 131

   at OpenSim.Region.CoreModules.ServiceConnectorsOut.MapImage.MapImageServiceModule.UploadMapTile(IScene scene) in d:\Temp\OpenSim\Region\CoreModules\ServiceConnectorsOut\MapImage\MapImageServiceModule.cs:line 214

   at OpenSim.Region.CoreModules.ServiceConnectorsOut.MapImage.MapImageServiceModule.EventManager_OnPrimsLoaded(Scene s) in d:\Temp\OpenSim\Region\CoreModules\ServiceConnectorsOut\MapImage\MapImageServiceModule.cs:line 164

   at OpenSim.Region.Framework.Scenes.EventManager.TriggerPrimsLoaded(Scene s) in d:\Temp\OpenSim\Region\Framework\Scenes\EventManager.cs:line 2259
TagsNo tags attached.
Git Revision or version number0.7.2 dev master
Run Mode Grid (Multiple Regions per Sim)
Physics EngineODE
Script Engine
Environment.NET / Windows32
Mono VersionNone
ViewerN/A
Attached Files

- Relationships

-  Notes
(0018679)
aiaustin (developer)
2011-06-13 12:21
edited on: 2011-06-13 12:23

Also worth noting that we still seem to have a problem on first use of a new OpenSim build that one (a first?) region of those regions included in each openSim.exe instance does not update the map tile for that one region, but it does for all others in that instance. This is a long standing fault. It does update on second run.

See http://opensimulator.org/mantis/view.php?id=5204 [^]

(0018680)
aiaustin (developer)
2011-06-13 12:33

I noticed that the map tiles flashing on and off as you change zoom level or change the size of the map window in Viewer 2 (2.6.9) is the one that failed to generate on first run.

Whej I started the OpenSim instances that contained the regions that wwere flashing (one - first?) in each, the flashing went away and the map behaved correctly for that region.

The other regions flashing are the map tiles for HG link-regions.
(0018687)
aiaustin (developer)
2011-06-15 03:59
edited on: 2011-06-15 04:00

It seems this error is NOT related just to the use of the warp3d renderer for map tiles, as it also now shows in the OSGrid add on region distribution and occurs with the standard map tile setup in that and whether or not I set for the Warp3D renderer in OpenSim.ini.

I am seeing this error with the 14-Jun-2011 r/15721 for OSGrid add on region distribution - osgrid.opensim-06142011.v0.7.2.603dbea.zip. It was not present in the previous version - osgrid.opensim-06122011.v0.7.2.06e254c.zipshutdopwn

2011-06-15 11:52:28,630 ERROR - OpenSim.Region.Framework.Scenes.EventManager [EVENT MANAGER]: Delegate for PrimsLoaded failed - continuing Object reference not set to an instance of an object. - at OpenSim.Region.CoreModules.ServiceConnectorsOut.MapImage.MapImageServiceModule.UploadMapTile(IScene scene) in d:\OSGRID\OSGRID 0.7 RELEASES\opensim-603dbea\OpenSim\Region\CoreModules\ServiceConnectorsOut\MapImage\MapImageServiceModule.cs:line 224

   at OpenSim.Region.CoreModules.ServiceConnectorsOut.MapImage.MapImageServiceModule.EventManager_OnPrimsLoaded(Scene s) in d:\OSGRID\OSGRID 0.7 RELEASES\opensim-603dbea\OpenSim\Region\CoreModules\ServiceConnectorsOut\MapImage\MapImageServiceModule.cs:line 164

   at OpenSim.Region.Framework.Scenes.EventManager.TriggerPrimsLoaded(Scene s) in d:\OSGRID\OSGRID 0.7 RELEASES\opensim-603dbea\OpenSim\Region\Framework\Scenes\EventManager.cs:line 2259

(0018692)
Diva (administrator)
2011-06-16 17:22

[17:15] <CIA-52> opensim: diva * r409738726d91 /OpenSim/Region/CoreModules/ServiceConnectorsOut/MapImage/MapImageServiceModule.cs: Added a couple of guards and warnings to the MapImage/MapImageServiceModule.
[17:15] <CIA-52> opensim: diva * r7819b4a794f5 /OpenSim/Region/ (7 files in 3 dirs): Merge branch 'master' of ssh://opensimulator.org/var/git/opensim [^]
(0018698)
aiaustin (developer)
2011-06-17 04:58
edited on: 2011-06-17 08:56

Hi Diva... was the patch above intended to address the "Delegate for PrimsLoaded failed" issue? I tested r/15729 frrom 17-Jun-2011 and still get that error reported in the OpenSim.exe console. I think its at the time of upload of a maptile to Robust, and only occurs on the first region of the 4 regions served by this instance of OpenSim.exe. I see one such message in each OpenSim.exe instance.. similar to the long term error we have seen on such a first run. On second run of each OpenSim.exe instance all the map tiles upload fine, even the first one, without this error showing.

I think the message is showing as something diffeernt with the new map tile uploader, but presumably the underlying issue is still the same one that been there for a long time as in Mantis 5204.

OpenSim.exe log for r/15729

12:48:20 - [EVENT MANAGER]: Delegate for PrimsLoaded failed - continuing Paramet
er is not valid. - at System.Drawing.Bitmap.LockBits(Rectangle rect, ImageLoc
kMode flags, PixelFormat format, BitmapData bitmapData)

(0018699)
Diva (administrator)
2011-06-17 08:19

The fix was for you second reported error message in note 0018687, which is different from the 1st. The 1st is purely a Warp3D issue. Someone else will have to look at that.
(0018700)
aiaustin (developer)
2011-06-17 08:55
edited on: 2011-06-17 08:57

Got it, yes I see that these were two types of error. Thanks for clarifying that Diva.

I have maps working now on OSGrid with the latest packaged version for add on regions for OSGrid too. They show the map tiles for OSGrid regions, but no tiles for the link-regions (same as I see on Openvue grid) which I believe is the current status.


- Issue History
Date Modified Username Field Change
2011-06-13 12:19 aiaustin New Issue
2011-06-13 12:19 aiaustin Git Revision => 0.7.2 dev master
2011-06-13 12:19 aiaustin SVN Revision => 15720
2011-06-13 12:19 aiaustin Run Mode => Grid (Multiple Regions per Sim)
2011-06-13 12:19 aiaustin Physics Engine => ODE
2011-06-13 12:19 aiaustin Environment => .NET / Windows32
2011-06-13 12:19 aiaustin Mono Version => None
2011-06-13 12:19 aiaustin Viewer => N/A
2011-06-13 12:21 aiaustin Note Added: 0018679
2011-06-13 12:23 aiaustin Note Edited: 0018679
2011-06-13 12:23 aiaustin Summary Error on map tile upload when usig Warp3d renderer - Delegate for PrimsLoaded failed - continuing Parameter is not valid => Error on map tile upload when using Warp3d renderer - Delegate for PrimsLoaded failed - continuing Parameter is not valid
2011-06-13 12:33 aiaustin Note Added: 0018680
2011-06-15 03:59 aiaustin Note Added: 0018687
2011-06-15 03:59 aiaustin Summary Error on map tile upload when using Warp3d renderer - Delegate for PrimsLoaded failed - continuing Parameter is not valid => Error on map tile upload - Delegate for PrimsLoaded failed - continuing Parameter is not valid
2011-06-15 04:00 aiaustin Note Edited: 0018687
2011-06-16 17:22 Diva Note Added: 0018692
2011-06-17 04:58 aiaustin Note Added: 0018698
2011-06-17 05:00 aiaustin Note Edited: 0018698
2011-06-17 08:19 Diva Note Added: 0018699
2011-06-17 08:55 aiaustin Note Added: 0018700
2011-06-17 08:56 aiaustin Note Edited: 0018698
2011-06-17 08:57 aiaustin Note Edited: 0018700


Copyright © 2000 - 2012 MantisBT Group
Powered by Mantis Bugtracker