Mantis Bug Tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0005510opensim[REGION] OpenSim Corepublic2011-05-31 08:022014-07-29 13:39
Reporteraiaustin 
Assigned Tojustincc 
PrioritynormalSeveritycrashReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version 
Target VersionFixed in Version 
Summary0005510: SL Viewer 2.6.8 crashes when llDialog used on touching an object
DescriptionImmediate viewer crash when using the SL viewer 2.6.8 when I touch a screen with the FreeView TV script in it. This is the case in OSGrid and on our own Openvue grid. This was not the case up to Viewer 2.6.6. It works fine also with 1.23.5.

BUT it works fine with Viewer 2.6.8 for FreeView screens in Second Life
itself with the same script in them.

As the system crashes without any server side warnings or errors its
tricky to know what is happening. I reset the object scripts just to
be sure and that had no effect.

I am using this specific version of the script which up to now has
worked fine in both SL and OpenSim:

http://openvce.net/resources/downloads/freeview-1.2a-2009-07-23.lsl [^]

Additional InformationRepeat by making a new object (e.g. cube). Add a new script to it and place in it the FreeView script.. version tested is common SL/OpenSim version from

http://openvce.net/resources/downloads/freeview-1.2a-2009-07-23.lsl [^]

Then touch the screen.. which should offer its menu.

In Second Life this works with Viewer 2.6.8, but crashes immediately in OpenSim (recent versions r/15540, 0.7.1.1 release r/15609 tested)
TagsNo tags attached.
Git Revision or version number0.7.1.1 release
Run Mode Grid (Multiple Regions per Sim)
Physics EngineODE
Environment.NET / Windows32
Mono VersionNone
ViewerSL: Viewer 2.6.8
Attached Files

- Relationships

-  Notes
(0018529)
aiaustin (developer)
2011-05-31 10:04
edited on: 2011-05-31 10:33

This cannot be right... but this is what it seems like to me after after whittling down the freeview script and getting crash after crash, the core item that seems to be causing the problem is llDialog. Create a new cube, add a new script, and then use this LSL code. And then touch the object and it crashes viewer 2.6.8 in OpenSim. Hardwiring the avatar key makes no diffeernce too, so its not the llDetectedKey(0) element. Same procedure in Second Life itself with Viewer 2.6.8 works fine.

default
{
    touch_start(integer num)
    {
        llDialog(llDetectedKey(0),"Title",["A","B","C"],777);
    }
}

(0018532)
justincc (administrator)
2011-05-31 11:29

Fixed in 8129e64 in git master.

Another good source of debug info is the viewer log. In this case, it pumped out a message which made the problem cause obvious.

- Issue History
Date Modified Username Field Change
2011-05-31 08:02 aiaustin New Issue
2011-05-31 08:02 aiaustin Git Revision => 0.7.1.1 release
2011-05-31 08:02 aiaustin SVN Revision => 15609
2011-05-31 08:02 aiaustin Run Mode => Grid (Multiple Regions per Sim)
2011-05-31 08:02 aiaustin Physics Engine => ODE
2011-05-31 08:02 aiaustin Environment => .NET / Windows32
2011-05-31 08:02 aiaustin Mono Version => None
2011-05-31 08:02 aiaustin Viewer => SL: Viewer 2.6.8
2011-05-31 08:03 aiaustin Description Updated
2011-05-31 08:04 aiaustin Additional Information Updated
2011-05-31 10:04 aiaustin Note Added: 0018529
2011-05-31 10:07 aiaustin Note Edited: 0018529
2011-05-31 10:29 aiaustin Summary SL Viewer 2.6.8 crashes when object with FreeView Script is touched => SL Viewer 2.6.8 crashes when llDialog used on touching an object
2011-05-31 10:31 aiaustin Note Edited: 0018529
2011-05-31 10:33 aiaustin Note Edited: 0018529
2011-05-31 11:29 justincc Status new => resolved
2011-05-31 11:29 justincc Resolution open => fixed
2011-05-31 11:29 justincc Assigned To => justincc
2011-05-31 11:29 justincc Note Added: 0018532
2014-07-29 13:39 chi11ken Status resolved => closed


Copyright © 2000 - 2012 MantisBT Group
Powered by Mantis Bugtracker