Mantis Bug Tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0005477opensim[REGION] OpenSim Corepublic2011-05-10 10:492014-07-29 13:39
ReporterMichelle Argus 
Assigned Tomelanie 
PrioritynormalSeveritymajorReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version 
Target VersionFixed in Version 
Summary0005477: Agent Limit gets set to 0 when aplying changes in the Regionsettings.
DescriptionWhen one changes any setting in the inworld viewer menu of the Region/Estate under the Tab "Region", the agentlimit is always set to 0. Due to thie agent limit teleports dont work afterwards.
Additional Informationthis issue might be related to http://opensimulator.org/mantis/view.php?id=5437. [^] For my regionconfigs i am using xml format loaded via web.
TagsNo tags attached.
Git Revision or version numberd4fcba08af080bcc60da490155cc88d3f20e7dda
Run Mode Grid (1 Region per Sim) , Grid (Multiple Regions per Sim)
Physics EngineBasicPhysics
EnvironmentMono / Linux32
Mono Version2.6.3
Viewerimprudence
Attached Filestxt file icon 001-Bugfix_Agentlimit.txt [^] (1,266 bytes) 2011-07-15 12:23 [Show Content]
txt file icon 002-Bugfix_Agentlimit.txt [^] (1,234 bytes) 2011-07-20 02:50 [Show Content]

- Relationships
related to 0005437closed Added MaxAgents to RegionConfig.ini 

-  Notes
(0018411)
Michelle Argus (reporter)
2011-05-13 10:24
edited on: 2011-05-13 10:24

Did some further testing and this issue seems to be limited to using regionfiles from web, maybe also non ini fileformats.

The result is that noone can visit the region, and only a manual DB change helps to put agentlimit to a higher value

(0018883)
Michelle Argus (reporter)
2011-07-15 12:24

Added patch fixing the agent Limit bug. It seems someone forgot to implement everything from the patch in Mantis 5437 ;)
(0018904)
justincc (administrator)
2011-07-15 18:22

Hi Michelle. Why does the patch use a configuration default of m_agentCapacity.ToString() rather than "0", like the other lines (I'm kind of assuming that 0 either means there is no limit, or that these defaults don't actually matter).

Does it make any difference to the bug if we use 0 rather than m_agentCapacity.ToString()?
(0018938)
Michelle Argus (reporter)
2011-07-16 03:16

Hmm,using "0" as default means 0 agent limit = noone may enter. This also aplys to object_capacity which would remove all prims. unless set in the xml.

I used m_agentCapacity.ToString() because that already was used in loadConfigurationOptionsFromMe() which entirely uses the default variables while loadConfigurationOptions() is mixed.

Now I am not sure, but wouldnt it be better to set the default configvariables to non "0" for all ? Also using the variables loadConfigurationOptions() in the same method as loadConfigurationOptionsFromMe() would make it easier as one would just need to change the default variables at the beginning of the file?
(0018943)
Michelle Argus (reporter)
2011-07-16 04:15

Btw, why do we need loadConfigurationOptionsFromMe() and loadConfigurationOptions() do the identical job?
(0019005)
Michelle Argus (reporter)
2011-07-20 02:54

Added a new Patch which replaces patch 001.

 The new Patch does not use m_agentCapacity.ToString(). I also changed the default value for object_capacity to 15000 as 0 by default means the region could return all prims when not specifyed in the xml.
(0019006)
melanie (administrator)
2011-07-20 03:35

That code is already in core.

commit 44e43d9d240735695668849fbd7aaafd339f262d
Author: E. Allen Soard <allensoard@yahoo.com>
Date: Fri Apr 15 06:17:26 2011 -0700

added it.
(0019007)
melanie (administrator)
2011-07-20 03:37

Proposed code is already in trunk.
(0019022)
justincc (administrator)
2011-07-20 18:52

As far as I can see this isn't the case - this is a slightly different area of the code.
(0019027)
Michelle Argus (reporter)
2011-07-21 14:15

thx justin, I allready thought I didnt find the right url for the trunk version, hehe

- Issue History
Date Modified Username Field Change
2011-05-10 10:49 Michelle Argus New Issue
2011-05-10 10:49 Michelle Argus Git Revision => d4fcba08af080bcc60da490155cc88d3f20e7dda
2011-05-10 10:49 Michelle Argus SVN Revision => r/15447
2011-05-10 10:49 Michelle Argus Run Mode => Grid (1 Region per Sim) , Grid (Multiple Regions per Sim)
2011-05-10 10:49 Michelle Argus Physics Engine => BasicPhysics
2011-05-10 10:49 Michelle Argus Environment => Mono / Linux32
2011-05-10 10:49 Michelle Argus Mono Version => 2.6.3
2011-05-10 10:49 Michelle Argus Viewer => imprudence
2011-05-13 10:24 Michelle Argus Note Added: 0018411
2011-05-13 10:24 Michelle Argus Note Edited: 0018411
2011-07-15 12:23 Michelle Argus File Added: 001-Bugfix_Agentlimit.txt
2011-07-15 12:24 Michelle Argus Note Added: 0018883
2011-07-15 12:24 Michelle Argus Status new => patch included
2011-07-15 12:33 Michelle Argus Relationship added related to 0005437
2011-07-15 18:22 justincc Note Added: 0018904
2011-07-15 18:22 justincc Status patch included => patch feedback
2011-07-16 03:16 Michelle Argus Note Added: 0018938
2011-07-16 04:15 Michelle Argus Note Added: 0018943
2011-07-20 02:50 Michelle Argus File Added: 002-Bugfix_Agentlimit.txt
2011-07-20 02:54 Michelle Argus Note Added: 0019005
2011-07-20 03:35 melanie Note Added: 0019006
2011-07-20 03:37 melanie Status patch feedback => resolved
2011-07-20 03:37 melanie Resolution open => no change required
2011-07-20 03:37 melanie Assigned To => melanie
2011-07-20 03:37 melanie Note Added: 0019007
2011-07-20 18:52 justincc Status resolved => feedback
2011-07-20 18:52 justincc Resolution no change required => reopened
2011-07-20 18:52 justincc Note Added: 0019022
2011-07-21 14:15 Michelle Argus Note Added: 0019027
2011-07-22 04:42 melanie Status feedback => resolved
2011-07-22 04:42 melanie Resolution reopened => fixed
2014-07-29 13:39 chi11ken Status resolved => closed


Copyright © 2000 - 2012 MantisBT Group
Powered by Mantis Bugtracker