Mantis Bug Tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0005431opensim[GRID] Hypergridpublic2011-04-06 21:452011-04-18 16:28
Reporternebadon 
Assigned ToDiva 
PrioritynormalSeverityminorReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version 
Target VersionFixed in Version 
Summary0005431: Can not take coalesced objects when hypergrid is enabled.
Descriptionunable to take a coalesced objects into ones inventory when Hypergrid is enabled in OpenSim.ini you can however rez these items if taken from a different region.
Additional InformationConfirmed with opensim-tree-8b4e347 - nixnerd - Standalone/Hypergrid - One Region - MySQL - Mono/Linux32 - ODE - Mono 2.4.4 - Imprudence 1.4.0 Experimental 2010.11.13
TagsNo tags attached.
Git Revision or version numberadb14ad20acce44cb4b269b0d518b210f9f5eae4
Run Mode Grid (1 Region per Sim) , Grid (Multiple Regions per Sim)
Physics EngineODE
EnvironmentMono / Linux32, Mono / Linux64, Mono / Windows, Mono / OSX, .NET / Windows32, .NET / Windows64
Mono Version2.8
Viewer
Attached Files

- Relationships

-  Notes
(0018242)
justincc (administrator)
2011-04-11 14:19
edited on: 2011-04-11 14:20

I see issues with IAR save/load as well (and probably OAR too since you can get coalesced objects within other objects).

This might be something to do with those assets not being properly analyzed by the UuidGatherer, since the XML is different.

Off the top of my head, it might be better to get the UUID gatherer to identify the object type from the asset data rather than pass in inventory flags or flag. Not sure, though.

(0018289)
Diva (administrator)
2011-04-15 17:13

[16:43] <CIA-38> opensim: diva * rcd6dce11086a /OpenSim/Region/CoreModules/Framework/InventoryAccess/ (HGInventoryAccessModule.cs InventoryAccessModule.cs): Fixes mantis 0005431 -- coalesced objects in HG-enabled regions. Needs more testing to make sure HG inventory isn't broken by this (it shouldn't).
(0018300)
nebadon (administrator)
2011-04-18 16:28

fixed.

- Issue History
Date Modified Username Field Change
2011-04-06 21:45 nebadon New Issue
2011-04-06 21:45 nebadon Git Revision => adb14ad20acce44cb4b269b0d518b210f9f5eae4
2011-04-06 21:45 nebadon SVN Revision => 0
2011-04-06 21:45 nebadon Run Mode => Grid (1 Region per Sim) , Grid (Multiple Regions per Sim)
2011-04-06 21:45 nebadon Physics Engine => ODE
2011-04-06 21:45 nebadon Environment => Mono / Linux32, Mono / Linux64, Mono / Windows, Mono / OSX, .NET / Windows32, .NET / Windows64
2011-04-06 21:45 nebadon Mono Version => 2.8
2011-04-08 10:19 nixnerd Status new => confirmed
2011-04-08 10:19 nixnerd Additional Information Updated
2011-04-11 14:19 justincc Note Added: 0018242
2011-04-11 14:20 justincc Note Edited: 0018242
2011-04-15 17:13 Diva Note Added: 0018289
2011-04-18 14:04 Diva Status confirmed => resolved
2011-04-18 14:04 Diva Resolution open => fixed
2011-04-18 14:04 Diva Assigned To => Diva
2011-04-18 16:28 nebadon Status resolved => closed
2011-04-18 16:28 nebadon Note Added: 0018300


Copyright © 2000 - 2012 MantisBT Group
Powered by Mantis Bugtracker