Mantis Bug Tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0005416opensim[REGION] OpenSim Corepublic2011-03-18 17:302012-02-10 13:42
ReporterBruce 
Assigned ToBlueWall 
PrioritynormalSeverityminorReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Versionmaster (dev code) 
Target VersionFixed in Versionmaster (dev code) 
Summary0005416: Issues with importing estate covenant from library
DescriptionNotecard in inventory containing covenant is overwritten with text for LLWearable version 22, New Hair, resulting in error "Covenant file format error" in viewer. It appears that the UUID of the notecard containing the covenant is replaced with a different UUID at the MySQL database level (table regionsettings, column covenant). This occurs on first run after upgrade to commit r/15021. Last commit where it works correctly is r/14979. Not tested with commits between these two versions. Tested twice with same results. The provisions of a TOS could be such as to impose that a certain text must be included in the Covenant for each region and any error in sowing the Covenant for a region should therefore not be considered as a trivial matter.
Additional InformationTo reproduce:
Create notecard with any text in it and name it Covenant
In viewer, go to World>Region/Estate
Select Covenant tab and drag notecard Covenant from library into the field for Covenant
Quit viewer and region server
Backup database
Install fresh copy of r/15021 and restart region server and login

Results:
In inventory, notecard Covenant and any copy of it (i.e. having same UUID) now contains information about LLWearable version 22, New Hair. On first test the UUID of the notecard containing the covenant and the copy of that notecard was changed to a different UUID. Unable to reproduce the change in UUID at the database level after that first test but maybe others can.
TagsNo tags attached.
Git Revision or version numberf4a30f3a234e8fbc946bf3fd5a1f96a39d9e79ea
Run Mode Standalone (Multiple Regions)
Physics EngineODE
Environment.NET / Windows32
Mono Version2.10
ViewerImprudence 1.3.0
Attached Fileslog file icon OpenSim.log [^] (154,113 bytes) 2011-04-09 12:04

- Relationships
duplicate of 0002208closedSnoopy Covenant File Format Error 

-  Notes
(0018144)
BlueWall (administrator)
2011-03-18 17:54

see: http://opensimulator.org/mantis/view.php?id=3047 [^]
(0018145)
Bruce (reporter)
2011-03-18 17:55

Addendum:
UUID for notecard with covenant was 0930c80b-40dc-40d3-bdad-a3be43570d4c but after a relog and a check of the regionsettings table the UUID for covenant was changed to f39fdda5-faf8-4cd1-94b6-4e1f7e271a7c for 5 of the 6 regions running on the same simulator. The one region for which it was not changed is the default region. There is no assetID in the inventoryitems table for UUID f39fdda5-faf8-4cd1-94b6-4e1f7e271a7c or in any other database table.
(0018146)
Bruce (reporter)
2011-03-18 18:04

Sorry Blue, I thought mantis 3047 was resolved since the error did no longer occur with commits post 0.7.0.2.
(0018147)
BlueWall (administrator)
2011-03-18 18:05

it's ok, it was closed ages ago. It's an old bug with history. Need to figure out a way to trap it :)
(0018148)
Bruce (reporter)
2011-03-18 18:28

Reverted to r/14979 of 05 Mar 11. Logged in and out 5 times with same viewer as before (Imprudence 1.3.0). Checked database each time. Error reported in mantises 3047 and 5416 is no present. One of the commits after r/14979 must have reintroduced that error (could be one of the merge branch commits).
(0018149)
Bruce (reporter)
2011-03-18 18:48

What could generate an UUID of f39fdda5-faf8-4cd1-94b6-4e1f7e271a7c ? It's not present in the database before or after the error occurs. And from where is the text for the LLWearable version 22, New Hair, originating since there is no such thing in the library (including the OpenSim Library) or database ? If this was a viewer issue, then the error would occur with r/14979 too, no ? It could also be an error which only affects the standalone architecture and not ROBUST. Hence no one in grid mode reporting this issue as yet.
(0018177)
Bruce (reporter)
2011-03-27 09:10

This mantis can be closed. Can no longer reproduce this error with r/15066 of 26 Mar 11 and Imprudence 1.3.0
(0018220)
slow putzo (reporter)
2011-04-08 17:50

Not true, if anyone was reviewing mantis they would see I reported this problem on Feb 17, 2011 as Mantis 0005390. The bug is certainly still there and has been for a long time. It fails for me without much difficulty and likes to pick on just one of my 64 regions over and over again.

I suspect it is something to do with the actual hair item that maybe one of the ladies who visits my regions has.

I do not run standalone, but rather have been on the grid for over a year now.

The region that fails is "Sunrise Estates" and it runs on a simulator with a couple of other regions.

If I had any ideas what was needed to find a solution, I would be more than happy to work on trying to capture whatever was needed.

Slow Putzo
(0018227)
Snoopy (administrator)
2011-04-09 00:12

This bug even exists since before September 2008.
(0018228)
Bruce (reporter)
2011-04-09 09:47

This bug reappeared on first run after upgrading to r/15130 (this and my previous reports are for HG standalone architecture). Once a new notecard is made which contains the covenant text it seems to persist on next logins. However, UUID for the new covenant notecard was manually inserted for each region in the regionsettings table of the MySql database, so perhaps this is why it is persistent now (easy to do when you only have 6 regions and each is using the same covenant). The viewer cache was cleared after installing r/15130 and before first login (Imprudence 1.3.1). The viewer cache was not cleared after installing previous commits (r/15066 and r/15122) and the bug was not present on first login after installation of these commits and the UUID for the notecard was not changed in the database. Perhaps this should be tested with different viewers and see if the bug can be reproduced with clear and not clear viewer cache after a new commit install.
(0018229)
slow putzo (reporter)
2011-04-09 09:59
edited on: 2011-04-09 10:06

In an effort to find a way to positivly cause this problem to happen in the hopes the developers can recreate it I am concentrating on a specific way to recreate it.

Yesterday April 8, 2011 I placed a convenant in each of my regions. I then verified that each was correct and logged off.

Today I logged in to my own residential region "Sanctuary" and noticed that when I arrived, I was missing my hair. I did a rebake and once my hair appeared, I checked my covenant. It was trashed with the "hair" xml information.

I verified that no one had visited my region since I left yesterday and they had not. I also verified my instance had not done any restart which it had not.

The hair I am wearing is "Cody's biker black hair" however it feel it has nothing at all to do with this problem because none of the UUID's match with his ID or that of the hair.

I have done the following.

- I am now going bald.
- I restored the covenant and verified it is correct.

I'm going to scan through the log file to see if I can spot anything at all that might suggest when and how this happened.

Looking in the mysql database I do not see a way to spot if this problem has stgruck because I only see the uuid listed for the NC with the covenant in the DB.

Any suggestions on how to verify the covenant is correct prior to me logging in would be appreciated.

Since this region was not restarted, I believe that is nothing more than a coincidence in past reports.

To be clear, I am running in grid mode, the instance I am concentrating on runs 4 regions. I check all of my regions now to see if the covenant has been trashed, but today only this one was trashed. The fastest way for me to verify that I know of at present is to simply look at each note card.

My next step today will be to review the log for "Sanctuary" and then visit each of my regions to see if just visiting them causes the problem.

I will keep my avatar without hair to see if it has any affect at all. I suspect it does not.

I am not sure which of the many mantis reports I should use as the "real" problem report. If a developer has a preference to one of them, I will report all of my recreation findings in that one mantis report.

I do not expect this to be a very fast diagnostic approach given how long this bug has been in the code, and how many people have tried to find a way to recreate it for a developer.

I may fail too, but it is worth a try.

(0018230)
Bruce (reporter)
2011-04-09 10:25

I found the New Hair data which is inserted in the covenant notecard as reported by slow putzo (see mantises 2208 , 2879, etc.) in ..bin\assets\BodyPartsAssetSet\newhair.dat
(0018231)
slow putzo (reporter)
2011-04-09 10:26
edited on: 2011-04-09 10:29

More information.

I just corrected the covenant for Sanctuary minutes ago. Verified it was fine which it was.

I then logged off.

That was on my laptop which is Windows 7 and Imprudence 1.3.1

I then logged in with my desktop and the covenant for Sanctuary is once again trashed.

Here is what Improudence reports as this machine runs Windows XP Professional.

Imprudence 1.3.1 (Feb 24 2011 23:46:21)
Release Notes

Grid: (osgrid)

Built with MSVC version 1400

You are at 2573864.8, 2556476.4, 22.2 in Sanctuary located at cpe-173-170-147-227.tampabay.res.rr.com (173.170.147.227:9137)
OpenSim 0.7.1 Dev OSgrid 0.7.1 (Dev) abea0c7: 2011-04-07 (Unix/Mono)
Release Notes

CPU: AMD (Unknown model) (3214 MHz)
Memory: 3326 MB
OS Version: Microsoft Windows XP Service Pack 3 (Build 2600)
Graphics Card Vendor: ATI Technologies Inc.
Graphics Card: ATI Radeon HD 4250
Windows Graphics Driver Version: 8.723-100406a-098765C-ATI
OpenGL Version: 3.2.9756 Compatibility Profile Context

libcurl Version: libcurl/7.18.1 OpenSSL/0.9.8j zlib/1.2.3
J2C Decoder Version: OpenJPEG: 1.4.0.565, Runtime: 1.4.0.565
Audio Driver Version: OpenAL, version 1.1 ALSOFT 1.12.854 / OpenAL Community / OpenAL Soft: DirectSound Software
GStreamer Version: 0.10.20.1
LLMozLib Version: [LLMediaImplLLMozLib] - 2.01.40579 (Mozilla GRE version 1.8.1.21_0000000000)
Packets Lost: 0/10998 (0.0%)


A check of the log file does not show anything at all that might be helpful. I see where I logged off and then where I logged back on and there is nothing between there to give any suggestions at all.

It was suggested I turn on debug, if that will help, I will do that.

First I want to see if I can force this to fail. If I can, then I will clear the log, force the failure with debug on, and attach that log to this mantis.

(0018232)
slow putzo (reporter)
2011-04-09 10:49

reporting the following:

- standing on "Sanctuary"
- logged off
- logged back on to "Sanctuary"
- covenant is ok
- checked NC for "Treasure Bay" (different server completely)
- NC is fine
- teleported to "Treasure bay"
- covenant trashed, NC replaced with "hair" information
- restored NC with correct information
- verified covenant looked ok
- TP'ed back to "Sanctuary" and logged off
- logged back on at "Sanctuary"
- covenant at "Sanctuary" is ok, NC for "Treasure Bay" is ok
- TP'ed to "treasure Bay" covenant and NC still fine
- logged off while standing at "treasure Bay"
- logged in using laptop (different computer) to "Sanctuary" covenant and NC now trashed again.
 it looks like I can recreate this bug at will by flipflopping between computers for login.


I'll do more login testing to be sure.
(0018233)
Bruce (reporter)
2011-04-09 11:07

Problem reappeared after a new login on same machine (previous logins did not trigger the bug). UUID for notecard was changed in the database for the default region (other 5 regions were fine). Removed newhair. dat from bin\assets\BodyPartsAssetSet\ will see what happens on next login.

Imprudence 1.3.1 (Feb 24 2011 21:23:31)
Release Notes
Grid: (itimotu)
Built with GCC version 40001
You are at 2304395.8, 2304150.0, 21.6 in Motu Aruo located at ip-208-109-168-104.ip.secureserver.net (208.109.168.104:9034)
OpenSim 0.7.1 Dev r15130 (08-Apr-11) (Win/.NET)
Release Notes
CPU: Dual i386 (Unknown) (2400 MHz)
Memory: 4096 MB
OS Version: Darwin 10.7.0 Darwin Kernel Version 10.7.0: Sat Jan 29 15:17:16 PST 2011; root:xnu-1504.9.37~1/RELEASE_I386 i386
Graphics Card Vendor: ATI Technologies Inc.
Graphics Card: ATI Radeon HD 2600 PRO OpenGL Engine
OpenGL Version: 2.1 ATI-1.6.26
libcurl Version: libcurl/7.19.7 OpenSSL/0.9.8l zlib/1.2.3
J2C Decoder Version: OpenJPEG: 1.4.0.565, Runtime: 1.4.0.565
Audio Driver Version: OpenAL, version 1.1 / Apple Computer Inc. / Software: Built-in Output
GStreamer Version: 0.10.22.0
LLMozLib Version: [LLMediaImplLLMozLib] - 2.01.40580 (Mozilla GRE version 1.8.1.21_0000000000)
Packets Lost: 18/15829 (0.1%)
(0018234)
Bruce (reporter)
2011-04-09 11:36

Logged-in several times without clearing viewer cache and covenant notecard was fine. Then cleared viewer cache and logged-in. Covenant card was overwritten with the New Hair data despite the fact that newhair.dat had been removed from bin\assets\BodyPartsAssetSet\
(0018235)
slow putzo (reporter)
2011-04-09 12:07

I uploaded the log file that captured the failure. Well lets say the debug pparameter was turned on, I tp'ed to the region which was fine before I TP'ed viewed the covenant which was trashed, logged off and closed down the instance and sent the log file.

I can make this fail every time by simply setting a covenant, then logging in first from one computer and then another. As soon as I log in from the computer I did not create the covenant from it gets trashed.

Nothing else changes that I can see. I log in from different computers frequently and none of my regions have had a problem other than this covenant problem.

- Issue History
Date Modified Username Field Change
2011-03-18 17:30 Bruce New Issue
2011-03-18 17:30 Bruce Git Revision => f4a30f3a234e8fbc946bf3fd5a1f96a39d9e79ea
2011-03-18 17:30 Bruce SVN Revision => r/15021
2011-03-18 17:30 Bruce Run Mode => Standalone (Multiple Regions)
2011-03-18 17:30 Bruce Physics Engine => ODE
2011-03-18 17:30 Bruce Environment => .NET / Windows32
2011-03-18 17:30 Bruce Mono Version => None
2011-03-18 17:30 Bruce Viewer => Imprudence 1.3.0
2011-03-18 17:54 BlueWall Note Added: 0018144
2011-03-18 17:55 Bruce Note Added: 0018145
2011-03-18 18:04 Bruce Note Added: 0018146
2011-03-18 18:05 BlueWall Note Added: 0018147
2011-03-18 18:28 Bruce Note Added: 0018148
2011-03-18 18:48 Bruce Note Added: 0018149
2011-03-19 10:04 Snoopy Relationship added duplicate of 0002208
2011-03-27 09:10 Bruce Note Added: 0018177
2011-04-08 17:50 slow putzo Note Added: 0018220
2011-04-09 00:12 Snoopy Note Added: 0018227
2011-04-09 09:47 Bruce Note Added: 0018228
2011-04-09 09:59 slow putzo Note Added: 0018229
2011-04-09 10:06 slow putzo Note Edited: 0018229
2011-04-09 10:25 Bruce Note Added: 0018230
2011-04-09 10:26 slow putzo Note Added: 0018231
2011-04-09 10:29 slow putzo Note Edited: 0018231
2011-04-09 10:49 slow putzo Note Added: 0018232
2011-04-09 11:07 Bruce Note Added: 0018233
2011-04-09 11:36 Bruce Note Added: 0018234
2011-04-09 12:04 slow putzo File Added: OpenSim.log
2011-04-09 12:07 slow putzo Note Added: 0018235
2012-02-10 13:42 BlueWall Mono Version None => 2.10
2012-02-10 13:42 BlueWall Status new => resolved
2012-02-10 13:42 BlueWall Fixed in Version => master (dev code)
2012-02-10 13:42 BlueWall Resolution open => fixed
2012-02-10 13:42 BlueWall Assigned To => BlueWall
2012-02-10 13:42 BlueWall Status resolved => closed


Copyright © 2000 - 2012 MantisBT Group
Powered by Mantis Bugtracker