Mantis Bug Tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0005413opensim[GRID] Hypergridpublic2011-03-18 08:432011-05-06 18:52
Reporternebadon 
Assigned ToDiva 
PrioritynormalSeverityblockReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version 
Target VersionFixed in Version 
Summary0005413: Autogenerated Hypergrid Hyperlinks inside a grid causing teleport and map issues.
DescriptionAuto-Generated Hypergrid Hyperlinks created inside of OSgrid to regions that reside inside of OSgrid are causing teleport failures and map search failures.

Example
On Lbsa plaza someone brings up the map and searchs for hg.osgrid.org:80:Wright Plaza it will automatically create a Hyperlink called "Wright Plaza" this of course is a problem because the region Wright Plaza already exists in the same grid. This causes teleport failures and map search failures until the Sim is either A) restarted or B) the hyperlink is manually removed, this is causing a lot of problems on the OSgrid Plazas and its users hosted regions.

I suggest that auto generated hyperlinks be disabled completely in Grids
TagsNo tags attached.
Git Revision or version numberANY
Run Mode Grid (1 Region per Sim)
Physics EngineBasicPhysics, PhysicsOfSimplicity, ODE, BulletX, PhysX, Other
EnvironmentMono / Linux32, Mono / Linux64, Mono / Windows, Mono / OSX, .NET / Windows32, .NET / Windows64
Mono Version2.6.3
Viewer
Attached Files

- Relationships

-  Notes
(0018186)
Diva (administrator)
2011-03-28 16:49

[16:48] <CIA-38> opensim: diva * r2d209d3844a5 / (4 files in 3 dirs):
[16:48] <CIA-38> opensim: Fix mantis 0005413. WARNING: new config variable in section [GridService] of the
[16:48] <CIA-38> opensim: simulators called Gatekeeper -- intended to have the URL of the grid's
[16:48] <CIA-38> opensim: Gatekeeper service (so that it can be checked against). See ini.examples.
(0018187)
nebadon (administrator)
2011-03-28 17:51

r2d209d3844a5 does not fix this problem.
(0018188)
nebadon (administrator)
2011-03-28 18:16
edited on: 2011-03-28 18:17

ok I was wrong.. i was only using http://hg.osgrid.org [^] as the URL, but it appears i actually have to include the port to make this work ie: http://hg.osgrid.org:80 [^]
it is confusing because we do not normally use ports in our GridCommon.ini for OSgrid.

(0018189)
nebadon (administrator)
2011-03-28 18:21

seems fixed

- Issue History
Date Modified Username Field Change
2011-03-18 08:43 nebadon New Issue
2011-03-18 08:43 nebadon Git Revision => ANY
2011-03-18 08:43 nebadon SVN Revision => 0
2011-03-18 08:43 nebadon Run Mode => Grid (1 Region per Sim)
2011-03-18 08:43 nebadon Physics Engine => BasicPhysics, PhysicsOfSimplicity, ODE, BulletX, PhysX, Other
2011-03-18 08:43 nebadon Environment => Mono / Linux32, Mono / Linux64, Mono / Windows, Mono / OSX, .NET / Windows32, .NET / Windows64
2011-03-18 08:43 nebadon Mono Version => 2.6.3
2011-03-28 15:25 Diva Status new => assigned
2011-03-28 15:25 Diva Assigned To => Diva
2011-03-28 16:49 Diva Note Added: 0018186
2011-03-28 17:51 nebadon Note Added: 0018187
2011-03-28 18:16 nebadon Note Added: 0018188
2011-03-28 18:17 nebadon Note Edited: 0018188
2011-03-28 18:21 nebadon Status assigned => resolved
2011-03-28 18:21 nebadon Resolution open => fixed
2011-03-28 18:21 nebadon Note Added: 0018189
2011-05-06 18:52 chi11ken Status resolved => closed


Copyright © 2000 - 2012 MantisBT Group
Powered by Mantis Bugtracker