Mantis Bug Tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0005352opensim[REGION] Script Functionspublic2011-01-30 03:052011-10-26 07:52
ReporterMichelle Argus 
Assigned ToBlueWall 
PrioritynormalSeverityfeatureReproducibilityN/A
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version 
Target VersionFixed in Version 
Summary0005352: New Permissions for OSSLfunctions
DescriptionIn Mantis 5232 shangcheng has the problem, that osTeleportAgent is restricted to parcelowners. Similar problems always occure in the ossl functions that have the permission restrictions hardcoded into the function.

 Currently we only can set via the ini if anyone can use a function, or a avatar with a given uuid, however still limited to the other permissions given by the function itself. A more flexible way would be, to add the posibility to limit it further in the ini settings instead of the hardcoded method like in osTeleportAgent.

Limitations could be
PARCEL_OWNER - Parcelowners can use the ossl function
PARCEL_GROUP_MEMBER - Groupmembers of Parcelcan use the function
ESTATE_OWNER - Regionowners can use the ossl's
ESTATE_MANAGER - Estatemanagers and Regionowners are allowed

One could use these permissions in all current and future ossl functions. It would be more flexible and would not need a new ossl function to be introduced just because someone needs it with a diffrent limitation (as in Mantis 5232 suggested).

Futher advantage is, that for reagions with a higher fluctuation in parcelowners/regionowners one does not need to change the avatar uuids ini the ini, instead one limits it to a specific group of avatars e.g. the regionowners.

TagsNo tags attached.
Git Revision or version numberany
Run ModeStandalone (1 Region) , Standalone (Multiple Regions) , Grid (1 Region per Sim) , Grid (Multiple Regions per Sim)
Physics EngineBasicPhysics
EnvironmentUnknown, Mono / Linux32, Mono / Linux64, Mono / Windows, Mono / OSX
Mono VersionNone
Viewer
Attached Filestxt file icon 001-Added-optional-ownergroups-to-existing-OSSL-agent-Permissions.txt [^] (7,215 bytes) 2011-09-24 06:14 [Show Content]
txt file icon 002-Added-optional-owner classes-to-existing-OSSL-agent-Permissions.txt [^] (8,056 bytes) 2011-10-01 06:26 [Show Content]
txt file icon 003-Added-optional-owner classes-to-existing-OSSL-agent-Permissions.txt [^] (8,061 bytes) 2011-10-23 07:45 [Show Content]
patch file icon 004-Added-optional-owner classes-to-existing-OSSL-agent-Permissions.patch [^] (8,030 bytes) 2011-10-26 07:06 [Show Content]

- Relationships
related to 0005232closedjustincc osTeleportAgent is still not working 
child of 0003986closed [OSSL] 

-  Notes
(0020028)
Michelle Argus (reporter)
2011-09-24 06:18
edited on: 2011-09-24 06:32

Added new permission options to ossl function.

 When limiting OSSL functions to Agent one can now also use PARCEL_GROUP_MEMBER, PARCEL_OWNER, ESTATE_MANAGER and ESTATE_OWNER to limit the use to the object owners of those ownergroups. It can be used in combination with agent uuids.

eg.
Allow_osRegionNotice = <uuid>, <uuid>, PARCEL_OWNER, ESTATE_OWNER

(0020069)
justincc (administrator)
2011-09-30 16:05

Hi Michelle. I like this functionality. However, could you make sure the patch contains a valid e-mail address in the From field? Git refuses to apply without it.

I think the information about these settings should be in OpenSim.ini.example rather than just OpenSimDefaults.ini. I moved the existing stuff in 844b4f3 so in your new patch please could you add it there?

Also,

; Comma separated list of UUIDS and ownergroup allows the function for that list of UUIDS or ownergroup
; ownergroup = PARCEL_GROUP_MEMBER,PARCEL_OWNER,ESTATE_MANAGER,ESTATE_OWNER.
; Allow_osSetRegionWaterHeight = 888760cb-a3cf-43ac-8ea4-8732fd3ee2bb

is messy. Please could the ownergroup be on separate lines instead, such as

; Comma separated list of owner classes that allow the function for a particular class of owners. Choices are
; PARCEL_GROUP_MEMBER, PARCEL_OWNER, ESTATE_MANAGER, ESTATE_OWNER
; Allow_osSetRegionWaterHeight = PARCEL_GROUP_MEMBER, PARCEL_OWNER, ESTATE_MANAGER, ESTATE_OWNER

I'd like to see individual explanations of each of the owner class types.

From this, you can also probably tell that I prefer "owner classes" to "ownergroup", which is too much like the other kind of group for me. But I'll be able to think more about this once we have a patch that applies in git.

(0020082)
Michelle Argus (reporter)
2011-10-01 06:35

ok, added new patch 002 replacing 001 and using 844b4f3...

- changed owner group to owner class
- added info to opensim.ini.example aswell
- added short explanations to each owner class

NB: Some of the individual classes already exist in LSL as constants, so i reused them e.g. PARCEL_OWNER as these might be known to the regionhosters already ;)

NB2: One could also implement this to creators with the exeption of the group class
(0020168)
justincc (administrator)
2011-10-18 17:17

Thanks Michelle. Sorry - not ignoring this patch, just keep running out of time to look at it (since it is a little more complicated than others). Hope to get round to it soon!
(0020169)
justincc (administrator)
2011-10-18 17:18

That goes for your other patches too.
(0020170)
smxy (reporter)
2011-10-18 20:46

Just wanted to thank you for all your patches, Michelle. Each makes my grid just a little bit better, and is appreciated. :)
(0020178)
justincc (administrator)
2011-10-21 15:18

Hi Michelle. Latest patch does not compile

                  [csc] /home/justincc/jc/it/v/virtual-environments/specific/second-life/servers/opensim/src/opensim-git/OpenSim/Region/ScriptEngine/Shared/Api/Implementation/OSSL_Api.cs(275,38): error CS0103: The name `AllowedOwnerClasses' does not exist in the current context
(0020228)
Michelle Argus (reporter)
2011-10-23 07:46

I missed a "perm."^^
(0020253)
BlueWall (administrator)
2011-10-26 06:09

003-Added-optional-owner classes-to-existing-OSSL-agent-Permissions.txt doesn't build:

Errors:

/home/opensim/src/OpenSim/OpenSim.sln (default targets) ->
(Build target) ->
/home/opensim/src/OpenSim/OpenSim/Region/ScriptEngine/Shared/Api/Implementation/OpenSim.Region.ScriptEngine.Shared.Api.csproj (default targets) ->
/usr/lib/mono/3.5/Microsoft.CSharp.targets (CoreCompile target) ->

    OSSL_Api.cs(275,38): error CS0103: The name `perm' does not exist in the current context

also, something is up with your patch format for `git am` it says that the email is not valid. I applied the patches with `patch`.
(0020254)
Michelle Argus (reporter)
2011-10-26 07:07

Did the changes on a newer version... build successfull again... and wrote the patch from scratch again.

 Hope 004 finaly works^^
(0020256)
BlueWall (administrator)
2011-10-26 07:52

Applied: 41395d544386fbee2d26909a590d4fa9720fdf5f

Thanks Michelle!

- Issue History
Date Modified Username Field Change
2011-01-30 03:05 Michelle Argus New Issue
2011-01-30 03:05 Michelle Argus Git Revision => any
2011-01-30 03:05 Michelle Argus SVN Revision => 0
2011-01-30 03:05 Michelle Argus Run Mode => Standalone (1 Region) , Standalone (Multiple Regions) , Grid (1 Region per Sim) , Grid (Multiple Regions per Sim)
2011-01-30 03:05 Michelle Argus Physics Engine => BasicPhysics
2011-01-30 03:05 Michelle Argus Environment => Unknown, Mono / Linux32, Mono / Linux64, Mono / Windows, Mono / OSX
2011-01-30 03:05 Michelle Argus Mono Version => None
2011-06-15 06:20 Michelle Argus Relationship added child of 0003986
2011-07-20 16:33 justincc Relationship added related to 0005232
2011-09-24 06:14 Michelle Argus File Added: 001-Added-optional-ownergroups-to-existing-OSSL-agent-Permissions.txt
2011-09-24 06:18 Michelle Argus Note Added: 0020028
2011-09-24 06:18 Michelle Argus Status new => patch included
2011-09-24 06:32 Michelle Argus Note Edited: 0020028
2011-09-24 06:32 Michelle Argus Note Edited: 0020028
2011-09-30 16:05 justincc Note Added: 0020069
2011-09-30 16:05 justincc Status patch included => patch feedback
2011-10-01 06:26 Michelle Argus File Added: 002-Added-optional-owner classes-to-existing-OSSL-agent-Permissions.txt
2011-10-01 06:35 Michelle Argus Note Added: 0020082
2011-10-18 17:17 justincc Note Added: 0020168
2011-10-18 17:18 justincc Note Added: 0020169
2011-10-18 20:46 smxy Note Added: 0020170
2011-10-21 15:18 justincc Note Added: 0020178
2011-10-23 07:45 Michelle Argus File Added: 003-Added-optional-owner classes-to-existing-OSSL-agent-Permissions.txt
2011-10-23 07:46 Michelle Argus Note Added: 0020228
2011-10-26 06:09 BlueWall Note Added: 0020253
2011-10-26 07:06 Michelle Argus File Added: 004-Added-optional-owner classes-to-existing-OSSL-agent-Permissions.patch
2011-10-26 07:07 Michelle Argus Note Added: 0020254
2011-10-26 07:52 BlueWall Status patch feedback => resolved
2011-10-26 07:52 BlueWall Resolution open => fixed
2011-10-26 07:52 BlueWall Assigned To => BlueWall
2011-10-26 07:52 BlueWall Note Added: 0020256
2011-10-26 07:52 BlueWall Status resolved => closed


Copyright © 2000 - 2012 MantisBT Group
Powered by Mantis Bugtracker