Mantis Bug Tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0005302opensim[REGION] OpenSim Corepublic2011-01-05 06:532011-04-28 11:14
ReporterConnorBaily 
Assigned ToConnorBaily 
PrioritynormalSeveritycrashReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version 
Target VersionFixed in Version 
Summary0005302: 0.7.0.2 Crashes every time after answering estate question
DescriptionNote: New database created and fresh install. Running on Windows 7 32bit.

After answering the following questions it crashes:

We are now going to ask a couple of questions about your region.

You can press 'enter' without typing anything to use the default

the default is displayed between [ ]: brackets.
=====================================

New region name []: Sandbox
Region UUID [b88fe3cd-37ac-4546-96a9-ae4576ef9900]:
Region Location [1000,1000]:
Internal IP address [0.0.0.0]:
Internal port [9000]:
Allow alternate ports [False]:
External host name [SYSTEMIP]:
14:33:56 - [REGIONINFO]: Resolving SYSTEMIP to 192.168.0.2 for external hostname of region Sandbox
14:33:56 - [REGIONINFO]: Resolving SYSTEMIP to 192.168.0.2 for external hostname of region Sandbox
14:33:56 - [LOADREGIONSPLUGIN]: Loading specific shared modules...
14:33:56 - [LOADREGIONSPLUGIN]: DynamicTextureModule...
14:33:56 - [LOADREGIONSPLUGIN]: LoadImageURLModule...
14:33:56 - [LOADREGIONSPLUGIN]: XMLRPCModule...
14:33:56 - [LOADREGIONSPLUGIN]: AssetTransactionModule...
14:33:56 - [LOADREGIONSPLUGIN]: Done.
14:33:56 - [LOADREGIONS]: Creating Region: Sandbox (ThreadID: 1)
14:33:56 - [LLUDPSERVER]: Average Environment.TickCount resolution: 15.6ms
Your region is not part of an estate.
Do you wish to join an existing estate? [no]: no
Additional InformationError message:

Unhandled Exception: MySql.Data.MySqlClient.MySqlException: Invalid attempt to access a field before calling Read()
   at MySql.Data.MySqlClient.MySqlDataReader.GetFieldValue(Int32 index, Boolean checkNull)
   at MySql.Data.MySqlClient.MySqlDataReader.GetValue(Int32 i)
   at MySql.Data.MySqlClient.MySqlDataReader.get_Item(Int32 i)
   at MySql.Data.MySqlClient.MySqlDataReader.get_Item(String name)
   at OpenSim.Data.MySQL.MySQLEstateStore.DoLoad(MySqlCommand cmd, UUID regionID, Boolean create)
   at OpenSim.Data.MySQL.MySQLEstateStore.LoadEstateSettings(UUID regionID, Boolean create)
   at OpenSim.Region.Framework.Scenes.Scene..ctor(RegionInfo regInfo, AgentCircuitManager authen, SceneCommunicationService sceneGridService
, StorageManager storeManager, ModuleLoader moduleLoader, Boolean dumpAssetsToFile, Boolean physicalPrim, Boolean SeeIntoRegionFromNeighbor,
 IConfigSource config, String simulatorVersion)
   at OpenSim.OpenSimBase.CreateScene(RegionInfo regionInfo, StorageManager storageManager, AgentCircuitManager circuitManager)
   at OpenSim.OpenSimBase.SetupScene(RegionInfo regionInfo, Int32 proxyOffset, IConfigSource configSource, IClientNetworkServer& clientServe
r)
   at OpenSim.OpenSimBase.CreateRegion(RegionInfo regionInfo, Boolean portadd_flag, Boolean do_post_init, IScene& mscene)
   at OpenSim.OpenSimBase.CreateRegion(RegionInfo regionInfo, Boolean portadd_flag, IScene& scene)
   at OpenSim.ApplicationPlugins.LoadRegions.LoadRegionsPlugin.PostInitialise()
   at OpenSim.OpenSimBase.StartupSpecific()
   at OpenSim.OpenSim.StartupSpecific()
   at OpenSim.Framework.Servers.BaseOpenSimServer.Startup()
   at OpenSim.Application.Main(String[] args)
TagsNo tags attached.
Git Revision or version number?
Run ModeStandalone (1 Region)
Physics EngineBasicPhysics
Script Engine
Environment.NET / Windows32
Mono VersionNone
Viewer
Attached Fileslog file icon OpenSim.log [^] (56,651 bytes) 2011-01-05 06:53
? file icon OpenSim.ini [^] (48,520 bytes) 2011-01-05 13:07
? file icon StandaloneCommon.ini [^] (4,648 bytes) 2011-01-05 13:07

- Relationships
duplicate of 0005294closedjustincc MySql exception during initial startup (after estate setup) 

-  Notes
(0018125)
nebadon (administrator)
2011-03-05 21:11

A possible solution to this problem is to change "localhost" to "127.0.0.1" in your connection string in GridCommon.ini
(0018349)
ConnorBaily (reporter)
2011-04-28 09:12

Downloaded fresh install of Opensim and installed MySQL v5.1.41. Everything working now
(0018350)
nebadon (administrator)
2011-04-28 11:14

reporter claims problem is resolved, closing ticket

- Issue History
Date Modified Username Field Change
2011-01-05 06:53 ConnorBaily New Issue
2011-01-05 06:53 ConnorBaily File Added: OpenSim.log
2011-01-05 06:53 ConnorBaily Git Revision => ?
2011-01-05 06:53 ConnorBaily SVN Revision => 0
2011-01-05 06:53 ConnorBaily Run Mode => Standalone (1 Region)
2011-01-05 06:53 ConnorBaily Physics Engine => BasicPhysics
2011-01-05 06:53 ConnorBaily Environment => .NET / Windows32
2011-01-05 06:53 ConnorBaily Mono Version => None
2011-01-05 13:06 ConnorBaily Category [GRID] User Server => [REGION] OpenSim Core
2011-01-05 13:06 ConnorBaily Summary Crash on first run => Crashes every time after answering estate question
2011-01-05 13:06 ConnorBaily Description Updated
2011-01-05 13:06 ConnorBaily Additional Information Updated
2011-01-05 13:07 ConnorBaily File Added: OpenSim.ini
2011-01-05 13:07 ConnorBaily File Added: StandaloneCommon.ini
2011-01-05 13:08 ConnorBaily Summary Crashes every time after answering estate question => 0.7.0.2 Crashes every time after answering estate question
2011-02-04 07:00 justincc Relationship added duplicate of 0005294
2011-03-05 21:11 nebadon Note Added: 0018125
2011-04-04 15:50 athap Note Added: 0018202
2011-04-04 15:50 athap Note Edited: 0018202
2011-04-04 15:51 athap Note Edited: 0018202
2011-04-04 16:15 athap Note Deleted: 0018202
2011-04-28 09:12 ConnorBaily Note Added: 0018349
2011-04-28 09:12 ConnorBaily Status new => resolved
2011-04-28 09:12 ConnorBaily Resolution open => fixed
2011-04-28 09:12 ConnorBaily Assigned To => ConnorBaily
2011-04-28 11:14 nebadon Status resolved => closed
2011-04-28 11:14 nebadon Note Added: 0018350


Copyright © 2000 - 2012 MantisBT Group
Powered by Mantis Bugtracker