Mantis Bug Tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0005276opensim[GRID] Hypergridpublic2010-12-15 07:042010-12-20 09:06
Reporteraiaustin 
Assigned To 
PrioritynormalSeverityminorReproducibilityalways
StatusnewResolutionopen 
PlatformOSOS Version
Product Versionmaster (dev code) 
Target VersionFixed in Version 
Summary0005276: Feedback on changes to Hypergrid cells in Map for Grid
DescriptionIn case its useful for debugging.. on upgrading Openvue grid on 0.7.1 dev master from r/14658 to r/14681 - which includes some changes to the handling of Hypergrid map cell images - I note these errors and reports in the OpenSim.exe console.

The 5 hyperlinked regions that I already have in the Robust.exe setup (listed in additional information below) all still show with the swirly hypergrid default image on the map.

14:53:28 - [WORLD MAP]: Remote sim does not have the stated region. Blacklisting.
14:53:28 - [WORLD MAP]: Remote sim does not have the stated region. Blacklisting.
14:53:29 - [WORLD MAP]: Remote sim does not have the stated region. Blacklisting.
14:53:50 - [WORLD MAP]: Bad send on GetMapItems Unable to connect to the remote server
14:53:50 - [WORLD MAP]: Blacklisted http://tausys.servegame.com:8002/MAP/MapItems/9917594884847872 [^]
14:54:58 - [WORLD MAP]: exception on parse of RequestMapItems reply from http://hg.osgrid.org:80/MAP/MapItems/9916495373220352: [^] Unable to cast object of type 'OpenMetaverse.StructuredData.OSD' to type 'OpenMetaverse.StructuredData.OSDMap'.
Additional InformationR.O.B.U.S.T.# show hyperlinks
Region Name
Location Region UUID
------------------------------------------------------------------------
http://grid.ansky.ca:8002/ [^]
2308864,2308096 (9019,9016) 05e47c04-6564-4f16-9c0b-5f4debfac40c

http://ucigrid03.nacs.uci.edu:9000/ [^]
2308864,2308352 (9019,9017) 5e3528e5-363b-4fc4-9135-c6184043f9a4

http://metaversesims.net:9000/ [^]
2309120,2308096 (9020,9016) 5fb88f44-a1a9-11df-981c-0800200c9a66

http://hg.osgrid.org:80 [^]
2308864,2308608 (9019,9018) 9101b44d-922c-4cc6-94b5-6d176e392dc4

http://tausys.servegame.com:8002/ [^]
2309120,2308352 (9020,9017) e3a59500-6c67-1014-9687-9333c92227a1
TagsNo tags attached.
Git Revision or version number0.7.1.dev
Run Mode Grid (Multiple Regions per Sim)
Physics EngineODE
Script Engine
Environment.NET / Windows32
Mono VersionNone
Viewer
Attached Files

- Relationships

-  Notes
(0017639)
Diva (administrator)
2010-12-19 09:55

Yes, these messages are new but they are now 'normal'.

WRT the map image you probably need to clear your viewer's cache.
(0017650)
aiaustin (developer)
2010-12-20 03:10

Thanks Diva. I cleared the cache of my viewer but the hypergrid map cells for the 4 up to date grids we are testing between UCI Grid 03, Ansky grid, etc all still show as the default swirly coloured disc image. (on r/14681).

WRT the messsages, does that include the "exception on parse of RequestMapItems reply" message. Does it indicate that the remore grid end is not up to a version that supports the facility, or some other type of problem? In other words is this a temporary issue for version mismatch or a liong term message that grid managers will see. The word "exception" being something I look for and try to resolve in testing.
(0017653)
Diva (administrator)
2010-12-20 08:25

The map image is retrieved upon linking. If you want to get another map image, you need to unlink and link again.

"Exception" is the correct behavior in this case. This is related to map items (things like the dots representing avatars); that's still not working across the HG.
(0017655)
aiaustin (developer)
2010-12-20 09:06

Okay, testing this again with r/14699 from 20-Dec-2010 installed... on a Grid setup with hyperlinks set in Robust.exe shell.

Before I start, note that there was already an image of the UCI Grid 03 region in my OpenSim install bin directory as 5e3528e5-363b-4fc4-9135-c6184043f9a4.jpg

Did unlink and a fresh link and it gave the same message as before..
[GATEKEEPER SERVICE CONNECTOR]: Failed getting/storing map image, because it is probably already in the cache

Manualluy renmovign it from bin directory has no effect after an unlink and another fresh link again. Gives same message about probably being in cache.

Logged back on via SL Viewer 1.23.5 which has had the caxche cleared in tye viewer too, and I still only get the swirly disc image for UCI Grid 03 region - and after unlinking and fresh linking another test grid (Ansky Grid) that one too.

Worth observing that regions do change a lot and some emans to refresh the map tile when it is working ought to be part of the plan if we are going to use realistic map tiles as on HG 1.0 rather than the standard swirly coloured dic we have used up to now in HG1.5.

Some relevant logs from Robust.exe console below:

R.O.B.U.S.T.# show hyperlinks
Region Name
Location Region UUID
------------------------------------------------------------------------
http://grid.ansky.ca:8002/ [^]
2308864,2308096 (9019,9016) 05e47c04-6564-4f16-9c0b-5f4debfac40c

http://ucigrid03.nacs.uci.edu:9000/ [^]
2308864,2308352 (9019,9017) 5e3528e5-363b-4fc4-9135-c6184043f9a4

http://metaversesims.net:9000/ [^]
2309120,2308096 (9020,9016) 5fb88f44-a1a9-11df-981c-0800200c9a66

http://hg.osgrid.org:80 [^]
2308864,2308608 (9019,9018) 9101b44d-922c-4cc6-94b5-6d176e392dc4

http://tausys.servegame.com:8002/ [^]
2309120,2308352 (9020,9017) e3a59500-6c67-1014-9687-9333c92227a1

R.O.B.U.S.T.# unlink-region http://ucigrid03.nacs.uci.edu:9000/ [^]
16:54:32 - [HYPERGRID LINKER]: Request to unlink http://ucigrid03.nacs.uci.edu:9000/ [^]
Successfully unlinked http://ucigrid03.nacs.uci.edu:9000/ [^]
R.O.B.U.S.T.# link-region 9019 9017 http://ucigrid03.nacs.uci.edu:9000/ [^]
16:54:48 - [HYPERGRID LINKER]: Link to http://ucigrid03.nacs.uci.edu:9000/:, [^] in 9019-9017
16:54:48 - [GATEKEEPER SERVICE CONNECTOR]: Linking to http://ucigrid03.nacs.uci.edu:9000/ [^]
16:54:49 - [GRID SERVICE]: Hyperlinks returned 4 regions
16:54:49 - [HYPERGRID LINKER]: naming linked region http://ucigrid03.nacs.uci.edu:9000/ [^]
16:54:49 - [GATEKEEPER SERVICE CONNECTOR]: Failed getting/storing map image, because it is probably already in the cache
16:54:49 - [HYPERGRID LINKER]: Successfully linked to region_uuid 5e3528e5-363b-4fc4-9135-c6184043f9a4
Hyperlink established

- Issue History
Date Modified Username Field Change
2010-12-15 07:04 aiaustin New Issue
2010-12-15 07:04 aiaustin Git Revision => 0.7.1.dev
2010-12-15 07:04 aiaustin SVN Revision => 14681
2010-12-15 07:04 aiaustin Run Mode => Grid (Multiple Regions per Sim)
2010-12-15 07:04 aiaustin Physics Engine => ODE
2010-12-15 07:04 aiaustin Environment => .NET / Windows32
2010-12-15 07:04 aiaustin Mono Version => None
2010-12-15 07:06 aiaustin Description Updated
2010-12-15 07:07 aiaustin Description Updated
2010-12-15 07:08 aiaustin Description Updated
2010-12-19 09:55 Diva Note Added: 0017639
2010-12-20 03:10 aiaustin Note Added: 0017650
2010-12-20 08:25 Diva Note Added: 0017653
2010-12-20 09:06 aiaustin Note Added: 0017655


Copyright © 2000 - 2012 MantisBT Group
Powered by Mantis Bugtracker