Mantis Bug Tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0005268opensim[REGION] OpenSim Corepublic2010-12-12 16:142014-07-29 13:42
ReporterLaniGlobal 
Assigned ToLaniGlobal 
PrioritynormalSeveritymajorReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version 
Target VersionFixed in Versionmaster (dev code) 
Summary0005268: Could Not Teleport. Problems Connecting to Destination. Viewer Client Crash.
DescriptionTeleport to a region running on another simulator on a grid, causes teleporting client viewer to crash.

Error message to viewer screen:
"Could Not Teleport. Problems Connecting to Destination."

Repeatable. Reproducible.
Additional InformationAfter experiencing this bug, then relog:
1. Avatar is often stripped of clothing and/or attachments.
2. Avatar is often ruthed or rendered as a poof cloud or transparent.

Product Versions:
Tested various 0.7x versions and regions running in OSgrid.
Tested in megaregions and 1 region per simulator.
TagsNo tags attached.
Git Revision or version numberVarious. Tested Git Revs List will be added in new notes.
Run Mode Grid (1 Region per Sim)
Physics EngineBasicPhysics
EnvironmentUnknown
Mono VersionNone
ViewerImprudence and Phoenix
Attached Files

- Relationships

-  Notes
(0017567)
kenvc (reporter)
2010-12-12 16:32

Have alo experienced this problem after the 12/09/2010 OSGrid release, BUT this release is so much better regarding rezzing the av and huds when a crash doesnt occur, I hesitated to even report this issue.

Anyway, after the crash when teleporting the AV normally appears at the location I was trying to teleport to. This seems to indicate that the crash may have happened right as the teleport was completing. Avitar shape, skin, and/or clothes are usually messed up, but patiently waiting normally results in everything going back to normal.
(0017569)
LaniGlobal (reporter)
2010-12-12 16:48
edited on: 2010-12-12 19:15

Tested and reproduced:

The regions are online, connected to OSgrid, and functioning.
All of the regions can be logged into directly. But not teleported or walked between them.

The regions are running on slightly different versions on different servers. Sometimes this bug does not cause the viewer to crash. In most cases, it prevents teleporting.

Sometimes this bug causes the viewer/client avatar to appear briefly at the destination region, and then rubber band back to the original region, then crash.

OpenSim 0.7.1 Dev 8f1a79420be062ea59b3c04aacb439fb57713ac7 - 14371 (Unix/Mono)

OpenSim 0.7.1 Dev OSgrid 0.7.1 (Dev) ae9c4a4: 2010-11-09 (Win/.NET) in OSgrid, KaladanSpace region

(0017570)
LaniGlobal (reporter)
2010-12-12 17:02
edited on: 2010-12-12 19:15

Tested and reproduced:
OpenSim 0.7.1 Dev 8f1a7942 in OSgrid, Lani region
OpenSim 0.7.1 Dev 8f1a7942 in OSgrid, Samsara region.

These sims are on different computers, both in the same data center location.
Both regions are online.
Can relog, and log in directly to each region.

(0017571)
LaniGlobal (reporter)
2010-12-12 17:07
edited on: 2010-12-12 17:14

During this condition of login, also seeing random occurrences of preventing walking or flying across border into another adjacent region running on a different server/simulator within the same grid.
Tested: OSgrid.
Date of tests: 12 Dec 2010

(0017573)
andreos firehawk (reporter)
2010-12-12 18:09
edited on: 2010-12-12 18:10

I have seen this many times, various 7.1x, various OS and viewers.

(0017588)
danbanner (manager)
2010-12-13 18:48
edited on: 2010-12-13 19:05

I can no longer teleport from 3ef9a4d (r/14628) to older releases (i.e. 8f1a7942) in osgrid even though tp in the opposite direction (i.e. 8f1a7942 -> 3ef9a4d) works just fine.

(0017589)
kenvc (reporter)
2010-12-13 21:13

Issue has been confirm by many different users including myself.
(0017591)
Diva (administrator)
2010-12-13 21:23

Is there anyone who can provide server logs for the departing sim, the receiving sim or both?
(0017860)
LaniGlobal (reporter)
2011-01-18 18:54

19 JAN 2011 - Tested again and Reproduced failed teleport with error as originally reported.
Viewer: Imprudence 1.4.0

Teleport from:
OSgrid, SpaceBarr region
OpenSim 0.7.1 Dev OSgrid 0.7.1 (Dev)9f7b37b: 2011-01-17(Unix/Mono)

Teleport to:
OSgrid, Wright Plaza region
OpenSim 0.7.1 Dev f73c90c 2011-01-17 17:52:03 -0800 (Unix/Mono)

Teleport to:
OSgrid, Lbsa Plaza
OpenSim 0.7.1 Dev 9f7b37b: 2011-01-18 01:48:37 +0000

Failed Teleport back to:
OSgrid, Wright Plaza region
OpenSim 0.7.1 Dev f73c90c 2011-01-17 17:52:03 -0800 (Unix/Mono)

Error popup in viewer:
"Could Not Teleport. Problems Connecting to Destination."

Multiple attempts to teleport to any location from the final region resulted in same error. "Could Not Teleport. Problems Connecting to Destination."
(0017861)
kenvc (reporter)
2011-01-18 19:45

This issue appears to have cleared up for me, apparently an update since it was originally reported fixed it?
(0017868)
LaniGlobal (reporter)
2011-01-19 19:53

Issue is not cleared up yet.

Bug still appears randomly (as of 20 Jan 2011) and increases in probability when more regions are visited during a client session.

Bug is present in OSgrid on latest version, however, on some instances of occurance, it seemed to heal itself after about 20 minutes: As per this testing example:

20 Jan 2011
Teleport from:
OSgrid, Lbsa Plaza region
OpenSim 0.7.1 Dev 9f7b37b: 2011-01-18 01:48:37 +0000

Failed Teleport to:
OSgrid, Wright Plaza region
OpenSim 0.7.1 Dev d3dca7d: 2011-01-19 01:50:02 +0000 (Unix/Mono)

Process Notes:
1. Failed teleport attempt to destination (Wright Plaza).
2. Did not relog.
3. Waited 20 minutes in the first region (Lbsa Plaza).
4. Tried to teleport again to destination (Wright Plaza).
5. Teleport was successful on the second try.
6. No viewer or sim crash experienced this time.
(0017923)
kenvc (reporter)
2011-02-02 12:13
edited on: 2011-02-02 14:02

NOTE: There is a possibility that the issues described below are because of the bad ice and snow storm currently gripping the area where the opensim servers are located.

This problem has returned for me since OSGrid's Robust came back online after the database change to InnoDB. Emerald and Ascent with the last two 0.7.1 dev releases all do the same thing occassionally. Was not happening prior to the database change to InnoDB, but this could just be a coincidence. Sometimes, the next time I log back in, my AV is located in the lower right corner of the sim I was TPing to when the crash happened. When this happens, I usually have to relog to TP anywhere else.

When I TP somewhere, the viewer sometimes has my AV hovering above water with no land in sight for a short time, then the viewer completely exists and closes with no error messages at all. Sometimes a few things rezz, then it just freezes before crashing. Tried clearing cache many times.

(0017928)
Sylvia Sonoda (reporter)
2011-02-03 02:01

I had and have the same problems. after the big downtime tp and wild landing spots increased enormously. Also part of the simulators now sometimes crash after tp's. :(
(0025278)
LaniGlobal (reporter)
2014-02-22 17:25

This was fixed prior to 0.7.4
Thanks to the devs that have worked tirelessly to make the improved teleports happen!

- Issue History
Date Modified Username Field Change
2010-12-12 16:14 LaniGlobal New Issue
2010-12-12 16:14 LaniGlobal Git Revision => Various. Tested Git Revs List will be added in new notes.
2010-12-12 16:14 LaniGlobal SVN Revision => 0
2010-12-12 16:14 LaniGlobal Run Mode => Grid (1 Region per Sim)
2010-12-12 16:14 LaniGlobal Physics Engine => BasicPhysics
2010-12-12 16:14 LaniGlobal Environment => Unknown
2010-12-12 16:14 LaniGlobal Mono Version => None
2010-12-12 16:14 LaniGlobal Viewer => Imprudence and Phoenix
2010-12-12 16:32 kenvc Note Added: 0017567
2010-12-12 16:48 LaniGlobal Note Added: 0017569
2010-12-12 17:02 LaniGlobal Note Added: 0017570
2010-12-12 17:03 LaniGlobal Note Edited: 0017570
2010-12-12 17:03 LaniGlobal Note Edited: 0017570
2010-12-12 17:05 LaniGlobal Note Edited: 0017569
2010-12-12 17:05 LaniGlobal Note Edited: 0017569
2010-12-12 17:07 LaniGlobal Note Edited: 0017570
2010-12-12 17:07 LaniGlobal Note Added: 0017571
2010-12-12 17:09 LaniGlobal Note Edited: 0017571
2010-12-12 17:09 LaniGlobal Note Edited: 0017571
2010-12-12 17:14 LaniGlobal Note Edited: 0017571
2010-12-12 17:14 LaniGlobal Note Edited: 0017571
2010-12-12 18:09 andreos firehawk Note Added: 0017573
2010-12-12 18:10 andreos firehawk Note Edited: 0017573
2010-12-12 19:09 LaniGlobal Note Edited: 0017569
2010-12-12 19:11 LaniGlobal Note Edited: 0017569
2010-12-12 19:12 LaniGlobal Note Edited: 0017570
2010-12-12 19:12 LaniGlobal Note Edited: 0017570
2010-12-12 19:12 LaniGlobal Note Edited: 0017570
2010-12-12 19:14 LaniGlobal Note Edited: 0017570
2010-12-12 19:15 LaniGlobal Note Edited: 0017570
2010-12-12 19:15 LaniGlobal Note Edited: 0017569
2010-12-13 18:48 danbanner Note Added: 0017588
2010-12-13 19:05 danbanner Note Edited: 0017588
2010-12-13 21:13 kenvc Note Added: 0017589
2010-12-13 21:13 kenvc Status new => confirmed
2010-12-13 21:23 Diva Note Added: 0017591
2011-01-18 18:54 LaniGlobal Note Added: 0017860
2011-01-18 19:45 kenvc Note Added: 0017861
2011-01-19 19:53 LaniGlobal Note Added: 0017868
2011-02-02 12:13 kenvc Note Added: 0017923
2011-02-02 14:02 kenvc Note Edited: 0017923
2011-02-03 02:01 Sylvia Sonoda Note Added: 0017928
2014-02-22 17:25 LaniGlobal Note Added: 0025278
2014-02-22 17:25 LaniGlobal Status confirmed => resolved
2014-02-22 17:25 LaniGlobal Fixed in Version => master (dev code)
2014-02-22 17:25 LaniGlobal Resolution open => fixed
2014-02-22 17:25 LaniGlobal Assigned To => LaniGlobal
2014-07-29 13:42 chi11ken Status resolved => closed


Copyright © 2000 - 2012 MantisBT Group
Powered by Mantis Bugtracker