Mantis Bug Tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0005249opensim[GRID] Robust Serverpublic2010-12-03 08:102019-02-11 06:07
Reportershangcheng 
Assigned Totampa 
PrioritynormalSeveritymajorReproducibilityalways
StatusclosedResolutionunable to reproduce 
PlatformOSOS Version
Product Versionmaster (dev code) 
Target VersionFixed in Version 
Summary0005249: getDefaultRegions always returns 0
Descriptionsetup DefaultRegions in robust.ini

grid always picks a random region instead of default
TagsNo tags attached.
Git Revision or version numberunknown (0.7.1 Dev)
Run Mode Grid (1 Region per Sim)
Physics EngineODE
Environment.NET / Windows64
Mono VersionNone
Viewer
Attached Files

- Relationships

-  Notes
(0017423)
Marck (reporter)
2010-12-03 08:16

The reported setup of the grid service was as follows:

[GridService]
    LocalServiceModule = "OpenSim.Services.GridService.dll:GridService"
    ; Realm = "regions"
    ; AllowDuplicateNames = "True"

    ;; Next, we can specify properties of regions, including default and fallback regions
    ;; The syntax is: Region_<RegionName> = "<flags>"
    ;; or: Region_<RegionID> = "<flags>"
    ;; where <flags> can be DefaultRegion, FallbackRegion, NoDirectLogin, Persistent, LockedOut,Reservation,NoMove,Authenticate
    ;; For example:
    Region_Avieku_Welcome = "DefaultRegion, FallbackRegion"
    Region_Help = "FallbackRegion"
    ; (replace spaces with underscore)
(0017433)
shangcheng (reporter)
2010-12-03 18:39

Determined that DefaultRegion works fine if you use Region_ID instead of Region_Name.

- Issue History
Date Modified Username Field Change
2010-12-03 08:10 shangcheng New Issue
2010-12-03 08:10 shangcheng Git Revision => 1.7.3
2010-12-03 08:10 shangcheng SVN Revision => 0
2010-12-03 08:10 shangcheng Run Mode => Grid (1 Region per Sim)
2010-12-03 08:10 shangcheng Physics Engine => ODE
2010-12-03 08:10 shangcheng Environment => .NET / Windows64
2010-12-03 08:10 shangcheng Mono Version => None
2010-12-03 08:14 Marck Git Revision 1.7.3 => unknown (0.7.1 Dev)
2010-12-03 08:16 Marck Note Added: 0017423
2010-12-03 18:39 shangcheng Note Added: 0017433
2014-01-23 15:41 justincc Category Robust Server => [GRID] Robust Server
2019-02-10 19:08 tampa Status new => resolved
2019-02-10 19:08 tampa Resolution open => unable to reproduce
2019-02-10 19:08 tampa Assigned To => tampa
2019-02-11 06:07 BillBlight Status resolved => closed


Copyright © 2000 - 2012 MantisBT Group
Powered by Mantis Bugtracker