Mantis Bug Tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0005193opensim[REGION] OpenSim Corepublic2010-11-10 08:232013-05-13 16:16
Reporterkenvc 
Assigned Tokenvc 
PriorityurgentSeveritymajorReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Versionmaster (dev code) 
Target VersionFixed in Versionmaster (dev code) 
Summary0005193: Dev Master 7.1 (7.2?) April 14, 2011 Constant red spewing of SculptyMap errors (same old problem)
DescriptionOn startup getting the constant spewing of SculptMap exception errors after loading a new oar almost every time if any sculpties are in the sim. Forcefully terminating the instance helped with this issue at one time, but now the problem doesn't seem to improve with this work-around.

The error logs continue to grow with these errors unless you forcefully terminate the instance, then it starts up all over again next time you run it. The simulators in this instance have constant rezz, TP, and lockup problems if you try to go into them.

This is the same issue and same error codes we saw right after the first .7.1 release. Still going on and may in fact be worse now.
Additional InformationThe following series of error messages spew continually and do NOT stop until the instance is forcefully terminated. Only way to stop it is to disable physics sculpty meshing:

Parameter name: x
   at System.Drawing.Bitmap.GetPixel(Int32 x, Int32 y)
   at PrimMesher.SculptMap..ctor(Bitmap bm, Int32 lod) in C:\Users\User\Desktop\opensim-tree-6ee6197\OpenSim\Region\Physics\Meshing\SculptMap.cs:line 109, Void .ctor(System.Drawing.Bitmap, Int32), System.Exception: Caught exception processing byte arrays in SculptMap(): e: System.ArgumentOutOfRangeException: Parameter must be positive and < Width.
Parameter name: x
   at System.Drawing.Bitmap.GetPixel(Int32 x, Int32 y)
   at PrimMesher.SculptMap..ctor(Bitmap bm, Int32 lod) in C:\Users\user\Desktop\opensim-tree-6ee6197\OpenSim\Region\Physics\Meshing\SculptMap.cs:line 109
   at PrimMesher.SculptMap..ctor(Bitmap bm, Int32 lod) in C:\Users\user\Desktop\opensim-tree-6ee6197\OpenSim\Region\Physics\Meshing\SculptMap.cs:line 121
   at PrimMesher.SculptMesh._SculptMesh(Bitmap sculptBitmap, SculptType sculptType, Int32 lod, Boolean viewerMode, Boolean mirror, Boolean invert) in C:\Users\user\Desktop\opensim-tree-6ee6197\OpenSim\Region\Physics\Meshing\SculptMesh.cs:line 299
   at PrimMesher.SculptMesh..ctor(Bitmap sculptBitmap, SculptType sculptType, Int32 lod, Boolean viewerMode, Boolean mirror, Boolean invert) in C:\Users\user\Desktop\opensim-tree-6ee6197\OpenSim\Region\Physics\Meshing\SculptMesh.cs:line 185
   at OpenSim.Region.Physics.Meshing.Meshmerizer.CreateMeshFromPrimMesher(String primName, PrimitiveBaseShape primShape, Vector3 size, Single lod) in C:\Users\user\Desktop\opensim-tree-6ee6197\OpenSim\Region\Physics\Meshing\Meshmerizer.cs:line 470
   at OpenSim.Region.Physics.Meshing.Meshmerizer.CreateMesh(String primName, PrimitiveBaseShape primShape, Vector3 size, Single lod, Boolean isPhysical) in C:\Users\user\Desktop\opensim-tree-6ee6197\OpenSim\Region\Physics\Meshing\Meshmerizer.cs:line 641
   at OpenSim.Region.Physics.OdePlugin.OdePrim.changeadd(Single timestep) in C:\Users\user\Desktop\opensim-tree-6ee6197\OpenSim\Region\Physics\OdePlugin\ODEPrim.cs:line 1435
   at OpenSim.Region.Physics.OdePlugin.OdePrim.ProcessTaints(Single timestep) in C:\Users\user\Desktop\opensim-tree-6ee6197\OpenSim\Region\Physics\OdePlugin\ODEPrim.cs:line 866
   at OpenSim.Region.Physics.OdePlugin.OdeScene.Simulate(Single timeStep) in C:\Users\user\Desktop\opensim-tree-6ee6197\OpenSim\Region\Physics\OdePlugin\OdePlugin.cs:line 2763
2011-04-14 20:38:11,154 ERROR - OpenSim.Region.Physics.OdePlugin.OdeScene.Cuba Beach Island [PHYSICS]: Caught exception processing byte arrays in SculptMap(): e: System.ArgumentOutOfRangeException: Parameter must be positive and < Width.
TagsNo tags attached.
Git Revision or version number* r821e67fb9507
Run Mode Grid (Multiple Regions per Sim)
Physics EngineODE
Environment.NET / Windows64
Mono VersionNone
ViewerAll viewers same problem
Attached Files

- Relationships

-  Notes
(0017420)
kenvc (reporter)
2010-12-02 19:10

Problem still happens with 11/18/2010 release after loading oars. Have to forcefully terminate the instance to recover from it then it usually doesnt happen again.
(0018257)
justincc (administrator)
2011-04-11 15:59

There is an issue which I think is actually in the jpeg decode libraries, since we don't see this problem on 32 bit. One workaround is to disable physic sculpty meshing.
(0018280)
kenvc (reporter)
2011-04-14 18:59

Continual spewing of red errors started again today using Dev Master from April 14th, 2011.

Additional error message details from today's error log are included above in the "Additional Information" section.
(0018281)
BlueWall (administrator)
2011-04-14 19:11

Can you see if CacheSculptMaps = false helps?
Also do any of the sculptys have protection, ie. transparent and watermarked when viewed with the build tool, or texture viewer?
(0020102)
kenvc (reporter)
2011-10-04 12:31

Have not tested this in a while, so after clearing assetcache and updating into a fresh folder, this issue appears to be gone with the Dev Master code as of 11/03/2011.

- Issue History
Date Modified Username Field Change
2010-11-10 08:23 kenvc New Issue
2010-11-10 08:23 kenvc Git Revision => ae9c4a4d118e126b4f849bbfed112d0971459339
2010-11-10 08:23 kenvc SVN Revision => 0
2010-11-10 08:23 kenvc Run Mode => Grid (Multiple Regions per Sim)
2010-11-10 08:23 kenvc Physics Engine => ODE
2010-11-10 08:23 kenvc Environment => .NET / Windows64
2010-11-10 08:23 kenvc Mono Version => None
2010-11-10 08:23 kenvc Viewer => Inprudence latest version
2010-12-02 19:10 kenvc Note Added: 0017420
2010-12-02 19:12 kenvc Description Updated
2011-04-11 15:59 justincc Note Added: 0018257
2011-04-14 18:59 kenvc Git Revision ae9c4a4d118e126b4f849bbfed112d0971459339 => 6ee6197
2011-04-14 18:59 kenvc Viewer Inprudence latest version => N/A
2011-04-14 18:59 kenvc Note Added: 0018280
2011-04-14 18:59 kenvc Priority normal => urgent
2011-04-14 18:59 kenvc Severity minor => major
2011-04-14 18:59 kenvc Reproducibility have not tried => always
2011-04-14 18:59 kenvc Status new => confirmed
2011-04-14 18:59 kenvc Summary Constant spewing of SculptyMap errors (again) => Dev Master 7.1 (7.2?) April 14, 2011 Constant red spewing of SculptyMap errors (same old problem)
2011-04-14 18:59 kenvc Description Updated
2011-04-14 18:59 kenvc Additional Information Updated
2011-04-14 19:11 BlueWall Note Added: 0018281
2011-04-14 19:53 kenvc Git Revision 6ee6197 => * r821e67fb9507
2011-04-15 06:29 kenvc Viewer N/A => All viewers same problem
2011-04-15 06:29 kenvc Description Updated
2011-10-04 12:31 kenvc Note Added: 0020102
2011-10-08 06:04 kenvc Status confirmed => resolved
2011-10-08 06:04 kenvc Resolution open => fixed
2011-10-08 06:04 kenvc Assigned To => kenvc
2013-05-13 16:16 kenvc Status resolved => closed
2013-05-13 16:16 kenvc Fixed in Version => master (dev code)


Copyright © 2000 - 2012 MantisBT Group
Powered by Mantis Bugtracker