Mantis Bug Tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0005136opensim[GRID] Hypergridpublic2010-10-24 13:502011-05-06 18:52
Reporteraiaustin 
Assigned ToDiva 
PrioritynormalSeverityminorReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Versionmaster (dev code) 
Target VersionFixed in Version 
Summary0005136: osTeleportAgent no longer works with host:port:region format
DescriptionIt seems that osTeleportAgent does not now work if the host:port or host:port:region name formats are used.
TagsNo tags attached.
Git Revision or version number0.7.1 Dev Master
Run Mode Grid (Multiple Regions per Sim)
Physics EngineODE
Environment.NET / Windows32
Mono VersionNone
Viewer
Attached Filesrtf file icon Part_1_osTeAg_script.rtf [^] (11,222 bytes) 2010-12-19 10:14
rtf file icon Part_2_osTeAg_script.rtf [^] (2,273 bytes) 2010-12-19 10:14
rtf file icon Part_3_osTeAg_script.rtf [^] (3,621 bytes) 2010-12-19 10:15
txt file icon Error_Report_01.txt [^] (7,504 bytes) 2010-12-20 17:13 [Show Content]
txt file icon teleport_fail.txt [^] (679,765 bytes) 2011-01-06 16:45
txt file icon scripts_issue.txt [^] (777,665 bytes) 2011-01-06 16:45
txt file icon other_error.txt [^] (5,024 bytes) 2011-01-06 16:46 [Show Content]

- Relationships
child of 0005135closedWhiteStar osTeleportAgent cause Viewer Internal Error on Arrival = 50% crash rate 

-  Notes
(0017309)
aiaustin (developer)
2010-11-16 19:49

Does Marck's patch for http://opensimulator.org/mantis/view.php?id=5211 [^] resolve this issue too?
(0017311)
Marck (reporter)
2010-11-16 22:34

Yes, 0005211 should resolve this issue. However, it does not address 0005135.
(0017574)
Bruce (reporter)
2010-12-12 20:51
edited on: 2010-12-12 20:51

This has reappeared with r14645 for certain osTeleportAgent scripts which worked fine with host:port or host:port:region format for hyperlinked regions.

(0017578)
aiaustin (developer)
2010-12-13 01:22
edited on: 2010-12-13 05:20

Bruce check if the failing regions relate to ones you set up as hyperlinks on your map. It could be that these conflict with OSTeleportAgent scripted jumps?

I cleared out all my old style map hyperlinks.

Unfortunately I also observed two crashes on arrival at Ansky grid from Openvue via map clicks yesterday... But I am still investigating the circumstances.

(0017582)
Bruce (reporter)
2010-12-13 06:29

Ai, the osTeleporterAgent scrip in question is using the name of hyperlinked regions. Those names are manually listed in a notecard. I think this no longer works because the names of hyperlinked regions now contain the prefix "http://" [^] and a trailing "/", as you can see in Map for hyperlinked regions these days (a short name for any such region was, in my humble opinion, much more 'user friendly'). Perhaps the script would work again if the "http://" [^] prefix and trailing "/" could be hidden, e.g. "virtual.aiai.ed.ac.uk:8002:Vue-9000" instead of "http://virtual.aiai.ed.ac.uk:8002:Vue-9000/". [^]
(0017584)
aiaustin (developer)
2010-12-13 07:31

That is a separate issue Bruce... I can verify that an OSTeleportAgent request using the destination with

host:port:region name works... with no http:// on front or training slash on end... which is what OSTeleportAgent is meant to do

It can ALSOP uise a local map region name... which includes your own regions AND the map name for linked regions, whichas you rigtly say now have a new format of http://host:port[:region]/ [^] with region name not showing if a link is done to teh default region for a grid, and with http:// on front and / on end even in the friendly map name.

Maybe Diva could consider NOT using the http:// and trailing slash in the local name as those are superflouus and wasting space on labels in the map. They ARE of course needed in teh actual address maintaine d in the link-region data base table which can be listed via "show hyperlinks" command in the relevant console. Then the hyperlinked map cell name would be the same format as used in OSTeleportAgent which would seem to make sense?
(0017641)
Diva (administrator)
2010-12-19 09:58

Please add a script that has problems, so that I can understand what's going on.
(0017642)
Bruce (reporter)
2010-12-19 10:17

3 files for osTeleportAgent script uploaded (place all 3 in a prim of any shape).
(0017643)
Bruce (reporter)
2010-12-19 11:03

Actually the correct syntax for link-region is apparently: http://host:port/ [^] [region] and not http://host:port[:region]/. [^] I checked with both and only the first incantation will link a region in my case (r/14693, standalone multiple regions, .Net, Win2k3/32, ODE, etc).
(0017644)
Diva (administrator)
2010-12-19 11:28

Yes, the syntax has changed. Does this change the problem reported in this issue?
(0017645)
Bruce (reporter)
2010-12-19 11:36

Sorry, it does not solve the problem. It could be a win32/.net issue because apparently that script works for Marck on his standalone (I think he is on Linux). The script returns "could not find [region name]" in most cases. It does not understand the new syntax as it is probably looking for a region name and not an URI. All linked regions which were created before the new syntax came into effect must be unlinked otherwise when you open Map the instances crashes (again this is on windows 32 with my setup).
(0017646)
Bruce (reporter)
2010-12-19 12:25

Running the attached script under r/14693:

The opensim.exe console reports:
16:09:07 - [GRID SERVICE]: GetRegionsByName virtual.aiai.ed.ac.uk:8002:Vue-5000
16:09:07 - [GRID SERVICE]: Found 0 regions
16:09:07 - [HYPERGRID LINKER]: Link to virtual.aiai.ed.ac.uk:8002:Vue-5000, in 11234-0
16:09:07 - [GATEKEEPER SERVICE CONNECTOR]: Linking to http://virtual.aiai.ed.ac.uk:8002/ [^]
16:09:08 - [HYPERGRID LINKER]: Region already exists in coordinates 9000 9003

The viewer reports:
The region 'Vue-5000' could not be found.

Show hyperlinks lists Vue-5000 correctly as: "http://virtual.aiai.ed.ac.uk:8002/ [^] Vue-5000"

GetRegionsByName may be the culprit ?
(0017647)
Marck (reporter)
2010-12-19 17:18

The issue described by Bruce occurs when a storage provider other than NullRegionData is used for region storage with the GridService.

Commit 3b4af8a0dc30e65b6f5c12d9f312f83be7ed240d (r/14697) should fix this, please test.
(0017659)
Bruce (reporter)
2010-12-20 14:40

Thank you Diva for looking into this and thank you Marck for fixing it in r/14697. Confirming osTeleportAgent script working properly again. Tested on r/14699.
(0017661)
Bruce (reporter)
2010-12-20 17:34
edited on: 2010-12-20 17:36

Re.: Mantis 5135 (reported as solved). Teleporting using osTeleportAgent from one region to another region within the same grid ("home grid") does not appear to be resolved (error report attached). Teleporting to the first region is fine but the agent may arrive as a cloud. Teleporting to a second region as a cloud is possible but not as a fully rendered agent. Teleporting to a second region as a fully rendered agent will crash the viewer (Imprudence 1.3.0) and opensim.exe (r/14699, standalone multiple regions, .Net, Win2k3/32, ODE, etc). Teleporting to the third region as a cloud will only crash the viewer. Teleporting to regions located outside the home grid to other HG enabled regions appears to be fine (tested with 4 HG enabled regions).

(0017768)
Diva (administrator)
2011-01-05 19:16

Is this solved?
If not, can you please provide an updated summary of how to repro?
(0017772)
aiaustin (developer)
2011-01-06 03:23
edited on: 2011-01-06 03:24

In my tests with r/14741 most recently (and now interacting between Openvue Grid and OSGrid) the osTeleportAgent scripts all seem to work fine with SL Viewer 1.23.5.

(0017775)
Bruce (reporter)
2011-01-06 08:26

Problem reported by me on 2010-12-20 at 17:34 concerning mantis 5135 persists and is worse in r14740 in as much as a second inter-grid teleport crashes the viewer each time. It could be a latency problem or date coming too fast for the viewer. Opensim.exe console did not generate any red warning messages. Will test with head tonight and report my findings here tomorrow. (tested r14370, 14722 and r/14740; standalone multiple regions; hyperlink enabled; .Net; Win2k3/32; ODE; mySQL; flotsam cache; Imprudence 1.3.0).
(0017776)
aiaustin (developer)
2011-01-06 08:44

I had one viewer crash today with SL 1.23.5 and r/14747 (5-Jan-2011) when going to Ansky grid from Openvue grid. It crashed on the attempt to use the Ansky hypergrid link-region map tile to come back home to Openvue.

But all my other HG jumps between Openvue Grid, OSGrid Wright Plaza and my own two regions on OSGRid (Vue-3200 and Vue-6400) and across to Diva's UCI Grid test setup worked fine using ostelePortAgent scripts for internal and HG jumps.
(0017786)
Bruce (reporter)
2011-01-06 16:54
edited on: 2011-01-06 17:00

Steps to recreate:

1. Enable StandalonHypergrid architecture with r14750 using Win2k3/32; .NET; mySQL; ODE; xEngine; flotsam cache; Imprudence 1.3.0

2. Create a home grid consisting of 6 regions, each having about 4,000 objects and 200 scripts.

3. check that all 6 regions are ready, i.e. "server_startup,1,0" on channel -800

4. Use object with osTeleportAgent script to teleport WITHIN home grid (teleporting outside home grid to HG regions using same interface works almost every time).

Results:
1. Could teleport to 3 regions in home grid before teleport to 4th region in home grid failed (see teleport_fail.txt)

2. Region to which the teleport was attempted and failed disappeared from mini map.

3. After this, successfully managed to teleport to 2 regions in home grid, including back to home region but delay from initiating teleport to arrival varied between 1 to 4 minutes (home region had longest delay).

5. Agent stayed fully rendered at all times and viewer never crashed.

6. objects set to touch/grab do not show a hand and objects with door or sit script operate 180 degrees in reverse (no errors in opensim.exe console but maybe scripts_issues.txt may show what is causing this). Restaring opensim.exe two or three times appears to resolve this.

7. opensim.exe console showed 2 unrelated red error messages (see other_error.txt).

Overall opensimulator at r/14750 works much better for me. Thank you to all the developers who contributed to these improvements.

(0017797)
Diva (administrator)
2011-01-07 07:17

I'm closing this, since it looks like the issue with osteleport not working for hyperlinks is fixed. The remaining issues seem to be related to teleports in general.

- Issue History
Date Modified Username Field Change
2010-10-24 13:50 aiaustin New Issue
2010-10-24 13:50 aiaustin Git Revision => 0.7.1 Dev master
2010-10-24 13:50 aiaustin SVN Revision => 14247
2010-10-24 13:50 aiaustin Run Mode => Grid (Multiple Regions per Sim)
2010-10-24 13:50 aiaustin Physics Engine => ODE
2010-10-24 13:50 aiaustin Environment => .NET / Windows32
2010-10-24 13:50 aiaustin Mono Version => None
2010-10-24 13:51 aiaustin Git Revision 0.7.1 Dev master => 0.7.1 Dev Master
2010-10-24 13:51 aiaustin Description Updated
2010-10-24 13:52 aiaustin SVN Revision 14247 => 14257
2010-10-24 14:35 WhiteStar Relationship added child of 0005135
2010-11-16 19:49 aiaustin Note Added: 0017309
2010-11-16 22:34 Marck Note Added: 0017311
2010-12-12 20:51 Bruce Note Added: 0017574
2010-12-12 20:51 Bruce Note Edited: 0017574
2010-12-13 01:22 aiaustin Note Added: 0017578
2010-12-13 01:23 aiaustin Note Edited: 0017578
2010-12-13 05:20 aiaustin Note Edited: 0017578
2010-12-13 06:29 Bruce Note Added: 0017582
2010-12-13 07:31 aiaustin Note Added: 0017584
2010-12-19 09:58 Diva Note Added: 0017641
2010-12-19 10:14 Bruce File Added: Part_1_osTeAg_script.rtf
2010-12-19 10:14 Bruce File Added: Part_2_osTeAg_script.rtf
2010-12-19 10:15 Bruce File Added: Part_3_osTeAg_script.rtf
2010-12-19 10:17 Bruce Note Added: 0017642
2010-12-19 11:03 Bruce Note Added: 0017643
2010-12-19 11:28 Diva Note Added: 0017644
2010-12-19 11:36 Bruce Note Added: 0017645
2010-12-19 12:25 Bruce Note Added: 0017646
2010-12-19 17:18 Marck Note Added: 0017647
2010-12-20 14:40 Bruce Note Added: 0017659
2010-12-20 17:13 Bruce File Added: Error_Report_01.txt
2010-12-20 17:34 Bruce Note Added: 0017661
2010-12-20 17:35 Bruce Note Edited: 0017661
2010-12-20 17:36 Bruce Note Edited: 0017661
2011-01-05 19:16 Diva Note Added: 0017768
2011-01-06 03:23 aiaustin Note Added: 0017772
2011-01-06 03:24 aiaustin Note Edited: 0017772
2011-01-06 08:26 Bruce Note Added: 0017775
2011-01-06 08:44 aiaustin Note Added: 0017776
2011-01-06 16:45 Bruce File Added: teleport_fail.txt
2011-01-06 16:45 Bruce File Added: scripts_issue.txt
2011-01-06 16:46 Bruce File Added: other_error.txt
2011-01-06 16:54 Bruce Note Added: 0017786
2011-01-06 17:00 Bruce Note Edited: 0017786
2011-01-07 07:17 Diva Status new => resolved
2011-01-07 07:17 Diva Resolution open => fixed
2011-01-07 07:17 Diva Assigned To => Diva
2011-01-07 07:17 Diva Note Added: 0017797
2011-05-06 18:52 chi11ken Status resolved => closed


Copyright © 2000 - 2012 MantisBT Group
Powered by Mantis Bugtracker