Mantis Bug Tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0005128opensim[REGION] OpenSim Corepublic2010-10-23 19:582011-05-06 18:52
Reporternebadon 
Assigned ToDiva 
PrioritynormalSeveritycrashReproducibilityrandom
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version 
Target VersionFixed in Version 
Summary0005128: HTTP Exception System.InvalidOperationException out of sync
Description22:47:39 - [REMOTE SIMULATION CONNECTOR]: Bad send on AgentUpdate Error: ConnectFailure (Connection refused)
22:47:42 - [REMOTE SIMULATION CONNECTOR]: exception on reply of ChilAgentUpdate from http://208.78.25.110:9500/agent/28e3f021-497f-42b3-aa29-3d1dc72ab06f/: [^] The request timed out
22:47:43 - [GETTEXTURE]: Texture 5d552738-3164-c206-3f3d-2158aebc5e78 not found
22:47:44 - [CLIENT]: Got a logout request for Saphy Riler in Wright Plaza
22:47:45 - [REMOTE SIMULATION CONNECTOR]: exception on reply of agent delete from Cassandra: Error: ConnectFailure (Connection refused)
22:47:46 - [APPLICATION]:
APPLICATION EXCEPTION DETECTED: System.UnhandledExceptionEventArgs

Exception: System.InvalidOperationException: out of sync
  at System.Collections.Generic.Dictionary`2+Enumerator[System.String,HttpServer.HttpFile].VerifyState () [0x00000] in <filename unknown>:0
  at System.Collections.Generic.Dictionary`2+Enumerator[System.String,HttpServer.HttpFile].MoveNext () [0x00000] in <filename unknown>:0
  at HttpServer.HttpForm.Clear () [0x00000] in <filename unknown>:0
  at HttpServer.HttpRequest.Clear () [0x00000] in <filename unknown>:0
  at HttpServer.HttpClientContext.OnRequestCompleted (System.Object source, System.EventArgs args) [0x00000] in <filename unknown>:0
  at (wrapper delegate-invoke) <Module>:invoke_void__this___object_EventArgs (object,System.EventArgs)
  at HttpServer.Parser.HttpRequestParser.OnRequestCompleted () [0x00000] in <filename unknown>:0
  at HttpServer.Parser.HttpRequestParser.Parse (System.Byte[] buffer, Int32 offset, Int32 count) [0x00000] in <filename unknown>:0
  at HttpServer.HttpClientContext.OnReceive (IAsyncResult ar) [0x00000] in <filename unknown>:0
  at System.Net.Sockets.Socket+SocketAsyncResult.CB (System.Object unused) [0x00000] in /home/osgrid/install/mono28/mono-2.8/mcs/class/System/System.Net.Sockets/Socket.cs:210

Application is terminating: True
TagsNo tags attached.
Git Revision or version number80f90229e514075ae8b0c8a38da58e1300780478
Run Mode Grid (1 Region per Sim)
Physics EngineODE
EnvironmentMono / Linux64
Mono Version2.8
Viewer
Attached Files

- Relationships

-  Notes
(0017100)
nebadon (administrator)
2010-10-23 20:05

just happened again:

23:04:01 - [REMOTE SIMULATION CONNECTOR]: exception on reply of ChilAgentUpdate from http://208.78.25.110:9500/agent/c5d9c54d-de03-aed0-2871-e8f56e1c58da/: [^] The request timed out
_wapi_connect: error looking up socket handle 0x17
23:04:01 - [REMOTE SIMULATION CONNECTOR]: Bad send on AgentUpdate Error: ConnectFailure (interrupted)
23:04:14 - [APPLICATION]:
APPLICATION EXCEPTION DETECTED: System.UnhandledExceptionEventArgs

Exception: System.InvalidOperationException: out of sync
  at System.Collections.Generic.Dictionary`2+Enumerator[System.String,HttpServer.HttpFile].VerifyState () [0x00000] in <filename unknown>:0
  at System.Collections.Generic.Dictionary`2+Enumerator[System.String,HttpServer.HttpFile].MoveNext () [0x00000] in <filename unknown>:0
  at HttpServer.HttpForm.Clear () [0x00000] in <filename unknown>:0
  at HttpServer.HttpRequest.Clear () [0x00000] in <filename unknown>:0
  at HttpServer.HttpClientContext.OnRequestCompleted (System.Object source, System.EventArgs args) [0x00000] in <filename unknown>:0
  at (wrapper delegate-invoke) <Module>:invoke_void__this___object_EventArgs (object,System.EventArgs)
  at HttpServer.Parser.HttpRequestParser.OnRequestCompleted () [0x00000] in <filename unknown>:0
  at HttpServer.Parser.HttpRequestParser.Parse (System.Byte[] buffer, Int32 offset, Int32 count) [0x00000] in <filename unknown>:0
  at HttpServer.HttpClientContext.OnReceive (IAsyncResult ar) [0x00000] in <filename unknown>:0
  at System.Net.Sockets.Socket+SocketAsyncResult.CB (System.Object unused) [0x00000] in /home/osgrid/install/mono28/mono-2.8/mcs/class/System/System.Net.Sockets/Socket.cs:210

Application is terminating: True
(0017101)
Diva (administrator)
2010-10-23 21:37

[21:33] <diva> ter_afk if you're around, that crash is because the post requests that come in with no content-type defined all go to the same static object called EmptyForm (in HttpForm.cs). Therefore that iteration in the Clear method sometimes chokes.
(0017117)
Snoopy (administrator)
2010-10-25 11:09

It looks like that such request timeout errors in the function UpdateAgent() of the class SimulationServiceConnector is the reason for much lag when there are many avatars in a region.
(0017130)
nebadon (administrator)
2010-10-25 19:52

happened again with some more data this time.

22:46:47 - [REMOTE SIMULATION CONNECTOR]: Bad send on AgentUpdate Error: ConnectFailure (Connection refused)
22:46:48 - [REMOTE SIMULATION CONNECTOR]: Bad send on AgentUpdate Error: ConnectFailure (Connection refused)
22:46:58 - [APPLICATION]:
APPLICATION EXCEPTION DETECTED: System.UnhandledExceptionEventArgs

Exception: System.InvalidOperationException: out of sync
  at System.Collections.Generic.Dictionary`2+Enumerator[System.String,HttpServer.HttpFile].VerifyState () [0x00000] in <filename unknown>:0
  at System.Collections.Generic.Dictionary`2+Enumerator[System.String,HttpServer.HttpFile].MoveNext () [0x00000] in <filename unknown>:0
  at HttpServer.HttpForm.Clear () [0x00000] in <filename unknown>:0
  at HttpServer.HttpRequest.Clear () [0x00000] in <filename unknown>:0
  at HttpServer.HttpClientContext.OnRequestCompleted (System.Object source, System.EventArgs args) [0x00000] in <filename unknown>:0
  at (wrapper delegate-invoke) <Module>:invoke_void__this___object_EventArgs (object,System.EventArgs)
  at HttpServer.Parser.HttpRequestParser.OnRequestCompleted () [0x00000] in <filename unknown>:0
  at HttpServer.Parser.HttpRequestParser.Parse (System.Byte[] buffer, Int32 offset, Int32 count) [0x00000] in <filename unknown>:0
  at HttpServer.HttpClientContext.OnReceive (IAsyncResult ar) [0x00000] in <filename unknown>:0
  at System.Net.Sockets.Socket+SocketAsyncResult.CB (System.Object unused) [0x00000] in /home/osgrid/install/mono28/mono-2.8/mcs/class/System/System.Net.Sockets/Socket.cs:210

Application is terminating: True

Bad call to mono_mutex_lock result 22
* Assertion at handles.c:1714, condition `ret == 0' not met

Stacktrace:
(0017248)
nebadon (administrator)
2010-11-05 22:12

grrr this crash really sucks! anyone have any clues how to fix this?

01:10:47 - [APPLICATION]:
APPLICATION EXCEPTION DETECTED: System.UnhandledExceptionEventArgs

Exception: System.InvalidOperationException: out of sync
  at System.Collections.Generic.Dictionary`2+Enumerator[System.String,HttpServer.HttpFile].VerifyState () [0x00000] in <filename unknown>:0
  at System.Collections.Generic.Dictionary`2+Enumerator[System.String,HttpServer.HttpFile].MoveNext () [0x00000] in <filename unknown>:0
  at HttpServer.HttpForm.Clear () [0x00000] in <filename unknown>:0
  at HttpServer.HttpRequest.Clear () [0x00000] in <filename unknown>:0
  at HttpServer.HttpClientContext.OnRequestCompleted (System.Object source, System.EventArgs args) [0x00000] in <filename unknown>:0
  at (wrapper delegate-invoke) <Module>:invoke_void__this___object_EventArgs (object,System.EventArgs)
  at HttpServer.Parser.HttpRequestParser.OnRequestCompleted () [0x00000] in <filename unknown>:0
  at HttpServer.Parser.HttpRequestParser.Parse (System.Byte[] buffer, Int32 offset, Int32 count) [0x00000] in <filename unknown>:0
  at HttpServer.HttpClientContext.OnReceive (IAsyncResult ar) [0x00000] in <filename unknown>:0
  at System.Net.Sockets.Socket+SocketAsyncResult.CB (System.Object unused) [0x00000] in /home/osgrid/install/mono28/mono-2.8/mcs/class/System/System.Net.Sockets/Socket.cs:210

Application is terminating: True
(0017249)
nebadon (administrator)
2010-11-05 22:21

I just figured out what is causing this issue, its HTTP Texture Pipeline being enabled in viewers. This will cause sim crash 100% of the time.
(0017637)
Diva (administrator)
2010-12-18 17:37

[17:37] <CIA-40> opensim: diva * rd576d7c0a6b0 /bin/HttpServer_OpenSim.dll: Replaced HttpServer_OpenSim.dll with a version that locks certain ops in HttpForm -- mantis 0005128.
(0017638)
Diva (administrator)
2010-12-19 07:41

Fixed!

- Issue History
Date Modified Username Field Change
2010-10-23 19:58 nebadon New Issue
2010-10-23 19:58 nebadon Git Revision => 80f90229e514075ae8b0c8a38da58e1300780478
2010-10-23 19:58 nebadon SVN Revision => 0
2010-10-23 19:58 nebadon Run Mode => Grid (1 Region per Sim)
2010-10-23 19:58 nebadon Physics Engine => ODE
2010-10-23 19:58 nebadon Environment => Mono / Linux64
2010-10-23 19:58 nebadon Mono Version => 2.8
2010-10-23 20:05 nebadon Note Added: 0017100
2010-10-23 21:37 Diva Note Added: 0017101
2010-10-25 11:09 Snoopy Note Added: 0017117
2010-10-25 19:52 nebadon Note Added: 0017130
2010-11-05 22:12 nebadon Note Added: 0017248
2010-11-05 22:21 nebadon Note Added: 0017249
2010-12-18 17:37 Diva Note Added: 0017637
2010-12-19 07:41 Diva Status new => resolved
2010-12-19 07:41 Diva Resolution open => fixed
2010-12-19 07:41 Diva Assigned To => Diva
2010-12-19 07:41 Diva Note Added: 0017638
2011-05-06 18:52 chi11ken Status resolved => closed


Copyright © 2000 - 2012 MantisBT Group
Powered by Mantis Bugtracker