Mantis Bug Tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0005112opensim[REGION] OpenSim Corepublic2010-10-21 05:182010-11-07 07:32
Reporteraiaustin 
Assigned Tootakup0pe 
PrioritynormalSeverityblockReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Versionmaster (dev code) 
Target VersionFixed in Versionmaster (dev code) 
Summary0005112: Recent changes have stopped viewer client from logging in to OpenSim (gatekeeper server URI issue?)
DescriptionClient (on same machine as OpenSim.exe and Robust.exe servers or a different machine on same LAN) cannot log in.

1. Viewer (SL 1.23) hangs at "Connecting to Region" point

2. Robust.exe console seems to indicate it is okay

3. OpenSim.exe console indicates [LLUDPSERVER]: connecting with unnotified circuit code

r/14150 tested and viewer cannot now log in to OpenSim.

r/14142 works fine. So it may be recent commits related to IP handing, HG and server URIs?
Additional InformationRobust. exe console:

13:14:08 - [LLOGIN SERVICE]: Login request for Ai Austin from 129.215.219.138 wi
th user agent Opensim 1.23.5.136262 starting in home
13:14:08 - [PASS AUTH]: got 4733825f6212bcf1e18221557f2e54d4; hashed = 76681d71e
75cd7a1c9dc1b951456948d; stored = 76681d71e75cd7a1c9dc1b951456948d
13:14:08 - [LLOGIN SERVICE]: 0 active gestures
13:14:08 - [PRESENCE SERVICE]: LoginAgent e24a9015-f5ca-452b-8c95-d32e34cb9d64 w
ith session ce4948da-931d-428a-97b3-9cf5c68a5cea and ssession 8cd7fa51-d404-4829
-b459-95d7e0b45c3b
13:14:08 - [GRID USER SERVICE]: User e24a9015-f5ca-452b-8c95-d32e34cb9d64 is onl
ine
13:14:08 - [LLOGIN SERVICE]: FindDestination for start location home
13:14:08 - [LLOGIN SERVICE]: Launching agent at Openvue
13:14:08 - [USER AGENT SERVICE]: Request to login user Ai Austin (@129.215.219.1
38) to grid virtual.aiai.ed.ac.uk:8002
13:14:08 - gatekeeper serveruri -> http://virtual.aiai.ed.ac.uk:9000/ [^]

13:14:08 - [REMOTE SIMULATION CONNECTOR]: Posted CreateAgent request to remote s
im http://virtual.aiai.ed.ac.uk:9000/foreignagent/e24a9015-f5ca-452b-8c95-d32e34 [^]
cb9d64/, region Openvue, x=256000 y=256000
13:14:08 - [REMOTE SIMULATION CONNECTOR]: DoCreateChildAgentCall reply was
13:14:08 - [USER AGENT SERVICE]: Gatekeeper sees me as
13:14:08 - [LLOGIN SERVICE]: Retrieved 21 friends
13:14:08 - [LLOGIN]: Library has 19 folders
13:14:08 - [LLOGIN SERVICE]: All clear. Sending login response to client.

-------------------------------------------

OpenSim.exe console:

13:14:11 - [LLUDPSERVER]: Handling UseCircuitCode packet from 129.215.219.138:63
862
13:14:11 - [LLUDPSERVER]: Connection request for client e24a9015-f5ca-452b-8c95-
d32e34cb9d64 connecting with unnotified circuit code 115480266 from 129.215.219.
138:63862
TagsNo tags attached.
Git Revision or version number0.7.1 dev master
Run Mode Grid (Multiple Regions per Sim)
Physics EngineODE
Environment.NET / Windows32
Mono VersionNone
Viewer
Attached Files

- Relationships
related to 0005110closedTeravus Region ServerURI Refactoring 

-  Notes
(0017041)
aiaustin (developer)
2010-10-21 08:12
edited on: 2010-10-21 09:24

Also tested on a VPN which reports quite a different IP number address.. yet on login the local net IP number is used and same symptoms occur. Will test from a home connection this evening. It could be some simple thing... But at the moment something seems to have been broken in the IP handling code.

(0017042)
aiaustin (developer)
2010-10-21 08:15

Why is gatekeeper reporting port 9000 (the home region sim port) rather than 8002 for the provided gatekeeper service port stated in Robust.HG.ini
(GatekeeperURI = "http://virtual.aiai.ed.ac.uk:8002" [^])

13:14:08 - [USER AGENT SERVICE]: Request to login user Ai Austin (@129.215.219.1
38) to grid virtual.aiai.ed.ac.uk:8002
13:14:08 - gatekeeper serveruri -> http://virtual.aiai.ed.ac.uk:9000/ [^]
(0017044)
otakup0pe (developer)
2010-10-21 12:31

this is due to my serveruri changes no doubt. someone assign this to me plz.
(0017045)
aiaustin (developer)
2010-10-21 12:47

I will watch for the patch appearing in the 0.7.1 dev master branch and give you feedback here. Thx.

- Issue History
Date Modified Username Field Change
2010-10-21 05:18 aiaustin New Issue
2010-10-21 05:18 aiaustin Git Revision => 0.7.1 dev master
2010-10-21 05:18 aiaustin SVN Revision => 14159
2010-10-21 05:18 aiaustin Run Mode => Grid (Multiple Regions per Sim)
2010-10-21 05:18 aiaustin Physics Engine => ODE
2010-10-21 05:18 aiaustin Environment => .NET / Windows32
2010-10-21 05:18 aiaustin Mono Version => None
2010-10-21 05:20 aiaustin SVN Revision 14159 => 14150
2010-10-21 05:20 aiaustin Description Updated
2010-10-21 08:12 aiaustin Note Added: 0017041
2010-10-21 08:15 aiaustin Note Added: 0017042
2010-10-21 08:15 aiaustin Note Edited: 0017041
2010-10-21 09:24 aiaustin Note Edited: 0017041
2010-10-21 12:31 otakup0pe Note Added: 0017044
2010-10-21 12:32 otakup0pe Status new => confirmed
2010-10-21 12:34 otakup0pe Relationship added related to 0005110
2010-10-21 12:47 aiaustin Note Added: 0017045
2010-10-21 12:54 aiaustin Summary Recent changes have stopped viewer client from logging in (when on same LAN?) to OpenSim => Recent changes have stopped viewer client from logging in to OpenSim (gatekeeper server URI issue?)
2010-10-22 14:51 justincc Status confirmed => assigned
2010-10-22 14:51 justincc Assigned To => otakup0pe
2010-10-22 20:41 otakup0pe Status assigned => resolved
2010-10-22 20:41 otakup0pe Fixed in Version => master (dev code)
2010-10-22 20:41 otakup0pe Resolution open => fixed
2010-11-07 07:32 chi11ken Status resolved => closed


Copyright © 2000 - 2012 MantisBT Group
Powered by Mantis Bugtracker