Mantis Bug Tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0005110opensim[REGION] OpenSim Corepublic2010-10-20 17:362011-08-18 18:50
Reporterotakup0pe 
Assigned ToTeravus 
PrioritynormalSeveritytweakReproducibilityhave not tried
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Versionmaster (dev code) 
Target VersionFixed in Versionmaster (dev code) 
Summary0005110: Region ServerURI Refactoring
DescriptionThis patch should clean up the way the HTTP URI for an OpenSim region server instance is handled internally. I have tested standalone and hypergrid/diva regions with this and it seems to work.
TagsNo tags attached.
Git Revision or version numbera7acb650d400a280a7b9edabd304376dff9c81af
Run ModeStandalone (1 Region) , Standalone (Multiple Regions)
Physics EngineBasicPhysics
EnvironmentUnknown
Mono Versiontrunk
Viewer
Attached Filespatch file icon opensim-serveruri.patch [^] (68,206 bytes) 2010-10-20 17:36 [Show Content]

- Relationships
related to 0005112closedotakup0pe Recent changes have stopped viewer client from logging in to OpenSim (gatekeeper server URI issue?) 

-  Notes
(0017022)
Teravus (administrator)
2010-10-20 20:10

* I Applied the Patch
(0017055)
otakup0pe (developer)
2010-10-21 22:49

i guess this wasn't merged properly.

can someone try merging from http://github.com/otakup0pe/opensim-sandbox [^]
(0017056)
aiaustin (developer)
2010-10-21 23:49
edited on: 2010-10-22 05:45

This is a block for viewer logins... at least in some situations... it would be helpful if the patch could be committed to 0.7.1 dev master. Not seeing it in the Github master area yet.

(0017058)
otakup0pe (developer)
2010-10-22 08:40

aiaustin does that mean you tried my github fork and it worked ?
(0017059)
aiaustin (developer)
2010-10-22 08:53
edited on: 2010-10-22 13:44

No I took a look to see if I could merge things but there were many changes. I am waiting for the commit to appear in 0.7.1 master as it seems Teravus did not commit it to that. I am stuck just now and cannot log in at all to 0.7.1 dev and hoped to leave a working system going for HyperGrid tests with OSGrid this weekend. I need the fixes up to 14150 as that fixes the serious Hypergate issues. Can teravus if he sees this do the commit?

I note that regions added onto OSGrid that worked a few days ago also have now stopped working and no attempt is made by OSGrid to contact the region sim server for a target region. Could this be the same issue?

(0017065)
justincc (administrator)
2010-10-22 13:40

This patch appears to have been committed in the sequence of commits

55974df14b6d64c1e1f9e386a3eacce3ba86dc98
19119d7705f8381a3c207d0e64a23243215a12b9
58f75fa19d9aea18283ecdbd44559efb81781c9d
017b83d0a3e3ac6a1c8bc86b9bef1ee47cba059e

put in by Teravus to OpenSim git master on Wednesday 20th October (author Jonathon Freedman).

So I'm rather confused Austin. Are you asking whether these can also be applied to 0.7.0.2 (which I would rather not do until they're shown to be bug-free, personally)?

Let's be careful to stick to be clear about version numbers as well please. There is no 0.7.2 or 0.7.12, which is confusing me :)
(0017066)
otakup0pe (developer)
2010-10-22 13:42

the patch didn't apply cleanly for whatever reason. i pushed my local refactor branch to http://github.com/otakup0pe/opensim-sandbox [^] (branch hg16 if it doesn't get set properly). yes the fork is against fortis, but this branch is against core :)
(0017067)
aiaustin (developer)
2010-10-22 13:44
edited on: 2010-10-22 14:07

Sorry... in all cases I meant 0.7.1 dev master. I corrected my earlier comment. I did not mean to suggest these changes or the patch be made to 0.7.0.2 post-fixes which is working fine. Just to 0.7.1 dev master

The four commits by "Jonathan Freedman" are the ones that broke things... The patch attached here by "otakup0pe" (2010-10-20 17:36) I think tries to fix things, but is not tested yet by me.

If its can't be patched can we take out the 4 changes by "Jonathan Freedman" until this is tested more? Diva may be able to input when she can as she did a lot of work in this area.

(0017069)
justincc (administrator)
2010-10-22 14:03

otakup0pe, I get conflicts against current head if I try and merge from hg16.

Please could you attach an applicable patch against current OpenSim master instead?
(0017071)
aiaustin (developer)
2010-10-22 14:11
edited on: 2010-10-22 14:37

Remember real bug that this is causing is listed at http://opensimulator.org/mantis/view.php?id=5112 [^]

But I wonder if we are speaking at cross purposes here. Is the patch here to FIX the 4 earlier commits (as I have been assuming), or is this the patch that actually caused the bug at mantis 5112?

(0017073)
Teravus (administrator)
2010-10-22 14:53

I got a note in OpenSim Dev to commit a patch on this bug but the patch that's up there is still the original one.

Is this resolved? The patch looks like the same one that was applied on the revision that you mentioned.
(0017074)
justincc (administrator)
2010-10-22 15:43

Okay, in consultation with otakup0pe (who is Jonathon Freedman, btw), I reverted the previous application of this patch and applied a merge from http://github.com/otakup0pe/opensim-sandbox [^] branch mantis5110 instead.

Please retest if you're still around, Austin.
(0017075)
justincc (administrator)
2010-10-22 16:06

Okay, merge code didn't seem to be working with ROBUST. So in consultation with otakup0pe, everything has been reverted for now back to the state before any of the patches were applied.
(0017076)
otakup0pe (developer)
2010-10-22 20:42

i'll let someone know when they can pull from a branch.
(0017077)
Bruce (reporter)
2010-10-22 20:53

Mantis 5123 may be related to 5110 (?)
(0017086)
aiaustin (developer)
2010-10-23 02:43
edited on: 2010-10-23 02:47

Hi folks, thanks for working this.

I just updated Openvue grid to 0.7.1 dev master r/14257 (opensim-tree-86f05bd) and all now seems to be working again, with logins and hypergrid movement to and from OSGrid UCI gateways testing fine from my home connection at least. Will test on viewers on same subnet and same host as services when I get into work Monday.

I see the very complicated set of commits and reverts in 0.7.1 dev. But importantly the empty sting parsing issue that was affecting hypergates and that was fixed in r/14149 and r/14150 is still in place though now with r/14236 and r/14237.

Initial tests on regions added to OSGrid also show that works even witout me changing my region end code. So the OSGRid folks might have updated last night too. But I see they sugegst an update for region sim servers and I will update now.


- Issue History
Date Modified Username Field Change
2010-10-20 17:36 otakup0pe New Issue
2010-10-20 17:36 otakup0pe File Added: opensim-serveruri.patch
2010-10-20 17:36 otakup0pe Git Revision => a7acb650d400a280a7b9edabd304376dff9c81af
2010-10-20 17:36 otakup0pe SVN Revision => 0
2010-10-20 17:36 otakup0pe Run Mode => Standalone (1 Region) , Standalone (Multiple Regions)
2010-10-20 17:36 otakup0pe Physics Engine => BasicPhysics
2010-10-20 17:36 otakup0pe Environment => Unknown
2010-10-20 17:36 otakup0pe Mono Version => None
2010-10-20 17:37 otakup0pe Status new => patch included
2010-10-20 20:10 Teravus Mono Version None => trunk
2010-10-20 20:10 Teravus Status patch included => resolved
2010-10-20 20:10 Teravus Fixed in Version => master (dev code)
2010-10-20 20:10 Teravus Resolution open => fixed
2010-10-20 20:10 Teravus Assigned To => Teravus
2010-10-20 20:10 Teravus Note Added: 0017022
2010-10-21 12:34 otakup0pe Relationship added related to 0005112
2010-10-21 22:49 otakup0pe Note Added: 0017055
2010-10-21 22:49 otakup0pe Status resolved => patch included
2010-10-21 23:49 aiaustin Note Added: 0017056
2010-10-21 23:49 aiaustin Note Edited: 0017056
2010-10-22 05:45 aiaustin Note Edited: 0017056
2010-10-22 08:40 otakup0pe Note Added: 0017058
2010-10-22 08:53 aiaustin Note Added: 0017059
2010-10-22 08:55 aiaustin Note Edited: 0017059
2010-10-22 09:09 aiaustin Note Edited: 0017059
2010-10-22 13:39 aiaustin Note Added: 0017064
2010-10-22 13:40 aiaustin Note Edited: 0017064
2010-10-22 13:40 justincc Note Added: 0017065
2010-10-22 13:40 justincc Status patch included => patch feedback
2010-10-22 13:42 otakup0pe Note Added: 0017066
2010-10-22 13:44 aiaustin Note Added: 0017067
2010-10-22 13:44 aiaustin Note Edited: 0017059
2010-10-22 13:45 aiaustin Note Edited: 0017067
2010-10-22 13:45 aiaustin Note Edited: 0017067
2010-10-22 13:46 aiaustin Note Added: 0017068
2010-10-22 13:47 aiaustin Note Edited: 0017067
2010-10-22 13:50 aiaustin Note Deleted: 0017064
2010-10-22 13:52 aiaustin Note Edited: 0017067
2010-10-22 13:52 aiaustin Note Deleted: 0017068
2010-10-22 13:54 aiaustin Note Edited: 0017067
2010-10-22 14:03 justincc Note Added: 0017069
2010-10-22 14:07 aiaustin Note Edited: 0017067
2010-10-22 14:11 aiaustin Note Added: 0017071
2010-10-22 14:37 aiaustin Note Edited: 0017071
2010-10-22 14:53 Teravus Note Added: 0017073
2010-10-22 15:43 justincc Note Added: 0017074
2010-10-22 16:06 justincc Note Added: 0017075
2010-10-22 20:42 otakup0pe Note Added: 0017076
2010-10-22 20:53 Bruce Note Added: 0017077
2010-10-23 02:43 aiaustin Note Added: 0017086
2010-10-23 02:47 aiaustin Note Edited: 0017086
2011-08-18 18:50 justincc Status patch feedback => closed


Copyright © 2000 - 2012 MantisBT Group
Powered by Mantis Bugtracker