Mantis Bug Tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0005099opensim[REGION] OpenSim Corepublic2010-10-18 22:112011-05-06 18:52
Reporterkenvc 
Assigned To 
PrioritynormalSeveritycrashReproducibilityalways
StatusclosedResolutionopen 
PlatformOSOS Version
Product Version 
Target VersionFixed in Version 
Summary0005099: 0.7.1 crashes after answering 1st estate question every time, not just 1st startup
DescriptionNote: This issue has been corrected in subsequent updates and is not longer a problem.

On startup, opensim asks to join an existing esate. If I answer no, immedate crash. If I answer yes, it asks for an estate name to join, then immediately crashes.

I am using this same version on Danger grid with no issues at all, but cannot get past this point on osgrid so all regions are down.

Crash happens before any info about it is written to the log file, so the log file is useless, but a screen shot is attached that does show the error info in the console window just prior to the crash.
Additional InformationSee attached jpg screenshot of the error messages just prior to the crash.
TagsNo tags attached.
Git Revision or version numbercd4d7a7c351ad78c13805374b46ea8168568d89e
Run Mode Grid (Multiple Regions per Sim)
Physics EngineODE
Script Engine
Environment.NET / Windows64
Mono VersionNone
Viewer
Attached Filesjpg file icon OSGridv0.7.1StartupError.jpg [^] (188,345 bytes) 2010-10-18 22:11

- Relationships

-  Notes
(0017012)
albertlr (reporter)
2010-10-19 22:10
edited on: 2010-10-25 08:59

I have experienced the exact error message and crash. My set up is using Windows 7 32 bit. I have checked every ini file, and can not find any problems with my set up.

01:54:36 - [LOADREGIONS]: Creating Region: Austeria1 (ThreadID: 1)
Your region is not part of an estate.
Do you wish to join an existing estate? [no]: no
01:54:51 - [APPLICATION]:

Unhandled Exception: System.NullReferenceException: Object reference not set to
an instance of an object.
   at OpenSim.OpenSimBase.PopulateRegionEstateInfo(RegionInfo regInfo) in d:\OSG
RID\OSGRID 0.7 RELEASES\opensim-cd4d7a7\OpenSim\Region\Application\OpenSimBase.c
s:line 819
   at OpenSim.ApplicationPlugins.LoadRegions.LoadRegionsPlugin.PostInitialise()
in d:\OSGRID\OSGRID 0.7 RELEASES\opensim-cd4d7a7\OpenSim\ApplicationPlugins\Load
Regions\LoadRegionsPlugin.cs:line 125
   at OpenSim.OpenSimBase.StartupSpecific() in d:\OSGRID\OSGRID 0.7 RELEASES\ope
nsim-cd4d7a7\OpenSim\Region\Application\OpenSimBase.cs:line 218
   at OpenSim.OpenSim.StartupSpecific() in d:\OSGRID\OSGRID 0.7 RELEASES\opensim
-cd4d7a7\OpenSim\Region\Application\OpenSim.cs:line 154
   at OpenSim.Framework.Servers.BaseOpenSimServer.Startup() in d:\OSGRID\OSGRID
0.7 RELEASES\opensim-cd4d7a7\OpenSim\Framework\Servers\BaseOpenSimServer.cs:line
 289
   at OpenSim.Application.Main(String[] args) in d:\OSGRID\OSGRID 0.7 RELEASES\o
pensim-cd4d7a7\OpenSim\Region\Application\Application.cs:line 272

OK I have successfully setup my sim on OSGRID. What I did was use the latest build, and I set up a new blank database in MYSQL. That allowed me to complete the updates and upload my sim. I restored all my oar files. I then shutdown, and switched my database to the original, and it worked fine. The only initial problem was some of the empty terrain did not show up, it was invisible. So I restored the oars again, and everything now seems fine.

(0017046)
nihlaeth (reporter)
2010-10-21 13:53

I had the same problem on Debian Lenny(vps) (connected to grid, multiple regions on one server), at first I thought I had a corrupted database but restoring backups didn't help. Then I found out that after a restart, the localhost record had disappeared from /etc/hosts (127.0.0.1 localhost). Adding it fixed everything.
(0017047)
melanie (administrator)
2010-10-21 14:13

This error can be caused by the estate data service not being configured.
(0017118)
Licu Rau (reporter)
2010-10-25 13:39

I am upgrading my grid from 0.6.9 to 0.7.1dev (r14258). After the migration I started some region still in the table 'regions' in the database and all went fine. But when I tried to start some region that no longer was in that table or when I tried to create new regions, I had exactly the same problem reported here. I searched a workaround and did this: in the source in OpenSim/Region/Application/OpenSimBase.cs I commented these rows:
  ///if (regInfo.EstateSettings.EstateID == 0) // No record at all
            ///{
                ///MainConsole.Instance.Output("Your region is not part of an estate.");
                ///while (true)
                ///{
                    ///string response = MainConsole.Instance.CmdPrompt("Do you wish to join an existing estate?", "no", new List<string>() { "yes", "no" });
                    ///if (response == "no")
                    ///{
                        // Create a new estate
                        ///regInfo.EstateSettings = estateDataService.LoadEstateSettings(regInfo.RegionID, true);

                        ///regInfo.EstateSettings.EstateName = MainConsole.Instance.CmdPrompt("New estate name", regInfo.EstateSettings.EstateName);
                        //regInfo.EstateSettings.Save();
                        ///break;
                    ///}
                    ///else
                    ///{
                        ///response = MainConsole.Instance.CmdPrompt("Estate name to join", "None");
                        ///if (response == "None")
                            ///continue;

                        ///List<int> estateIDs = estateDataService.GetEstates(response);
                        ///if (estateIDs.Count < 1)
                        ///{
                            ///MainConsole.Instance.Output("The name you have entered matches no known estate. Please try again");
                            ///continue;
                        ///}

                        ///int estateID = estateIDs[0];

                        ///regInfo.EstateSettings = estateDataService.LoadEstateSettings(estateID);

                        ///if (estateDataService.LinkRegion(regInfo.RegionID, estateID))
                            ///break;

                        ///MainConsole.Instance.Output("Joining the estate failed. Please try again.");
                    ///}
                ///}
            ///}


and compiled... well... perhaps i am losing something but it worked and i can continue migrating my grid. (my grid is Craft)
(0017119)
DannyBisby (reporter)
2010-10-25 13:49

I experienced this first startup per every region, the option "yes" to use existing estate failed, even when i entered my estate name the one that was setup was "My Estate"
(0017154)
WhiteStar (reporter)
2010-10-27 16:39

After digging through the DB and Tables, it still only leaves the Estate as "My Estate" regardless of what you tell it. The "Estate Owner" is recorded with the UUID and correctly stored and as such it does show the correct ownership. It appears that this is still on the To Complete list.

I have also not found a way to correct Estate Name without DB Diving which for 90%+ of the General Population out there should be avoided. Even a Console Command or something should have been considered for this change.
(0017160)
Clinton (reporter)
2010-10-28 04:30

I was having the same problem during the OSGrid switchover. I use MYSQL, but changed back to SQLite for the inital startup to see what would happen. It started fine. I changed back to MYSQL and haven't had a problem since. I have suggested this to others with the same problem but the temporary switch to sqlite didn't help them. I'm using Windows7 and dont know what the others are using.
(0017238)
bld0112 (reporter)
2010-11-02 10:05
edited on: 2010-11-12 00:10

Experiencing same problem,
(0017047)
melanie (administrator)
2010-10-21 14:13
says it is caused by ---, but can you explain to us how to configure this correctly?

I am running Windows XP, and SimianGrid, this problem is annoying.


Update:
It worked! I was pointing to my SimianGrid database in GridCommon.ini.
Every opensim.exe simulator should have each new database of its own, and not pointing to the ROBUST or SimianGrid database in the ConnectString= in GridCommon.ini.
A big misunderstanding of the whole setup process! it should be clearer in tutorial.

(0017378)
Licu Rau (reporter)
2010-11-24 06:36
edited on: 2010-11-24 08:42

Some more information about this error:
it can happen in various situations, one is that reported by bld0112, another seems to be when a wrong version of mono or libgdiplus is installed (or missing libgdiplus), but the worse case is this: you start your new regions, answer yes or no to the question "Do you wish to join an existing estate? [no]:" and the region/regions start normally, without crashes. Then, if for a crash or for maintenance the regions stay offline long enough that Robust deletes them from database (unregisters them), you can not start the regions and get always that error.
This happens in my grid using OpenSim r14371.


Some of the regions having this problem are now started, without do anything for that... I can't understand, the only thing I can think is that there were problems on the network of my provider.
I will collect some more information about this, with this version it often happens.

(0017380)
melanie (administrator)
2010-11-24 08:28

Licu, simply removing estate registration will not help. Sure, you get it up but any results you get after that will be intrinsically flawed.

Instead of messign with perfectly working code, revisit your configuration and make sure you're loading an estate storage service. Please don't muddy the waters for others by posting things about an opensim version you castrated and that then misbehaves because of that.

This is a configuration issue, it has been one from day one. It is caused by reusing old config files rather than starting fresh with new ones. Occasionally, there are points in the development where configuration changes so much that you should throw away your old config files and start from scratch. This estate change was one like that.
(0017381)
Licu Rau (reporter)
2010-11-24 08:51
edited on: 2010-12-06 15:47

Thank you for your answer, melanie
if it can help, I am no more using the 'castrate' version and all the configuration files are new, redone from scratch. All the grid and its 65 sims usually work well, this is an occasional problem and I am just trying to understand why this happens. And, sure, I will not 'muddy the waters' in the future, sorry.

(0017441)
Licu Rau (reporter)
2010-12-06 14:01
edited on: 2010-12-06 15:39

By the way... same problem in osgrid, official osgrid version, configuration files made by "experts"... :(

00:37:01 - [APPLICATION]:
APPLICATION EXCEPTION DETECTED: System.UnhandledExceptionEventArgs

Exception: System.NullReferenceException: Object reference not set to an instance of an object
  at OpenSim.OpenSimBase.PopulateRegionEstateInfo (OpenSim.Framework.RegionInfo regInfo) [0x00000]
  at OpenSim.ApplicationPlugins.LoadRegions.LoadRegionsPlugin.PostInitialise () [0x00000]
  at OpenSim.OpenSimBase.StartupSpecific () [0x00000]
  at OpenSim.OpenSim.StartupSpecific () [0x00000]
  at OpenSim.Framework.Servers.BaseOpenSimServer.Startup () [0x00000]
  at OpenSim.Application.Main (System.String[] args) [0x00000]

Application is terminating: True

(0017454)
JoeRadik (reporter)
2010-12-07 22:30

I'm experiencing the same problem connecting one of my pre 0.7 sims to osgrid. Pretty sure it's not a configuration issue.

Ubuntu 9.04
Mono JIT compiler version 2.6.3 (tarball Mon Apr 5 21:35:38 MSD 2010)

I installed the mono version a while back. I've tried a fresh database and using the EstateConnectionString explicitly.
 
I've successfully restarted the other sim which is configured in a similar way.

Ubuntu 10.04.1 LTS
Mono JIT compiler version 2.4.4 (Debian 2.4.4~svn151842-1ubuntu4)

I guess I'll start playing around with mono and libgdiplus versions.
(0017492)
JoeRadik (reporter)
2010-12-09 17:46

Still experiencing this issue. Here's what I've tried so far. I've been working with the latest OSGrid release (11/18) and MySQL up to this point.

Ubuntu 9.04
------
Upgraded to mono 2.8.1 - No success
Compiled from master (12/8) - No success
Converted to use new region with SQLite - Success!

Ubuntu 10.04.1 LTS
------
Compiled from master (12/8) - Success using MySQL!

So the problem only exists on the Ubuntu 9.04 system and is somehow related to MySQL.
(0017587)
JoeRadik (reporter)
2010-12-13 12:28

My problem ended up being a configuration issue just as Melanie suggested.

ConnectionString = "Data Source=localhost;Database=opensim;User ID=opensim;Password=***;"

I had to replace the Data Source "localhost" with the actual URL for the server. My pre 0.7 installation worked using localhost on this system, so it appears that something has changed.

I can use localhost with the mysql client like this:

mysql -u opensim -h localhost -p

But, OpenSim does not like me using localhost for the Data Source.
(0017590)
kenvc (reporter)
2010-12-13 21:17

Have not had this problem since the initial .7.1 release.
(0017693)
BreenWhitman (reporter)
2010-12-27 22:59
edited on: 2010-12-27 23:01

This is almost certainly to do with the mySQL connection string. Previous versions seemed tolerant of errors, say if the string was not enclosed in quotes properly.

Also changed, you should now use 127.0.0.1 rather than using localhost.

This error can still manifest because people, while using the new configs, may be pasting old connection strings from old configs.

So melanie is sort of correct in her usual subtle-as-a-sledgehammer style, but its probably just an old connection string people are using :)

(0017890)
danbanner (manager)
2011-01-24 09:18

The reason 'localhost' would not work is if there is no localhost entry in the hosts file.

- Issue History
Date Modified Username Field Change
2010-10-18 22:11 kenvc New Issue
2010-10-18 22:11 kenvc File Added: OSGridv0.7.1StartupError.jpg
2010-10-18 22:11 kenvc Git Revision => cd4d7a7c351ad78c13805374b46ea8168568d89e
2010-10-18 22:11 kenvc SVN Revision => 0
2010-10-18 22:11 kenvc Run Mode => Grid (Multiple Regions per Sim)
2010-10-18 22:11 kenvc Physics Engine => ODE
2010-10-18 22:11 kenvc Environment => .NET / Windows64
2010-10-18 22:11 kenvc Mono Version => None
2010-10-18 22:11 kenvc Summary 0.7.1 crashes after answering 1st estate question => 0.7.1 crashes after answering 1st estate question every time, not just 1st startup
2010-10-19 22:10 albertlr Note Added: 0017012
2010-10-21 13:53 nihlaeth Note Added: 0017046
2010-10-21 14:13 melanie Note Added: 0017047
2010-10-25 08:54 albertlr Note Edited: 0017012
2010-10-25 08:59 albertlr Note Edited: 0017012
2010-10-25 08:59 albertlr Note Edited: 0017012
2010-10-25 13:39 Licu Rau Note Added: 0017118
2010-10-25 13:49 DannyBisby Note Added: 0017119
2010-10-27 16:39 WhiteStar Note Added: 0017154
2010-10-28 04:30 Clinton Note Added: 0017160
2010-11-02 10:05 bld0112 Note Added: 0017238
2010-11-12 00:10 bld0112 Note Edited: 0017238
2010-11-24 06:36 Licu Rau Note Added: 0017378
2010-11-24 08:28 melanie Note Added: 0017380
2010-11-24 08:42 Licu Rau Note Edited: 0017378
2010-11-24 08:51 Licu Rau Note Added: 0017381
2010-12-06 14:01 Licu Rau Note Added: 0017441
2010-12-06 15:39 Licu Rau Note Edited: 0017441
2010-12-06 15:47 Licu Rau Note Edited: 0017381
2010-12-07 22:30 JoeRadik Note Added: 0017454
2010-12-09 17:46 JoeRadik Note Added: 0017492
2010-12-13 12:28 JoeRadik Note Added: 0017587
2010-12-13 21:17 kenvc Note Added: 0017590
2010-12-27 22:59 BreenWhitman Note Added: 0017693
2010-12-27 23:01 BreenWhitman Note Edited: 0017693
2011-01-24 09:18 danbanner Note Added: 0017890
2011-01-24 09:25 kenvc Status new => resolved
2011-01-24 09:25 kenvc Description Updated
2011-05-06 18:52 chi11ken Status resolved => closed


Copyright © 2000 - 2012 MantisBT Group
Powered by Mantis Bugtracker