Mantis Bug Tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0005094opensim[REGION] OpenSim Corepublic2010-10-17 21:322013-05-13 16:52
Reporterkenvc 
Assigned Tokenvc 
PriorityhighSeveritymajorReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version 
Target VersionFixed in Versionmaster (dev code) 
Summary0005094: 0.7.1 Continual spewing of exception processing byte arrays in SculptMap() System.ArgumentOutOfRangeException
DescriptionError spewing about sculptmaps. Problem still happening in almost ever case on all OSGrid .7.1 versions right after importing OARS files. This issue never happened on the osgrid 0.6.9 release. The error below continually spews:

OpenSim.Region.Physics.OdePlugin.OdeScene.BoraBora_C2 [PHYSICS]: Caught exception processing byte arrays in SculptMap(): e: System.ArgumentOutOfRangeException: Parameter must be positive and < Width.
Parameter name: x
Additional InformationThe following error message continualls spews in about 1/2 my regions shortly after loading oars:

2010-12-06 17:12:52,541 ERROR - OpenSim.Region.Physics.OdePlugin.OdeScene.BoraBora_C2 [PHYSICS]: Caught exception processing byte arrays in SculptMap(): e: System.ArgumentOutOfRangeException: Parameter must be positive and < Width.
Parameter name: x
   at System.Drawing.Bitmap.GetPixel(Int32 x, Int32 y)
   at PrimMesher.SculptMap..ctor(Bitmap bm, Int32 lod) in d:\OSGRID\OSGRID 0.7 RELEASES\osgrid.opensim-11182010.v0.7.1\OpenSim\Region\Physics\Meshing\SculptMap.cs:line 109, Void .ctor(System.Drawing.Bitmap, Int32), System.Exception: Caught exception processing byte arrays in SculptMap(): e: System.ArgumentOutOfRangeException: Parameter must be positive and < Width.
Parameter name: x
   at System.Drawing.Bitmap.GetPixel(Int32 x, Int32 y)
   at PrimMesher.SculptMap..ctor(Bitmap bm, Int32 lod) in d:\OSGRID\OSGRID 0.7 RELEASES\osgrid.opensim-11182010.v0.7.1\OpenSim\Region\Physics\Meshing\SculptMap.cs:line 109
   at PrimMesher.SculptMap..ctor(Bitmap bm, Int32 lod) in d:\OSGRID\OSGRID 0.7 RELEASES\osgrid.opensim-11182010.v0.7.1\OpenSim\Region\Physics\Meshing\SculptMap.cs:line 121
   at PrimMesher.SculptMesh._SculptMesh(Bitmap sculptBitmap, SculptType sculptType, Int32 lod, Boolean viewerMode, Boolean mirror, Boolean invert) in d:\OSGRID\OSGRID 0.7 RELEASES\osgrid.opensim-11182010.v0.7.1\OpenSim\Region\Physics\Meshing\SculptMesh.cs:line 299
   at PrimMesher.SculptMesh..ctor(Bitmap sculptBitmap, SculptType sculptType, Int32 lod, Boolean viewerMode, Boolean mirror, Boolean invert) in d:\OSGRID\OSGRID 0.7 RELEASES\osgrid.opensim-11182010.v0.7.1\OpenSim\Region\Physics\Meshing\SculptMesh.cs:line 185
   at OpenSim.Region.Physics.Meshing.Meshmerizer.CreateMeshFromPrimMesher(String primName, PrimitiveBaseShape primShape, Vector3 size, Single lod) in d:\OSGRID\OSGRID 0.7 RELEASES\osgrid.opensim-11182010.v0.7.1\OpenSim\Region\Physics\Meshing\Meshmerizer.cs:line 463
   at OpenSim.Region.Physics.Meshing.Meshmerizer.CreateMesh(String primName, PrimitiveBaseShape primShape, Vector3 size, Single lod, Boolean isPhysical) in d:\OSGRID\OSGRID 0.7 RELEASES\osgrid.opensim-11182010.v0.7.1\OpenSim\Region\Physics\Meshing\Meshmerizer.cs:line 634
   at OpenSim.Region.Physics.OdePlugin.OdePrim.changeadd(Single timestep) in d:\OSGRID\OSGRID 0.7 RELEASES\osgrid.opensim-11182010.v0.7.1\OpenSim\Region\Physics\OdePlugin\ODEPrim.cs:line 1435
   at OpenSim.Region.Physics.OdePlugin.OdePrim.ProcessTaints(Single timestep) in d:\OSGRID\OSGRID 0.7 RELEASES\osgrid.opensim-11182010.v0.7.1\OpenSim\Region\Physics\OdePlugin\ODEPrim.cs:line 866
   at OpenSim.Region.Physics.OdePlugin.OdeScene.Simulate(Single timeStep) in d:\OSGRID\OSGRID 0.7 RELEASES\osgrid.opensim-11182010.v0.7.1\OpenSim\Region\Physics\OdePlugin\OdePlugin.cs:line 2757
TagsNo tags attached.
Git Revision or version numbered26376
Run Mode Grid (Multiple Regions per Sim)
Physics EngineOther
Environment.NET / Windows64
Mono VersionNone
ViewerN/A
Attached Files

- Relationships
duplicate of 0005093closedkenvc 0.7.1 Continual spewing of exception processing byte arrays in SculptMap() System.ArgumentOutOfRangeException 
child of 0004704new Sculpted Prim ODE Physics Meshing error message flooding 

-  Notes
(0017443)
kenvc (reporter)
2010-12-06 15:24

Same old issue still happening as of 12/06/2010
(0017636)
kenvc (reporter)
2010-12-18 09:09

Problem still exists in 12/14/2010 release after loading oars.
(0017854)
manni99 (reporter)
2011-01-14 14:51

I originally submitted mantis 0004704 on 5/10/2010 because I was getting the same message. As I stated there, if I manually back out the changes to SculptMap.cs introduced by GIT eb6d63ab8ee1 (r12723), it fixes the problem for me.
(0017987)
kenvc (reporter)
2011-02-06 20:38

Still happening in 02/26/2011 release unless you save all your cache folders when doing a version update. Also happens after loading oars. Continual red spewing that wont stop unless you close the instance and restart it.
(0023891)
kenvc (reporter)
2013-05-13 16:52

The error spew was fixed some time ago.

- Issue History
Date Modified Username Field Change
2010-10-17 21:32 kenvc New Issue
2010-10-17 21:32 kenvc Git Revision => cd4d7a7
2010-10-17 21:32 kenvc SVN Revision => 0
2010-10-17 21:32 kenvc Run Mode => Grid (Multiple Regions per Sim)
2010-10-17 21:32 kenvc Physics Engine => Other
2010-10-17 21:32 kenvc Environment => .NET / Windows64
2010-10-17 21:32 kenvc Mono Version => None
2010-10-17 21:32 kenvc Issue generated from: 0005093
2010-10-17 21:36 kenvc Relationship added duplicate of 0005093
2010-10-18 06:05 kenvc Git Revision cd4d7a7 => cd4d7a7c351ad78c13805374b46ea8168568d89e
2010-10-18 06:05 kenvc Note Added: 0016968
2010-10-18 06:05 kenvc Summary 0.7.0.1 Continual spewing of exception processing byte arrays in SculptMap() System.ArgumentOutOfRangeException => 0.7.1 Continual spewing of exception processing byte arrays in SculptMap() System.ArgumentOutOfRangeException
2010-10-18 06:13 kenvc Note Deleted: 0016968
2010-12-06 14:39 kenvc Git Revision cd4d7a7c351ad78c13805374b46ea8168568d89e => 8f1a794
2010-12-06 14:39 kenvc Priority normal => high
2010-12-06 14:39 kenvc Description Updated
2010-12-06 14:40 kenvc Note Added: 0017442
2010-12-06 14:46 kenvc Note Deleted: 0017442
2010-12-06 15:24 kenvc Viewer => N/A
2010-12-06 15:24 kenvc Note Added: 0017443
2010-12-06 15:24 kenvc Status new => confirmed
2010-12-06 15:24 kenvc Description Updated
2010-12-06 15:24 kenvc Additional Information Updated
2010-12-18 09:09 kenvc Git Revision 8f1a794 => ed26376
2010-12-18 09:09 kenvc Note Added: 0017636
2011-01-05 15:28 kenvc Relationship added child of 0004704
2011-01-14 14:51 manni99 Note Added: 0017854
2011-02-06 20:38 kenvc Note Added: 0017987
2013-05-13 16:52 kenvc Note Added: 0023891
2013-05-13 16:52 kenvc Status confirmed => resolved
2013-05-13 16:52 kenvc Fixed in Version => master (dev code)
2013-05-13 16:52 kenvc Resolution open => fixed
2013-05-13 16:52 kenvc Assigned To => kenvc
2013-05-13 16:52 kenvc Status resolved => closed


Copyright © 2000 - 2012 MantisBT Group
Powered by Mantis Bugtracker