Mantis Bug Tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0005093opensim[REGION] OpenSim Corepublic2010-10-17 21:152013-05-13 16:50
Reporterkenvc 
Assigned Tokenvc 
PrioritynormalSeveritymajorReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version 
Target VersionFixed in Versionmaster (dev code) 
Summary0005093: 0.7.1 Continual spewing of exception processing byte arrays in SculptMap() System.ArgumentOutOfRangeException
DescriptionThis problem did not exist in the latest osgrid 0.6.9 release. Here is a quick summary:

ERROR - OpenSim.Region.Physics.OdePlugin.OdeScene.BoraBora Mansion [PHYSICS]: Caught exception processing byte arrays in SculptMap(): e: System.ArgumentOutOfRangeException: Parameter must be positive and < Width.
Parameter name: x

The full text of the error that repeats continually over and over is included in the additional information section below. The eror messages fill up the log file to over 100 meg in just a few minutes so the instance has to be shutdown or the hard drive will be consumed by the log file.

This version ran fine on Danger grid the first few times I ran it, then after importing the oars files into this instance the erros started. Restarting the instance does not help. The errors are continual.
Additional Information2010-10-17 22:34:13,684 ERROR - OpenSim.Region.Physics.OdePlugin.OdeScene.BoraBora Mansion [PHYSICS]: Caught exception processing byte arrays in SculptMap(): e: System.ArgumentOutOfRangeException: Parameter must be positive and < Width.
Parameter name: x
   at System.Drawing.Bitmap.GetPixel(Int32 x, Int32 y)
   at PrimMesher.SculptMap..ctor(Bitmap bm, Int32 lod) in d:\OSGRID\DANGER RELEASES\opensim-cd4d7a7\OpenSim\Region\Physics\Meshing\SculptMap.cs:line 109, Void .ctor(System.Drawing.Bitmap, Int32), System.Exception: Caught exception processing byte arrays in SculptMap(): e: System.ArgumentOutOfRangeException: Parameter must be positive and < Width.
Parameter name: x
   at System.Drawing.Bitmap.GetPixel(Int32 x, Int32 y)
   at PrimMesher.SculptMap..ctor(Bitmap bm, Int32 lod) in d:\OSGRID\DANGER RELEASES\opensim-cd4d7a7\OpenSim\Region\Physics\Meshing\SculptMap.cs:line 109
   at PrimMesher.SculptMap..ctor(Bitmap bm, Int32 lod) in d:\OSGRID\DANGER RELEASES\opensim-cd4d7a7\OpenSim\Region\Physics\Meshing\SculptMap.cs:line 121
   at PrimMesher.SculptMesh._SculptMesh(Bitmap sculptBitmap, SculptType sculptType, Int32 lod, Boolean viewerMode, Boolean mirror, Boolean invert) in d:\OSGRID\DANGER RELEASES\opensim-cd4d7a7\OpenSim\Region\Physics\Meshing\SculptMesh.cs:line 299
   at PrimMesher.SculptMesh..ctor(Bitmap sculptBitmap, SculptType sculptType, Int32 lod, Boolean viewerMode, Boolean mirror, Boolean invert) in d:\OSGRID\DANGER RELEASES\opensim-cd4d7a7\OpenSim\Region\Physics\Meshing\SculptMesh.cs:line 185
   at OpenSim.Region.Physics.Meshing.Meshmerizer.CreateMeshFromPrimMesher(String primName, PrimitiveBaseShape primShape, Vector3 size, Single lod) in d:\OSGRID\DANGER RELEASES\opensim-cd4d7a7\OpenSim\Region\Physics\Meshing\Meshmerizer.cs:line 419
   at OpenSim.Region.Physics.Meshing.Meshmerizer.CreateMesh(String primName, PrimitiveBaseShape primShape, Vector3 size, Single lod, Boolean isPhysical) in d:\OSGRID\DANGER RELEASES\opensim-cd4d7a7\OpenSim\Region\Physics\Meshing\Meshmerizer.cs:line 590
   at OpenSim.Region.Physics.OdePlugin.OdePrim.changeadd(Single timestep) in d:\OSGRID\DANGER RELEASES\opensim-cd4d7a7\OpenSim\Region\Physics\OdePlugin\ODEPrim.cs:line 1435
   at OpenSim.Region.Physics.OdePlugin.OdePrim.ProcessTaints(Single timestep) in d:\OSGRID\DANGER RELEASES\opensim-cd4d7a7\OpenSim\Region\Physics\OdePlugin\ODEPrim.cs:line 866
   at OpenSim.Region.Physics.OdePlugin.OdeScene.Simulate(Single timeStep) in d:\OSGRID\DANGER RELEASES\opensim-cd4d7a7\OpenSim\Region\Physics\OdePlugin\OdePlugin.cs:line 2757
TagsNo tags attached.
Git Revision or version numbercd4d7a7c351ad78c13805374b46ea8168568d89e
Run Mode Grid (Multiple Regions per Sim)
Physics EngineOther
Environment.NET / Windows64
Mono VersionNone
Viewer
Attached Files? file icon sculpty.tga [^] (3,090 bytes) 2010-10-21 15:47

- Relationships
has duplicate 0005094closedkenvc 0.7.1 Continual spewing of exception processing byte arrays in SculptMap() System.ArgumentOutOfRangeException 
has duplicate 0005296new Broken sculpties handling. 

-  Notes
(0016969)
kenvc (reporter)
2010-10-18 06:07
edited on: 2010-10-18 06:12

After several hours of having the system offline, the problem appeared to go away for a few minutes but now it is back as bad as ever. Having to take the sim offline that has this prblem.

(0016986)
wayne dawner (reporter)
2010-10-18 17:16
edited on: 2010-10-18 17:35

I have found an interesting fix for this and have no idea why it works.
At the console of the spewing sim do a save oar and wait till the oar is finished then do a load oar of that file.
Spewing quits.

Interesting also is that this fix does not work with Cenome cache

(0017000)
AdelleF (reporter)
2010-10-19 13:04

I can confirm this in 0.7.1 (Dev) cd4d7a7
Windows 32bit .NET
Grid, ODE, Meshmerizer.

This started after a migration from 0.6.9PF to 0.7.1 (OSgrid binary dist)
Out of 10 simulators only one was affected. I have heard several other reports from people that have migrated from 0.6.9 to 0.7.1 that they are also experiencing this.

As wayne mentioned, loading an oar does stop this, but after a restart the red spew continues (or at least in my case)

Changing to zeromesher stops the red spew.
Changing CacheSculptMaps = true/false has no effect
Changing mesh_sculpted_prim = true to false does stop the spew, and I am currently using that as a workaround.
(0017002)
Marcus Llewellyn (reporter)
2010-10-19 13:15

What stopped the error for me was to allow the sim to come all the way up, all the while catching the exception. Once up, I *killed* (not a clean shutdown) OpenSim. When I brought it back up, the exception no longer happened.
(0017003)
wayne dawner (reporter)
2010-10-19 13:16

In my instances the regions can be restarted without spew. Just shows the errors loading the sculpt. But using Cenome Cache the Errors recur.
(0017004)
WordfromtheWise (reporter)
2010-10-19 13:22
edited on: 2010-10-19 14:58

for me the solution was the change from true to false in openism.ini:

[ODEPhysicsSettings]
    ;# {mesh_sculpted_prim} {[Startup]physics:OpenDynamicsEngine} {Mesh sculpties so they collide as they look?} {true false} true
    ;; Do we want to mesh sculpted prim to collide like they look?
    mesh_sculpted_prim = false

after that the sim came up with no error and all is ok ..

Thanks to AdelleF

my Setup:
Windows 2003 64-bit Server
Database : Sqlite opensim.db file(s)
recommended .7 version from osgdrid website
the day after migration ( OpenSim 0.7.1 Dev )

(0017005)
AdelleF (reporter)
2010-10-19 13:23
edited on: 2010-10-19 13:43

I have tried all of the above and more, and the only thing that stopped it for me was either changing the mesher or disabling sculpt meshes.

It would be great to know what sculpt map is doing this, a UUID or even prim location, then I could submit it here, or place it on other regions for further testing to see if it actually a corrupt sculpt map.

ETA: I did not initially import an oar. This was an error right after a successful migration to 0.7.1. I only performed the load oar to see if it would resolve the issue.

(0017006)
Ken Grunke (reporter)
2010-10-19 14:11
edited on: 2010-10-19 17:05

You can stop it inworld by Disabling physics in the Debug tab, in World/Region-Estate window.

I noticed this back in August when I first started playing with 0.7. I asked Nebadon and he thought it was caused by 32x32 sculptmaps. I successfully stopped the red spew by scouring my sim for such maps and deleting them.

(0017007)
WordfromtheWise (reporter)
2010-10-19 14:51
edited on: 2010-10-19 14:52

@Ken Grunke .. can you try setting

mesh_sculpted_prim = false
and
meshing = Meshmerizer

in the opensim.ini ...

red spew should be gone than ?

(0017008)
Ken Grunke (reporter)
2010-10-19 14:53

I can verify on my osgrid sim that 32x32 sculptymaps cause this error.
I dug up 3 such maps (I rarely used them, so had to search a bit) and created sculpties with them. Upon dropping a sculptymap on the first prim, 18 lines of red appeared in the console pretty much the same as posted above, but it didn't spew. Same with two more 32x32 maps.
Upon restart of the sim, the spew began with a fury. Deleting the 3 culprits did not stop the spew until another restart of the sim.

Linux Kubuntu 10.04 32-bit system/Mono 2.4.2.3; Sqlite on Osgrid's binary release from 10/15.2010
(0017009)
wayne dawner (reporter)
2010-10-19 16:03

look at mantis 4704
(0017011)
Ken Grunke (reporter)
2010-10-19 18:36

I have to correct my last post, my error was similar to this but not the same. Here it is after creating a sculpty with one of my 32x32 bitmaps created in Wings 3D (the last bit is amusing):

16:14:12 - [PHYSICS]: Caught exception processing byte arrays in SculptMap(): e: System.ArgumentException: A null reference or invalid value was found [GDI+ status: InvalidParameter]
  at System.Drawing.GDIPlus.CheckStatus (Status status) [0x00000]
  at System.Drawing.Bitmap.GetPixel (Int32 x, Int32 y) [0x00000]
  at (wrapper remoting-invoke-with-check) System.Drawing.Bitmap:GetPixel (int,int)
  at PrimMesher.SculptMap..ctor (System.Drawing.Bitmap bm, Int32 lod) [0x00000] , Void .ctor(Bitmap, Int32), System.Exception: Caught exception processing byte arrays in SculptMap(): e: System.ArgumentException: A null reference or invalid value was found [GDI+ status: InvalidParameter]
  at System.Drawing.GDIPlus.CheckStatus (Status status) [0x00000]
  at System.Drawing.Bitmap.GetPixel (Int32 x, Int32 y) [0x00000]
  at (wrapper remoting-invoke-with-check) System.Drawing.Bitmap:GetPixel (int,int)
  at PrimMesher.SculptMap..ctor (System.Drawing.Bitmap bm, Int32 lod) [0x00000]
  at PrimMesher.SculptMap..ctor (System.Drawing.Bitmap bm, Int32 lod) [0x00000]
  at PrimMesher.SculptMesh._SculptMesh (System.Drawing.Bitmap sculptBitmap, SculptType sculptType, Int32 lod, Boolean viewerMode, Boolean mirror, Boolean invert) [0x00000]
  at PrimMesher.SculptMesh..ctor (System.Drawing.Bitmap sculptBitmap, SculptType sculptType, Int32 lod, Boolean viewerMode, Boolean mirror, Boolean invert) [0x00000]
  at OpenSim.Region.Physics.Meshing.Meshmerizer.CreateMeshFromPrimMesher (System.String primName, OpenSim.Framework.PrimitiveBaseShape primShape, Vector3 size, Single lod) [0x00000]
  at OpenSim.Region.Physics.Meshing.Meshmerizer.CreateMesh (System.String primName, OpenSim.Framework.PrimitiveBaseShape primShape, Vector3 size, Single lod, Boolean isPhysical) [0x00000]
  at OpenSim.Region.Physics.OdePlugin.OdePrim.changeshape (Single timestamp) [0x00000]
  at OpenSim.Region.Physics.OdePlugin.OdePrim.ProcessTaints (Single timestep) [0x00000]
  at OpenSim.Region.Physics.OdePlugin.OdeScene.Simulate (Single timeStep) [0x00000]
16:14:12 - [PHYSICS]: The scene reused a disposed PhysActor for Primitive/6640719e-cc60-4e7e-aaeb-6af0c4ad5b16! *waves finger*, Don't be evil. A couple of things can cause this. An improper prim breakdown(be sure to set prim_geom to zero after d.GeomDestroy! An improper buildup (creating the geom failed). Or, the Scene Reused a physics actor after disposing it.)

--

I wasn't able to reproduce the red spew after a second try at creating the sculpty, even after a restart with leaving the sculpty out - only the error immediately after the creation.
(0017017)
Ken Grunke (reporter)
2010-10-20 11:59

OSGrid admin advises the following for sculptymap-related console spew: "When you are sure the sim has loaded restart your sim you may need to close the console or end task on the process, this problem should only happen on the initial startup, then never again."

Seems that the issue, although not really resolved, is under control--I haven't seen it again.
(0017021)
jfhopkin (reporter)
2010-10-20 16:20

Encountered this here too - fixed by setting mesh_sculpted_prim = false (thanks, WordfromtheWise).
(0017051)
AdelleF (reporter)
2010-10-21 15:47

For some strange reason the red spew is intermittant. The times when it doesn't spew on startup it gives me a much more informal error (below), including object uuid. I have found the actual sculpty that is causing this and attached the sculpt map to this mantis. Removing the object from my region has completely stopped any spew or errors.


2010-10-21 23:42:31,054 ERROR - OpenSim.Region.Physics.OdePlugin.OdeScene.Dreamtech Temp [PHYSICS]: Exception while meshing prim Primitive/d41ca429-e8ab-461e-aed2-26cbfbe3f23e.
2010-10-21 23:42:31,070 DEBUG - OpenSim.Region.Physics.OdePlugin.OdeScene.Dreamtech Temp System.Exception: Caught exception processing byte arrays in SculptMap(): e: System.ArgumentOutOfRangeException: Parameter must be positive and < Width.
Parameter name: x
   at System.Drawing.Bitmap.GetPixel(Int32 x, Int32 y)
   at PrimMesher.SculptMap..ctor(Bitmap bm, Int32 lod) in c:\opensim\OpenSim\Region\Physics\Meshing\SculptMap.cs:line 109
   at PrimMesher.SculptMap..ctor(Bitmap bm, Int32 lod) in c:\opensim\OpenSim\Region\Physics\Meshing\SculptMap.cs:line 121
   at PrimMesher.SculptMesh._SculptMesh(Bitmap sculptBitmap, SculptType sculptType, Int32 lod, Boolean viewerMode, Boolean mirror, Boolean invert) in c:\opensim\OpenSim\Region\Physics\Meshing\SculptMesh.cs:line 299
   at PrimMesher.SculptMesh..ctor(Bitmap sculptBitmap, SculptType sculptType, Int32 lod, Boolean viewerMode, Boolean mirror, Boolean invert) in c:\opensim\OpenSim\Region\Physics\Meshing\SculptMesh.cs:line 185
   at OpenSim.Region.Physics.Meshing.Meshmerizer.CreateMeshFromPrimMesher(String primName, PrimitiveBaseShape primShape, Vector3 size, Single lod) in c:\opensim\OpenSim\Region\Physics\Meshing\Meshmerizer.cs:line 463
   at OpenSim.Region.Physics.Meshing.Meshmerizer.CreateMesh(String primName, PrimitiveBaseShape primShape, Vector3 size, Single lod, Boolean isPhysical) in c:\opensim\OpenSim\Region\Physics\Meshing\Meshmerizer.cs:line 634
   at OpenSim.Region.Physics.OdePlugin.OdeScene.AddPrimShape(String primName, PrimitiveBaseShape pbs, Vector3 position, Vector3 size, Quaternion rotation, Boolean isPhysical) in c:\opensim\OpenSim\Region\Physics\OdePlugin\OdePlugin.cs:line 1777
2010-10-21 23:42:31,070 DEBUG - OpenSim.Region.Framework.Scenes.SceneObjectPart [SOP]: physics actor is null for d41ca429-e8ab-461e-aed2-26cbfbe3f23e with parent d41ca429-e8ab-461e-aed2-26cbfbe3f23e
(0018135)
Katan Lorefield (reporter)
2011-03-16 10:18
edited on: 2011-03-16 10:22

I have run into a similar problem when sculpty maps are rezzed, but only at that point and during restart. It has been happening for me up to and including ver 0.7.1.dev.b82b0b1. Problem has occured on both Windows Vista 64bit (4-core processor, 3GB ram) and Ubuntu 32bit (2-core processor, 1GB ram). In both instances per WordfromtheWise's post, I changed the opensim.ini setting "mesh_sculpted_prim = true" to false. Subsequent tests with the same sculpties shows problem has been resolved on both platforms.

*added note, Ubuntu is version 10.10

(0023890)
kenvc (reporter)
2013-05-13 16:50

The problem with the spew was fixed some time ago, so closing issue.

- Issue History
Date Modified Username Field Change
2010-10-17 21:15 kenvc New Issue
2010-10-17 21:15 kenvc Git Revision => cd4d7a7
2010-10-17 21:15 kenvc SVN Revision => 0
2010-10-17 21:15 kenvc Run Mode => Grid (Multiple Regions per Sim)
2010-10-17 21:15 kenvc Physics Engine => Other
2010-10-17 21:15 kenvc Environment => .NET / Windows64
2010-10-17 21:15 kenvc Mono Version => None
2010-10-17 21:32 kenvc Issue cloned: 0005094
2010-10-17 21:34 kenvc Summary 0.7.1 Continual spewing of exception processing byte arrays in SculptMap() System.ArgumentOutOfRangeException => 0.7.0.1 Continual spewing of exception processing byte arrays in SculptMap() System.ArgumentOutOfRangeException
2010-10-17 21:36 kenvc Relationship added has duplicate 0005094
2010-10-18 06:07 kenvc Git Revision cd4d7a7 => cd4d7a7c351ad78c13805374b46ea8168568d89e
2010-10-18 06:07 kenvc Note Added: 0016969
2010-10-18 06:07 kenvc Summary 0.7.0.1 Continual spewing of exception processing byte arrays in SculptMap() System.ArgumentOutOfRangeException => 0.7.1 Continual spewing of exception processing byte arrays in SculptMap() System.ArgumentOutOfRangeException
2010-10-18 06:12 kenvc Note Edited: 0016969
2010-10-18 17:16 wayne dawner Note Added: 0016986
2010-10-18 17:35 wayne dawner Note Edited: 0016986
2010-10-19 13:04 AdelleF Note Added: 0017000
2010-10-19 13:15 Marcus Llewellyn Note Added: 0017002
2010-10-19 13:16 wayne dawner Note Added: 0017003
2010-10-19 13:22 WordfromtheWise Note Added: 0017004
2010-10-19 13:23 AdelleF Note Added: 0017005
2010-10-19 13:24 WordfromtheWise Note Edited: 0017004
2010-10-19 13:43 AdelleF Note Edited: 0017005
2010-10-19 14:11 Ken Grunke Note Added: 0017006
2010-10-19 14:51 WordfromtheWise Note Added: 0017007
2010-10-19 14:52 WordfromtheWise Note Edited: 0017007
2010-10-19 14:53 Ken Grunke Note Added: 0017008
2010-10-19 14:58 WordfromtheWise Note Edited: 0017004
2010-10-19 16:03 wayne dawner Note Added: 0017009
2010-10-19 17:05 Ken Grunke Note Edited: 0017006
2010-10-19 18:36 Ken Grunke Note Added: 0017011
2010-10-20 11:59 Ken Grunke Note Added: 0017017
2010-10-20 16:20 jfhopkin Note Added: 0017021
2010-10-21 10:12 wayne dawner Note Added: 0017043
2010-10-21 10:38 wayne dawner Note Deleted: 0017043
2010-10-21 15:47 AdelleF File Added: sculpty.tga
2010-10-21 15:47 AdelleF Note Added: 0017051
2011-01-03 14:07 Tokeiito Relationship added child of 0005296
2011-01-03 14:11 Tokeiito Relationship deleted child of 0005296
2011-01-03 14:12 Tokeiito Relationship added has duplicate 0005296
2011-03-16 10:18 Katan Lorefield Note Added: 0018135
2011-03-16 10:19 Katan Lorefield Note Edited: 0018135
2011-03-16 10:22 Katan Lorefield Note Edited: 0018135
2013-05-13 16:50 kenvc Note Added: 0023890
2013-05-13 16:50 kenvc Status new => resolved
2013-05-13 16:50 kenvc Fixed in Version => master (dev code)
2013-05-13 16:50 kenvc Resolution open => fixed
2013-05-13 16:50 kenvc Assigned To => kenvc
2013-05-13 16:50 kenvc Status resolved => closed


Copyright © 2000 - 2012 MantisBT Group
Powered by Mantis Bugtracker