Mantis Bug Tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0005012opensim[REGION] Physics Enginespublic2010-09-01 10:592010-09-01 10:59
Reporterjanine serpente 
Assigned To 
PrioritynormalSeveritymajorReproducibilityalways
StatusnewResolutionopen 
PlatformOSOS Version
Product Version 
Target VersionFixed in Version 
Summary0005012: vehicle physics not operating the same as SL
Descriptionthis is my second Mantis about the same function

llSetVehicleVectorParam( VEHICLE_ANGULAR_MOTOR_DIRECTION , v )

This is specifically related to using a BOAT type vehicle, I have not tested other vehicle types yet, but;

The scale of the angular forces appears to be completely different to SL.
values of say 75.0 in SL turn at a normal rate, and cause opensim/ODE to spin like crazy and lose the vehicle into no-mans land.

dividing by 100 or so makes opensim behave more like SL.

This prevents scripts from SL being run without modification on opensim/ODE.
TagsNo tags attached.
Git Revision or version numberI don't know what this means, but I have tested on 0.69 and 0.7x
Run ModeStandalone (1 Region)
Physics EngineODE
Script Engine
EnvironmentUnknown
Mono VersionNone
Viewer
Attached Files

- Relationships

-  Notes
There are no notes attached to this issue.

- Issue History
Date Modified Username Field Change
2010-09-01 10:59 janine serpente New Issue
2010-09-01 10:59 janine serpente Git Revision => I don't know what this means, but I have tested on 0.69 and 0.7x
2010-09-01 10:59 janine serpente SVN Revision => 0
2010-09-01 10:59 janine serpente Run Mode => Standalone (1 Region)
2010-09-01 10:59 janine serpente Physics Engine => ODE
2010-09-01 10:59 janine serpente Environment => Unknown
2010-09-01 10:59 janine serpente Mono Version => None


Copyright © 2000 - 2012 MantisBT Group
Powered by Mantis Bugtracker