Mantis Bug Tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0004977opensim[REGION] OpenSim Corepublic2010-08-25 07:052010-10-27 20:37
Reporteraiaustin 
Assigned Tojustincc 
PrioritynormalSeverityminorReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version 
Target VersionFixed in Versionmaster (dev code) 
Summary0004977: UUID GATHERER Failed to get part - System.NullReferenceException
Description15:01:30 - [COMMANDFILE]: Running 'fcache assets'
15:01:30 - [FLOTSAM ASSET CACHE]: Caching all assets, in all scenes.
15:01:31 - [UUID GATHERER]: Failed to get part - System.NullReferenceException:
Object reference not set to an instance of an object.
15:01:31 - [UUID GATHERER]: Texture entry length for prim was 46 (min is 46)
15:01:31 - [UUID GATHERER]: Failed to get part - System.NullReferenceException:
Object reference not set to an instance of an object.
15:01:31 - [UUID GATHERER]: Texture entry length for prim was 65 (min is 46)
15:01:31 - [FLOTSAM ASSET CACHE]: Completed Scene Caching, 724 assets found.
Additional InformationSame error is given when creating an OAR in the same region.
TagsNo tags attached.
Git Revision or version number0.7.0.1 post-fixes
Run Mode Grid (Multiple Regions per Sim)
Physics EngineODE
Environment.NET / Windows32
Mono VersionNone
Viewer
Attached Filesjpg file icon hg-object-causing-issue-4977.jpg [^] (120,473 bytes) 2010-08-26 08:26

- Relationships

-  Notes
(0016596)
aiaustin (developer)
2010-08-25 08:01

Full trace of one instance of the error from OpenSim.log:

2010-08-25 15:01:19,030 ERROR - OpenSim.Region.Framework.Scenes.UuidGatherer [UUID GATHERER]: Failed to get part - System.NullReferenceException: Object reference not set to an instance of an object.

   at OpenSim.Region.Framework.Scenes.UuidGatherer.GetGestureAssetUuids(UUID gestureUuid, IDictionary`2 assetUuids) in d:\Temp\OpenSim\Region\Framework\Scenes\UuidGatherer.cs:line 295

   at OpenSim.Region.Framework.Scenes.UuidGatherer.GatherAssetUuids(UUID assetUuid, AssetType assetType, IDictionary`2 assetUuids) in d:\Temp\OpenSim\Region\Framework\Scenes\UuidGatherer.cs:line 97

   at OpenSim.Region.Framework.Scenes.UuidGatherer.GatherAssetUuids(SceneObjectGroup sceneObject, IDictionary`2 assetUuids) in d:\Temp\OpenSim\Region\Framework\Scenes\UuidGatherer.cs:line 163
(0016611)
aiaustin (developer)
2010-08-26 01:15
edited on: 2010-08-26 01:28

I have tracked this down to a single region, which is one of the Openvue hypergrid gateway regions - Vue-5000. The error occurs on that region only and shows up when doing a cache of the assets or making an OAR.

I am aware of one change on that region. I deleted one of two objects placed by a hypergrid traveller. The object has visually disappeared after it was deleted. It was a single cube textured with a single texture. No script in it. Just a visitor marker.

09:04:25 - [COMMANDFILE]: Running 'fcache assets'
09:04:25 - [FLOTSAM ASSET CACHE]: Caching all assets, in all scenes.
09:04:26 - [UUID GATHERER]: Failed to get part - System.NullReferenceException:
Object reference not set to an instance of an object.
09:04:26 - [UUID GATHERER]: Texture entry length for prim was 65 (min is 46)
09:04:26 - [FLOTSAM ASSET CACHE]: Completed Scene Caching, 728 assets found.

Currently selected region is Vue-5000
Region (Vue-5000) # save oar aa.oar
09:03:25 - [ARCHIVER]: Writing archive for region Vue-5000 to aa.oar
09:03:25 - [UUID GATHERER]: Failed to get part - System.NullReferenceException:
Object reference not set to an instance of an object.
09:03:25 - [UUID GATHERER]: Texture entry length for prim was 65 (min is 46)
09:03:25 - [ARCHIVER]: 12 scene objects to serialize requiring save of 57 assets

09:03:25 - [ARCHIVER]: AssetsRequest executed looking for 57 assets
09:03:25 - [ARCHIVER]: Added 50 assets to archive
09:03:25 - [ARCHIVER]: Successfully added 55 assets (2 assets notified missing)
09:03:25 - [ARCHIVER]: Could not find asset 89556747-24cb-920b-43ed-47caed15465f

09:03:25 - [ARCHIVER]: Could not find asset cddc51a1-f1ba-4078-a53f-81236b1d73e4

09:03:25 - [ARCHIVER]: Creating archive file. This may take some time.
09:03:25 - [ARCHIVER]: Added control file to archive.
09:03:25 - [ARCHIVER]: Added region settings to archive.
09:03:25 - [ARCHIVER]: Added parcel settings to archive.
09:03:25 - [ARCHIVER]: Added terrain information to archive.
09:03:25 - [ARCHIVER]: Added scene objects to archive.

(0016612)
aiaustin (developer)
2010-08-26 01:33

It would be useful to have the usual UUID/name of the object and its region and location in the diagnostic.

09:30:03 - [UUID GATHERER]: Failed to get part - System.NullReferenceException:
Object reference not set to an instance of an object.

There are only a few dozen objects on the region affected, but it is unclear which is causing the problem. An essentially identical set of assets are on another gateway region and that saves without error.
(0016615)
aiaustin (developer)
2010-08-26 07:33
edited on: 2010-08-26 08:26

Object identified as a single prim cube with a two textures used on the faces. Left by a hypergrid traveller under HG1.5. See image attached.
When it was deleted the error message on cache and save oar went away.

(0016663)
Karen Palen (reporter)
2010-08-28 05:02

Similar problem to above, but I am unable to identify the actual objects. There are 4 HG objects left by visitors, but I am unable to verify their UUIDs.

No asset in the database has any of the 4 UUIDs as you might expect.

The objects appear normal otherwise.

Region (MarsSim 1) # save oar
04:52:07 - [ARCHIVER]: Writing archive for region MarsSim 1 to region.oar
04:52:07 - [UUID GATHERER]: Failed to get part - System.NullReferenceException: Object reference not set to an instance of an object
  at OpenSim.Region.Framework.Scenes.UuidGatherer.GetGestureAssetUuids (UUID gestureUuid, IDictionary`2 assetUuids) [0x00000]
  at OpenSim.Region.Framework.Scenes.UuidGatherer.GatherAssetUuids (UUID assetUuid, AssetType assetType, IDictionary`2 assetUuids) [0x00000]
  at OpenSim.Region.Framework.Scenes.UuidGatherer.GatherAssetUuids (OpenSim.Region.Framework.Scenes.SceneObjectGroup sceneObject, IDictionary`2 assetUuids) [0x00000]
04:52:07 - [UUID GATHERER]: Texture entry length for prim was 65 (min is 46)
04:52:07 - [ARCHIVER]: 37 scene objects to serialize requiring save of 74 assets
04:52:07 - [ARCHIVER]: AssetsRequest executed looking for 75 assets
04:52:07 - [ARCHIVER]: Added 50 assets to archive
04:52:07 - [ARCHIVER]: Successfully added 71 assets (4 assets notified missing)
04:52:07 - [ARCHIVER]: Could not find asset cddc51a1-f1ba-4078-a53f-81236b1d73e4
04:52:07 - [ARCHIVER]: Could not find asset efaaee6b-7912-4fde-8b50-26cbebcb187d
04:52:07 - [ARCHIVER]: Could not find asset b4e51e59-e9a0-4430-ba4f-69c04a81d76c
04:52:07 - [ARCHIVER]: Could not find asset aae69e09-f2eb-4ade-a08d-9616a026ee9b
(0016664)
Karen Palen (reporter)
2010-08-28 05:06
edited on: 2010-08-28 05:11

By inspection I note that one of aiausten's objects corresponds to one of mine!

"Could not find asset cddc51a1-f1ba-4078-a53f-81236b1d73e4"

Since we both have the flag in question this would tend to identify that object as the culprit. The flag edits, "takes" and re-rezzes normally.

After rezzing a new copy of the flag, the same 4 items are flagged as not found (i.e. the newly rezzed flag appears to save correctly)

(0016668)
aiaustin (developer)
2010-08-28 10:17
edited on: 2010-08-28 14:39

I think the System.NullReferenceException: may be on a cube with object name "Mentolyptus Was Here :) (new port 8002)" and not the flag, as I deleted the same flags you have on MarsSim 1 and still had the error. It was only when I deleted the cube that the System.NullReferenceException: went away.

It looks like hypergrid objects or the texures on them might not be being handled correctly in some OpenSim functions like fcache assets and save oar.

(0016886)
justincc (administrator)
2010-09-24 16:03

Addressed in b366ad5012e6. However, this exception was generated because the asset describing the metadata for a gesture in that box simply isn't present with no way to recover it.

- Issue History
Date Modified Username Field Change
2010-08-25 07:05 aiaustin New Issue
2010-08-25 07:05 aiaustin Git Revision => 0.7.0.1 post-fixes
2010-08-25 07:05 aiaustin SVN Revision => 13708
2010-08-25 07:05 aiaustin Run Mode => Grid (Multiple Regions per Sim)
2010-08-25 07:05 aiaustin Physics Engine => ODE
2010-08-25 07:05 aiaustin Environment => .NET / Windows32
2010-08-25 07:05 aiaustin Mono Version => None
2010-08-25 07:06 aiaustin Additional Information Updated
2010-08-25 07:45 melanie Summary [UUID GATHERER]: Failed to get part - System.NullReferenceException => UUID GATHERER Failed to get part - System.NullReferenceException
2010-08-25 08:01 aiaustin Note Added: 0016596
2010-08-25 09:54 justincc Status new => assigned
2010-08-25 09:54 justincc Assigned To => justincc
2010-08-26 01:15 aiaustin Note Added: 0016611
2010-08-26 01:28 aiaustin Note Edited: 0016611
2010-08-26 01:33 aiaustin Note Added: 0016612
2010-08-26 03:58 aiaustin Additional Information Updated
2010-08-26 07:33 aiaustin Note Added: 0016615
2010-08-26 08:26 aiaustin File Added: hg-object-causing-issue-4977.jpg
2010-08-26 08:26 aiaustin Note Edited: 0016615
2010-08-26 08:27 aiaustin Additional Information Updated
2010-08-28 05:02 Karen Palen Note Added: 0016663
2010-08-28 05:06 Karen Palen Note Added: 0016664
2010-08-28 05:11 Karen Palen Note Edited: 0016664
2010-08-28 10:17 aiaustin Note Added: 0016668
2010-08-28 10:18 aiaustin Note Edited: 0016668
2010-08-28 14:39 aiaustin Note Edited: 0016668
2010-09-24 16:03 justincc Status assigned => resolved
2010-09-24 16:03 justincc Fixed in Version => master (dev code)
2010-09-24 16:03 justincc Resolution open => fixed
2010-09-24 16:03 justincc Note Added: 0016886
2010-10-27 20:37 chi11ken Status resolved => closed


Copyright © 2000 - 2012 MantisBT Group
Powered by Mantis Bugtracker