Mantis Bug Tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0004975opensim[REGION] OpenSim Corepublic2010-08-25 02:532012-02-11 05:14
Reportermarkidcas 
Assigned To 
PrioritynormalSeverityminorReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version 
Target VersionFixed in Versionmaster (dev code) 
Summary0004975: Estate covenant overwritten on restart
DescriptionNearly every time a grid using 0.7 RC1 is restarted the covenants for all regions disappear.
TagsNo tags attached.
Git Revision or version number0.7 RC1
Run Mode Grid (Multiple Regions per Sim)
Physics EngineODE
EnvironmentMono / Linux64
Mono Version2.10
Viewer
Attached Filestxt file icon covenant.txt [^] (817 bytes) 2010-08-28 05:35 [Show Content]

- Relationships
has duplicate 0002879closedBlueWall Covenant fails because of garbadeg notecard (database inconsistency ?) 

-  Notes
(0016665)
Marck (reporter)
2010-08-28 05:35

I see the same issue on a hypergrid-enabled standalone running OpenSim 0.7.1 revision 374807d19421963a5ff842513079f94a3044bfa9 (r/13751).

After a restart, the region's covenant field has the following content: "Problem importing estate covenant: Covenant file format error."

In my inventory, the notecard that I had used for setting the covenant does not contain the original text anymore but has been overwritten with the text that I have attached to this report (covenant.txt).
(0016669)
markidcas (reporter)
2010-08-28 11:28

Thats a very weird problem Marck, did you try using a different (new) notecard and if so did the new notecard become corrupted also? The content of your notecard seems to be replaced by the settings for a users attachment.

Well in our case there is no notecard problem at all. The covenant updates fine while the grid is up and running but then when the grid is shutdown-restarted the settings go back to "There is no covenant for this region", so seem to be different problems.
(0016670)
smxy (reporter)
2010-08-28 11:36

I have seen Marck's issue. It's a very old one.
(0020858)
Pixel Tomsen (manager)
2012-02-10 22:28

http://opensimulator.org/mantis/view.php?id=2879 [^]

- Issue History
Date Modified Username Field Change
2010-08-25 02:53 markidcas New Issue
2010-08-25 02:53 markidcas Git Revision => 0.7 RC1
2010-08-25 02:53 markidcas SVN Revision => 0
2010-08-25 02:53 markidcas Run Mode => Grid (Multiple Regions per Sim)
2010-08-25 02:53 markidcas Physics Engine => ODE
2010-08-25 02:53 markidcas Environment => Mono / Linux64
2010-08-25 02:53 markidcas Mono Version => 1.2.4
2010-08-28 05:35 Marck File Added: covenant.txt
2010-08-28 05:35 Marck Note Added: 0016665
2010-08-28 10:54 Fly-Man- Relationship added has duplicate 0002879
2010-08-28 11:28 markidcas Note Added: 0016669
2010-08-28 11:36 smxy Note Added: 0016670
2012-02-10 22:28 Pixel Tomsen Mono Version 1.2.4 => 2.10
2012-02-10 22:28 Pixel Tomsen Note Added: 0020858
2012-02-10 22:28 Pixel Tomsen Status new => resolved
2012-02-10 22:28 Pixel Tomsen Fixed in Version => master (dev code)
2012-02-10 22:28 Pixel Tomsen Resolution open => fixed
2012-02-10 22:28 Pixel Tomsen Assigned To => Pixel Tomsen
2012-02-11 05:14 BlueWall Status resolved => closed
2012-02-11 05:14 BlueWall Assigned To Pixel Tomsen =>


Copyright © 2000 - 2012 MantisBT Group
Powered by Mantis Bugtracker