Mantis Bug Tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0004941opensim[GRID] Hypergridpublic2010-08-13 03:132010-09-12 10:47
Reporteraiaustin 
Assigned ToDiva 
PrioritynormalSeverityfeatureReproducibilityN/A
StatusclosedResolutionfixed 
PlatformOperating SystemOperating System Version
Product Version 
Target VersionFixed in Version 
Summary0004941: Suggestion to shorten Avatar name for hypergrid traveller and make more friendly
DescriptionWhen on a hypergrid location, the avatar has a name tag "Avatar Name@Hostname:port". This can in some cases be very long and is often split in an ugly way over several lines.

Would it be possible to use the Grid Name or Grid Nickname instead of Hostname:port? Hence "Avatar Name@Grid Name"
TagsNo tags attached.
Git Revision or version number0.7.0.1 post-fixes
Run Mode Grid (Multiple Regions per Sim)
Physics EngineODE
Script Engine
EnvironmentUnknown, .NET / Windows32
Mono VersionNone
Viewer
Attached Filespatch file icon 0001-Shorten-avatar-names-of-hypergrid-travellers.patch [^] (2,323 bytes) 2010-08-13 14:19 [Show Content]

- Relationships

-  Notes
(0016377)
danbanner (manager)
2010-08-13 03:17
edited on: 2010-08-13 03:18

even getting rid of the "http://" [^] would help considerably.

(0016387)
Marck (reporter)
2010-08-13 14:20
edited on: 2010-08-13 14:53

The attached patch 0001-Shorten-avatar-names-of-hypergrid-travellers.patch changes avatar names of hypergrid travellers to only show the hostname of their home, i.e. instead of the full HomeURI, only its hostname part is used as last name.

The nick name of the home grid can not be used for this, because that information is not available at the time the name is constructed, as far as I understand.

I am not sure if the port should also be shown in the name, because it is possible that there are different grids or standalones accessible under the same hostname. With this patch, I followed the scheme used for linked regions in commit 774114 (r/13556) which also uses just the region name or hostname without any port info. However, I did include in comments the port info for both the name shown on linked regions and hypergrid traveller avatar names. This way, a committer could easily decide whether this additional port information should be included or not.

The choice between including the port with the hostname or just using the hostname could also be made a configuration option. I think I am able to provide an appropriate patch, if such a configuration option is requested.

(0016405)
Bruce (reporter)
2010-08-14 11:03

Ah now I'm confused. I just entered "ink-region" in console for r13558 and I got the following message:

Region (root) # link-region
Usage: link-region <Xloc> <Yloc> <HostName>:<HttpPort>[:<RemoteRegionName>]:
Usage: link-region <Xloc> <Yloc> <HostName> <HttpPort> [<LocalName>]:
Usage: link-region <URI_of_xml> [<exclude>]:

Looks to me that in the first two cases you still need to give a port number or am I missing something ?
(0016406)
Marck (reporter)
2010-08-14 11:18

Bruce, this report is about the names given to avatars during their visit to a hypergrid destination. It is not about creating link regions. Those links still require the full information including host name and port.

What I was referring to in my previous note is the displayed name of link regions in the world map and with console command "show hyperlinks". These used to have the form "hostname:port:region", but since r/13556 they are displayed with just the region name or, if no region name is given, the hostname.
(0016407)
aiaustin (developer)
2010-08-14 11:21

Every time I use link-region I can never remember whether I must give a final : it seems odd to have to end with a : even if a region name is stated. But the help syntax implies it is needed... and experience suggests it nmight alwysa be required? A little tidy up to drop the need fo any final : with and without region name being specified would be good.
(0016408)
Bruce (reporter)
2010-08-14 11:24
edited on: 2010-08-14 11:38

One aspect to consider: Running two instances on the same server, one is 0.6.9 the other is 0.7.0.1 in standalone mode. The external URL/IP is the same for both instances, the only difference is the port number, one is 9000 the other is 9001. So whilst removing "http://" [^] is fine, removal of the port number from avatar sub-title would be a bit confusing under this setup. May I suggest the addition of a setting in the opensim.ini file which would allow selecting "true" or "false" for the addition of the port number in the sub-title of avatar names.

[addendum: above read "relevant HG configuration file" and not "opensim.ini file"]

(0016409)
Marck (reporter)
2010-08-14 11:27
edited on: 2010-08-14 11:30

aiaustin, you do not need to end a link-region address with ':'. These ':' are strewn all over the help text output, but they are not part of the help texts as they appear in the source code. Some parser is 'salting' the output with these colons for a reason that I have not figured out yet.

(0016410)
aiaustin (developer)
2010-08-14 11:36

Thx Marck, noted. The failures wee probably for unrelated reasons during early HG1.5 testing between several of us, so no wonder I could not make sense of when the : was needed and when not :-)
(0016415)
Diva (administrator)
2010-08-15 17:32

Thanks Marck!

[17:27] <CIA-35> opensim: diva * rd5c24241b7bc /OpenSim/Services/HypergridService/GatekeeperService.cs: Thanks Marck for the patch to mantis 0004941 (shortening avies' names on HG)

[17:30] <CIA-35> opensim: diva 0.7-post-fixes * r50a88ed2e46e /OpenSim/Services/HypergridService/GatekeeperService.cs: Thanks Marck for the patch to mantis 0004941 (shortening avies' names on HG)

- Issue History
Date Modified Username Field Change
2010-08-13 03:13 aiaustin New Issue
2010-08-13 03:13 aiaustin Git Revision => 0.7.0.1 post-fixes
2010-08-13 03:13 aiaustin SVN Revision => 13566
2010-08-13 03:13 aiaustin Run Mode => Grid (Multiple Regions per Sim)
2010-08-13 03:13 aiaustin Physics Engine => ODE
2010-08-13 03:13 aiaustin Environment => Unknown, .NET / Windows32
2010-08-13 03:13 aiaustin Mono Version => None
2010-08-13 03:13 aiaustin Summary Suggestion to sorten Avatar name for hypergrid traveller and make more friendly => Suggestion to shorten Avatar name for hypergrid traveller and make more friendly
2010-08-13 03:13 aiaustin Description Updated
2010-08-13 03:17 danbanner Note Added: 0016377
2010-08-13 03:18 danbanner Note Edited: 0016377
2010-08-13 03:18 danbanner Note Edited: 0016377
2010-08-13 14:19 Marck File Added: 0001-Shorten-avatar-names-of-hypergrid-travellers.patch
2010-08-13 14:20 Marck Note Added: 0016387
2010-08-13 14:20 Marck Status new => patch included
2010-08-13 14:20 Marck Note Edited: 0016387
2010-08-13 14:53 Marck Note Edited: 0016387
2010-08-14 11:03 Bruce Note Added: 0016405
2010-08-14 11:18 Marck Note Added: 0016406
2010-08-14 11:21 aiaustin Note Added: 0016407
2010-08-14 11:24 Bruce Note Added: 0016408
2010-08-14 11:27 Marck Note Added: 0016409
2010-08-14 11:30 Marck Note Edited: 0016409
2010-08-14 11:36 aiaustin Note Added: 0016410
2010-08-14 11:38 Bruce Note Edited: 0016408
2010-08-15 17:32 Diva Status patch included => resolved
2010-08-15 17:32 Diva Resolution open => fixed
2010-08-15 17:32 Diva Assigned To => Diva
2010-08-15 17:32 Diva Note Added: 0016415
2010-09-12 10:47 chi11ken Status resolved => closed


Copyright © 2000 - 2012 MantisBT Group
Powered by Mantis Bugtracker