Mantis Bug Tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0004824opensim[REGION] OpenSim Corepublic2010-06-29 14:572011-12-09 16:27
Reporteraiaustin 
Assigned Tojustincc 
PrioritynormalSeverityminorReproducibilitysometimes
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version 
Target VersionFixed in Version 
Summary0004824: Avatar clothing textures show with incorrect holes and rainbow effects in 0.7 RC1 and onwards, but not in 0.6.9
DescriptionAvatar clothing textures show with transparency/holes which are not meant to be present in 0.7.0 and onwards, but not in 0.6.9

Noted on several different avatars, and for different (single) clothing items, which previously worked in 0.6.9. Not always showing the holes though.
TagsNo tags attached.
Git Revision or version number0.7 RC1 onwards
Run Mode Grid (Multiple Regions per Sim)
Physics EngineODE
Script Engine
Environment.NET / Windows32
Mono VersionNone
Viewer
Attached Filesjpg file icon faulty-textures-on-clothing-svn13155.jpg [^] (438,269 bytes) 2010-06-29 14:57

- Relationships
related to 0004817new 0.7 RC2 [J2KDecoderModule]: Failed to decode layer data 

-  Notes
(0016573)
aiaustin (developer)
2010-08-22 13:50
edited on: 2010-08-29 03:21

Oddly the same clothing items show with holes even when new textures are uploaded. Texture has simple V neck transparency but none where holes appear.

Observed some J2K decode errors in logs, but not yet established if these coincide with point at which clothing holes start to appear.

15:59:58 - [ASSET TRANSACTIONS]: Uploaded asset 5ef2189f-5151-949b-6a89-d983de6147c8 for transaction 9865139e-4036-de6d-3359-bda526f4dd7a
15:59:58 - [J2KDecoderModule]: CSJ2K threw an exception decoding texture 5ef2189f-5151-949b-6a89-d983de6147c8: IO Error when reading tile 0 x 0
15:59:58 - [J2KDecoderModule]: Failed to decode layer data for texture 5ef2189f-5151-949b-6a89-d983de6147c8, guessing sane defaults
Region (root) # [WARNING]: EOC marker not found. Codestream is corrupted.x, Int3

(0016678)
aiaustin (developer)
2010-08-29 03:20
edited on: 2010-08-29 03:20

Notes that Imprudence 1.30.0 RC2 viewer release notes indicate this is a known problem...

OpenSims using CS2JK to bake avatar textures might corrupt an avatar's appearance (looking "rainbow" or "checker-boarded") when using openjpeg. A rebake will generally fix this.


- Issue History
Date Modified Username Field Change
2010-06-29 14:57 aiaustin New Issue
2010-06-29 14:57 aiaustin File Added: faulty-textures-on-clothing-svn13155.jpg
2010-06-29 14:57 aiaustin Git Revision => 0.7 RC1 onwards
2010-06-29 14:57 aiaustin SVN Revision => 13155
2010-06-29 14:57 aiaustin Run Mode => Grid (Multiple Regions per Sim)
2010-06-29 14:57 aiaustin Physics Engine => ODE
2010-06-29 14:57 aiaustin Environment => .NET / Windows32
2010-06-29 14:57 aiaustin Mono Version => None
2010-06-29 14:58 aiaustin Description Updated
2010-06-29 15:04 Diva Relationship added related to 0004817
2010-08-22 13:50 aiaustin Note Added: 0016573
2010-08-29 03:20 aiaustin Note Added: 0016678
2010-08-29 03:20 aiaustin Note Edited: 0016678
2010-08-29 03:21 aiaustin Note Edited: 0016573
2010-10-15 14:46 aiaustin Summary Avatar clothing textures show with transparency in 0.7 RC1 and onwards, but not in 0.6.9 => Avatar clothing textures show with incorrect holes and rainbow effects in 0.7 RC1 and onwards, but not in 0.6.9
2010-10-15 14:46 aiaustin Description Updated
2011-12-09 16:27 justincc Status new => closed
2011-12-09 16:27 justincc Assigned To => justincc
2011-12-09 16:27 justincc Resolution open => fixed


Copyright © 2000 - 2012 MantisBT Group
Powered by Mantis Bugtracker