Mantis Bug Tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0004658opensim[MISC] Compiling / Buildingpublic2010-04-05 16:282010-10-27 10:08
ReporterFly-Man- 
Assigned ToFly-Man- 
PrioritynormalSeverityminorReproducibilityalways
StatusclosedResolutionunable to reproduce 
PlatformLinuxOSDebianOS Version9.10 Server
Product Versionmaster (dev code) 
Target Versionmaster (dev code)Fixed in Versionmaster (dev code) 
Summary0004658: Create user doesn't fill in standard values in tables
DescriptionAfter issuing a create user in the ROBUST server on a clean slate installation, the user is created without filling in the standard fields:

HomeURI=
GatekeeperURI=
InventoryServerURI=
AssetServerURI=

It does create a inventory for this user but is unable to fill in the ServiceUrl's, user is unable to login to a region and gets a "Login failed" error message
Steps To ReproduceR.O.B.U.S.T.# create user
First name [Default]: Test
Last name [User]: User
Passwordtest
Email []: test@localhost
01:21:10 - [AUTHENTICATION DB]: Set password for principalID 84bfb890-77a9-47b6-84c9-114577d54ec4
01:21:10 - [USER ACCOUNT SERVICE]: Unable to set home for account Test User.
01:21:10 - [INVENTORY SERVICE]: Adding folder My Inventory 63b7f47c-b3af-480c-9573-1938e898c5b5 to folder 00000000-0000-0000-0000-000000000000
01:21:10 - [INVENTORY SERVICE]: Adding folder Animations 493e8b32-17b7-4f17-baa5-d37e43748894 to folder 63b7f47c-b3af-480c-9573-1938e898c5b5
01:21:10 - [INVENTORY SERVICE]: Adding folder Body Parts 846095d8-7acf-4579-9130-bdee03bff2af to folder 63b7f47c-b3af-480c-9573-1938e898c5b5
01:21:10 - [INVENTORY SERVICE]: Adding folder Calling Cards 6733a05e-50f1-44ca-8206-563a71e0e315 to folder 63b7f47c-b3af-480c-9573-1938e898c5b5
01:21:10 - [INVENTORY SERVICE]: Adding folder Clothing 2b0cb4a4-1af4-42e7-89a0-9a1652e6f457 to folder 63b7f47c-b3af-480c-9573-1938e898c5b5
01:21:10 - [INVENTORY SERVICE]: Adding folder Gestures 2d370eae-4622-48d9-be71-33dc64c14f8d to folder 63b7f47c-b3af-480c-9573-1938e898c5b5
01:21:10 - [INVENTORY SERVICE]: Adding folder Landmarks cd8bc567-e020-4f7f-8618-8957d7feea83 to folder 63b7f47c-b3af-480c-9573-1938e898c5b5
01:21:10 - [INVENTORY SERVICE]: Adding folder Lost And Found a91c5cf9-b44f-4ad7-bd20-4b83358e2611 to folder 63b7f47c-b3af-480c-9573-1938e898c5b5
01:21:10 - [INVENTORY SERVICE]: Adding folder Notecards 408cf231-998e-4f75-9dff-64eb80b6be2b to folder 63b7f47c-b3af-480c-9573-1938e898c5b5
01:21:10 - [INVENTORY SERVICE]: Adding folder Objects 8617e168-3217-48e9-8346-cab29e7f4555 to folder 63b7f47c-b3af-480c-9573-1938e898c5b5
01:21:10 - [INVENTORY SERVICE]: Adding folder Photo Album 177aafb4-b41e-4f23-948b-5882a9bac532 to folder 63b7f47c-b3af-480c-9573-1938e898c5b5
01:21:10 - [INVENTORY SERVICE]: Adding folder Scripts f4bf546a-5efa-44f0-848e-b94b15b6a655 to folder 63b7f47c-b3af-480c-9573-1938e898c5b5
01:21:10 - [INVENTORY SERVICE]: Adding folder Sounds 9f8f1daa-301d-43ca-b505-302a92da2b22 to folder 63b7f47c-b3af-480c-9573-1938e898c5b5
01:21:10 - [INVENTORY SERVICE]: Adding folder Textures 832c979f-c129-4083-a98e-c54affcbae85 to folder 63b7f47c-b3af-480c-9573-1938e898c5b5
01:21:10 - [INVENTORY SERVICE]: Adding folder Trash 50f87ce4-f46b-4916-a7e8-6223910e6954 to folder 63b7f47c-b3af-480c-9573-1938e898c5b5
01:21:10 - [USER ACCOUNT SERVICE]: Account Test User created successfully
TagsNo tags attached.
Git Revision or version numberf302224cafa9ffe8f47cce2274022e1ee2ed37d6
Run ModeStandalone (1 Region) , Standalone (Multiple Regions) , Grid (1 Region per Sim) , Grid (Multiple Regions per Sim)
Physics EngineODE
Script Engine
EnvironmentUnknown
Mono VersionNone
Viewer
Attached Files

- Relationships

-  Notes
(0015285)
Fly-Man- (developer)
2010-04-05 16:39

This happens on a clean slate installed Grid server, no OpenSim.ini or any of the files inside the config-include folder touched.

Just a standard install a newbie would do.
(0015287)
melanie (administrator)
2010-04-05 16:45

It works on a standalone. But then, of course it would. It has no servers. Thanks for reporting this, it's helped me to solve a customer issue.
(0015412)
Diva (administrator)
2010-05-06 07:52

I need more info, because what you're reporting doesn't match the implementation. Yes, those fields are empty -- by design. Login should not care about them; the LoginService should provide default ones.

These fields are an enhancement to the default values provided by the LoginService. Those default values in LoginService are mandatory.
(0017125)
Fly-Man- (developer)
2010-10-25 17:30

I am unable to reproduce this with the latest trunk, so closing this issue

- Issue History
Date Modified Username Field Change
2010-04-05 16:28 Fly-Man- New Issue
2010-04-05 16:28 Fly-Man- Git Revision => f302224cafa9ffe8f47cce2274022e1ee2ed37d6
2010-04-05 16:28 Fly-Man- SVN Revision => 0
2010-04-05 16:28 Fly-Man- Run Mode => Standalone (1 Region) , Standalone (Multiple Regions) , Grid (1 Region per Sim) , Grid (Multiple Regions per Sim)
2010-04-05 16:28 Fly-Man- Physics Engine => ODE
2010-04-05 16:28 Fly-Man- Environment => Unknown
2010-04-05 16:28 Fly-Man- Mono Version => None
2010-04-05 16:39 Fly-Man- Note Added: 0015285
2010-04-05 16:45 melanie Note Added: 0015287
2010-05-06 07:52 Diva Note Added: 0015412
2010-10-25 17:30 Fly-Man- Status new => resolved
2010-10-25 17:30 Fly-Man- Resolution open => unable to reproduce
2010-10-25 17:30 Fly-Man- Assigned To => Fly-Man-
2010-10-25 17:30 Fly-Man- Note Added: 0017125
2010-10-27 10:08 Fly-Man- Status resolved => closed
2010-10-27 10:08 Fly-Man- Fixed in Version => master (dev code)


Copyright © 2000 - 2012 MantisBT Group
Powered by Mantis Bugtracker