Mantis Bug Tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0004657opensim[MISC] Compiling / Buildingpublic2010-04-05 13:492010-04-16 16:48
ReporterFly-Man- 
Assigned Tojustincc 
PrioritynormalSeverityminorReproducibilityalways
StatusclosedResolutionwon't fix 
PlatformLinuxOSDebianOS Version9.10 Server
Product Version 
Target Versionmaster (dev code)Fixed in Version 
Summary0004657: Failure to start 0.6.9 RC1 servers
DescriptionWhen starting the 0.6.9 RC1 User Server

22:47:23 - Launching UserServer...
22:47:23 - [STARTUP]: Beginning startup processing
22:47:23 - [STARTUP]: Version: OpenSim 0.6.9 (RC1)


Unhandled Exception: System.ArgumentOutOfRangeException: Value must be positive and below the buffer height.
Parameter name: top
  at System.TermInfoDriver.SetCursorPosition (Int32 left, Int32 top) [0x00000]
  at System.TermInfoDriver.set_CursorTop (Int32 value) [0x00000]
  at System.ConsoleDriver.set_CursorTop (Int32 value) [0x00000]
  at System.Console.set_CursorTop (Int32 value) [0x00000]
  at OpenSim.Framework.Console.LocalConsole.SetCursorLeft (Int32 left) [0x00000]
  at OpenSim.Framework.Console.LocalConsole.ReadLine (System.String p, Boolean isCommand, Boolean e) [0x00000]
  at OpenSim.Framework.Console.ConsoleBase.CmdPrompt (System.String p, System.String def) [0x00000]
  at OpenSim.Framework.ConfigurationMember.performConfigurationRetrieve () [0x00000]
  at OpenSim.Framework.UserConfig..ctor (System.String description, System.String filename) [0x00000]
  at OpenSim.Grid.UserServer.OpenUser_Main.StartupCoreComponents () [0x00000]
  at OpenSim.Grid.UserServer.OpenUser_Main.StartupSpecific () [0x00000]
  at OpenSim.Framework.Servers.BaseOpenSimServer.Startup () [0x00000]
  at OpenSim.Grid.UserServer.OpenUser_Main.Main (System.String[] args) [0x00000]

Can someone please explain why the heck I get this message on a clean slate OpenSim install from the dist.opensimulator.org ??
TagsNo tags attached.
Git Revision or version number0.6.9
Run ModeStandalone (1 Region) , Standalone (Multiple Regions) , Grid (1 Region per Sim) , Grid (Multiple Regions per Sim)
Physics EngineODE
EnvironmentUnknown
Mono VersionNone
Viewer
Attached Files

- Relationships

-  Notes
(0015275)
melanie (administrator)
2010-04-05 14:15

Known issue. Use -console=basic for the legacy servers. 0.7 doesn't have the issue.
(0015276)
Fly-Man- (developer)
2010-04-05 14:55

Well, there's a small issue then:

I can't run 0.7 as it's dangerous to run it on live machines.
(0015277)
melanie (administrator)
2010-04-05 15:11

That is why I advised to run with -console=basic, which avoids the issue on 0.6.9. With a workaround available and the servers being deprecated, I'm closing this again as won't fix and expect it to stay closed.
(0015278)
justincc (administrator)
2010-04-05 15:13

I have to disagree here - we can't put out a release with this kind of issue. I am going to reopen and address it later this week (probably Friday).
(0015279)
melanie (administrator)
2010-04-05 15:21

Issue has been there all along. The workaround is well known.
(0015280)
jhurliman (manager)
2010-04-05 15:24

What do you mean we can't put out a release with this kind of issue? It's been present in every release for as long as I've used OpenSim. I noticed it from day one because Ubuntu's default theme for the screen command clips the console from 80 lines down to 79 or 78, which crashes OpenSim unless you use -console=basic.

Not saying that being incompatible with Ubuntu out of the box is desirable, but it's definitely not unique to the upcoming 0.6.9.
(0015281)
justincc (administrator)
2010-04-05 15:33

Somehow I've managed not to experience this issue until now, probably because I've not walked through the setup for ages. Do you know if it was occuring with 0.6.8?

But I really don't think we can have a credible release where you have to put an obscure (to newbies) string on the console just to get the basic configuration to work. And I can't believe that it's all that difficult to fix, at least for the majority case.
(0015282)
melanie (administrator)
2010-04-05 15:42
edited on: 2010-04-05 15:43

It's just that the code that needs to be fixed is already obsolete. So it's wasted work, because that code doesn't exist in 0.7.

The new console works flawlessly in the ROBUST shell and the region server. The legacy servers have some issue that prevents them from working with that console. It wasn't like that from the start, the error was introduced later. When I implemented the console, all servers worked with it without resizing.

To fix this, it's either a long bug hunting session to find the point where it was broken, or to put in a quick and dirty fix that may break other things.

That is what made me decide on "Won't Fix". Devil you know, and all that.

(0015283)
Fly-Man- (developer)
2010-04-05 16:15

Either way, it's not a known issue before. 0.6.8 has no issues with loading the legacy services. And I am not using screen for the loading of the legacy servers.

The earlier release of the 0.6.9 doesn't have this issue, only the RC1 version seems to fail loading.
(0015284)
melanie (administrator)
2010-04-05 16:18

That does narrow it down some.
(0015343)
justincc (administrator)
2010-04-16 13:01

Addressed in c77444a82157

Fly-Man, could you build the latest 0.6.9-post-fixes and let me know if the problem has gone away?
(0015344)
Fly-Man- (developer)
2010-04-16 16:48

Servers starting up without the errors, thank you Justincc for the fix

- Issue History
Date Modified Username Field Change
2010-04-05 13:49 Fly-Man- New Issue
2010-04-05 13:49 Fly-Man- Git Revision => 0.6.9
2010-04-05 13:49 Fly-Man- SVN Revision => 0
2010-04-05 13:49 Fly-Man- Run Mode => Standalone (1 Region) , Standalone (Multiple Regions) , Grid (1 Region per Sim) , Grid (Multiple Regions per Sim)
2010-04-05 13:49 Fly-Man- Physics Engine => ODE
2010-04-05 13:49 Fly-Man- Environment => Unknown
2010-04-05 13:49 Fly-Man- Mono Version => None
2010-04-05 14:15 melanie Status new => resolved
2010-04-05 14:15 melanie Resolution open => won't fix
2010-04-05 14:15 melanie Assigned To => melanie
2010-04-05 14:15 melanie Note Added: 0015275
2010-04-05 14:55 Fly-Man- Status resolved => feedback
2010-04-05 14:55 Fly-Man- Resolution won't fix => reopened
2010-04-05 14:55 Fly-Man- Note Added: 0015276
2010-04-05 15:11 melanie Status feedback => resolved
2010-04-05 15:11 melanie Resolution reopened => won't fix
2010-04-05 15:11 melanie Note Added: 0015277
2010-04-05 15:12 justincc Status resolved => assigned
2010-04-05 15:12 justincc Assigned To melanie => justincc
2010-04-05 15:13 justincc Note Added: 0015278
2010-04-05 15:13 justincc Status assigned => confirmed
2010-04-05 15:21 melanie Note Added: 0015279
2010-04-05 15:24 jhurliman Note Added: 0015280
2010-04-05 15:33 justincc Note Added: 0015281
2010-04-05 15:42 melanie Note Added: 0015282
2010-04-05 15:43 melanie Note Edited: 0015282
2010-04-05 16:15 Fly-Man- Note Added: 0015283
2010-04-05 16:18 melanie Note Added: 0015284
2010-04-16 13:00 justincc Status confirmed => resolved
2010-04-16 13:01 justincc Note Added: 0015343
2010-04-16 16:48 Fly-Man- Status resolved => closed
2010-04-16 16:48 Fly-Man- Note Added: 0015344


Copyright © 2000 - 2012 MantisBT Group
Powered by Mantis Bugtracker