Mantis Bug Tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0004604opensim[GRID] User Servicepublic2010-03-02 19:592010-09-12 10:46
Reporterjohndrellwolf 
Assigned Tojohndrellwolf 
PrioritynormalSeverityblockReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Versionmaster (dev code) 
Target VersionFixed in Version 
Summary0004604: Unable to login to region
DescriptionUpdated to latest master, rebuilt ini files from examples, let migration occur, after migration not one single user is able to login.

Error given:
[LLOGIN SERVICE]: Exception processing login for <username here>: System.NullReferenceException: Object reference not set to an instance of an object.

No other messages are given. I have created a new user since the migration and same error occurs.
Additional InformationUnsure if this is connected in any way. But since the migration there is a startup error with the [GridInfo] not being in opensim.ini yet it is listed in there. I even tried reducing the tag from [GridInfoService] to [GridInfo] and it still fails to be read.

I have also attempted to revert back to an older version but it also fails to allow connections after this update so I am attempting to revert the database.
TagsNo tags attached.
Git Revision or version number?
Run Mode Grid (Multiple Regions per Sim)
Physics EngineODE
Environment.NET / Windows64
Mono VersionNone
Viewer
Attached Fileslog file icon OpenSim.Server.log [^] (13,619 bytes) 2010-03-02 20:46
log file icon OpenSim.Server-updated.log [^] (16,280 bytes) 2010-03-02 21:27

- Relationships
related to 0004607closed userfriends table not being created on first run 
related to 0004610closed auth tables not being populated from old users table 
related to 0004630closed some error about MIGRATIONS when running opensim first times 

-  Notes
(0015066)
Diva (administrator)
2010-03-02 20:25

Try again and show me the log of the ROBUST server. I added a better debug message.
(0015067)
johndrellwolf (reporter)
2010-03-02 20:48

Here is my ROBUST server log. I hope it gives you the information needed. Thank you for the quick response. And your moving the GridInfo to the server.ini seemed to fix the issue. I just copied the data from opensim.ini to opensim.server.ini and it resolved that issue.
(0015068)
Diva (administrator)
2010-03-02 21:14

Looks like there's something wrong with your auth table. You may want to look into the DB directly to see what's wrong. Does it have any rows in it?

I added better error handling, but it won't solve the problem; it simply will not throw an exception. The problem is in the auth table.
(0015069)
johndrellwolf (reporter)
2010-03-02 21:26

I updated the auth table with one account and it is now going slightly further, but not logging in. however it appears that in the migration the auth table was never populated with the previously stored data. An updated copy of the log file is being attached with this note.
(0015070)
Diva (administrator)
2010-03-02 21:30

I see the migration error for friends, but don't see any error for auth. Try dropping the auth table entirely, and issue this SQL query:
DELETE from migrations WHERE name='AuthStore';

Then try running again and see if you get migration errors on auth.

(I'm assuming you didn't touch your existing data in the obsolete users table; don't touch it for now until you have the new data under control)
(0015071)
johndrellwolf (reporter)
2010-03-02 21:58
edited on: 2010-03-02 21:59

After manually updating the friends and auth tables I now have all users getting to the same location listed in the second log file. They fail to continue loading past the "[LLOGIN]: Library has 19 folders" line. and every user must manually enter a location to login to or they cannot even get this far.


Also Region server gives error:
2010-03-02 21:53:12,840 DEBUG - OpenSim.Region.ClientStack.LindenUDP.LLUDPServer [LLUDPSERVER]: Handling UseCircuitCode packet from 71.237.255.241:60856
2010-03-02 21:53:12,856 WARN - OpenSim.Region.ClientStack.LindenUDP.LLUDPServer [LLUDPSERVER]: Ignoring a repeated UseCircuitCode from fc667fb3-6d19-4a3f-939b-0671621bfb20 at 71.237.255.241:60856 for circuit 1598935347

(0015072)
Diva (administrator)
2010-03-02 22:01

If your goal is to help test the master branch, I'm right with you. You have encountered some problems with migrations. I would like to find out what those are. Please do what I ask, if you want to help.

If, however, your goal is to get your grid going in any way you can, I'm not going to waste my time with this issue. Try a few things, and good luck.
(0015073)
johndrellwolf (reporter)
2010-03-02 22:12

sorry I failed to list that in the last note. I had to remove the auth table then the next run it created the table and worked correctly. at that point the friends table failed to migrate so I ran the same procedure with the FriendsStore and that allowed the program to migrate it correctly. However now I am observing another issue.

I am willing to do anything you ask. I do not mind at all and if I was just going to get my grid going I would simply restore my database from a backup and go back to the previous software the older software.
(0015074)
Diva (administrator)
2010-03-02 22:22

What do you mean "the same procedure with the FriendStore"? You mean you dropped it and deleted the migration row, and that made it work? If so, that is very weird, but it's good information that I can test here.

I added one more debug message to the login service. If all is well, you should see this message:
[LLOGIN SERVICE]: All clear. Sending login response to client.

After that, it's up to the client and the region. So if things get stuck, you'll need to look in the region log file and detect errors there.
(0015075)
johndrellwolf (reporter)
2010-03-02 22:27

Yes. I had to delete the migration row for FriendsStore and drop the table. then run the ROBUST server again and it updated correctly. Also sorry if I made it seem that I had the sole task of getting my grid back up. That was not my intention.
(0015076)
Diva (administrator)
2010-03-02 22:28

No problem.
It looks like you are getting stuck at the region now, so you need to look there.
(0015077)
johndrellwolf (reporter)
2010-03-02 23:00

Thank you for all of your great help. This issue is resolved. After a quick reboot of the server hardware to apply one other change (unrelated Windows system update) the remaining login issue seems to be resolved.
(0015078)
johndrellwolf (reporter)
2010-03-02 23:19

Should this happen just run "DELETE from migrations WHERE name='AuthStore';" and "DELETE from migrations WHERE name='FriendsStore';" then drop both the friends and auth tables from your database. Rerun the ROBUST server and it should complete without error. It worked for me.

- Issue History
Date Modified Username Field Change
2010-03-02 19:59 johndrellwolf New Issue
2010-03-02 19:59 johndrellwolf Git Revision => ?
2010-03-02 19:59 johndrellwolf SVN Revision => 0
2010-03-02 19:59 johndrellwolf Run Mode => Grid (Multiple Regions per Sim)
2010-03-02 19:59 johndrellwolf Physics Engine => ODE
2010-03-02 19:59 johndrellwolf Environment => .NET / Windows64
2010-03-02 19:59 johndrellwolf Mono Version => None
2010-03-02 20:25 Diva Note Added: 0015066
2010-03-02 20:46 johndrellwolf File Added: OpenSim.Server.log
2010-03-02 20:48 johndrellwolf Note Added: 0015067
2010-03-02 21:14 Diva Note Added: 0015068
2010-03-02 21:26 johndrellwolf Note Added: 0015069
2010-03-02 21:27 johndrellwolf File Added: OpenSim.Server-updated.log
2010-03-02 21:30 Diva Note Added: 0015070
2010-03-02 21:58 johndrellwolf Note Added: 0015071
2010-03-02 21:59 johndrellwolf Note Edited: 0015071
2010-03-02 22:01 Diva Note Added: 0015072
2010-03-02 22:12 johndrellwolf Note Added: 0015073
2010-03-02 22:22 Diva Note Added: 0015074
2010-03-02 22:27 johndrellwolf Note Added: 0015075
2010-03-02 22:28 Diva Note Added: 0015076
2010-03-02 23:00 johndrellwolf Note Added: 0015077
2010-03-02 23:19 johndrellwolf Status new => resolved
2010-03-02 23:19 johndrellwolf Resolution open => fixed
2010-03-02 23:19 johndrellwolf Assigned To => johndrellwolf
2010-03-02 23:19 johndrellwolf Note Added: 0015078
2010-03-03 10:50 Diva Relationship added related to 0004607
2010-03-03 14:43 Diva Relationship added related to 0004610
2010-03-17 08:39 Diva Relationship added related to 0004630
2010-09-12 10:46 chi11ken Status resolved => closed


Copyright © 2000 - 2012 MantisBT Group
Powered by Mantis Bugtracker