Mantis Bug Tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0004521opensim[GRID] Asset Servicepublic2010-01-16 12:482010-01-16 12:48
Reporterseyfarth 
Assigned To 
PrioritynormalSeverityminorReproducibilityalways
StatusnewResolutionopen 
PlatformOSOS Version
Product Version 
Target VersionFixed in Version 
Summary0004521: Logging in multiple bots increases login time
DescriptionI am trying to test server performance using a C# client which logs in and move a bot successfully. My test environment is the OSBEST grid at Southern Miss. It takes about 1 second to login my first bot. If I leave the bots logged in, but not moving the time increases. The 20th bot takes about 15 seconds. I had hoped to test with 100 bots, but the total login time is excessive if the logins are sequential.
Additional InformationBoth the grid server and the region server are running Windows. Using the task manager and the advanced resources window, there does not seem to be much of a load. The CPU usage for both servers is under 5%, the memory usage is pretty low, the disk usage is a few kbytes per second, and the network usage builds up to a few kbytes per second. My theory is that there are a lot of small network packets.
TagsNo tags attached.
Git Revision or version number0.6.9.482dcb7
Run Mode Grid (1 Region per Sim)
Physics EngineBasicPhysics
Script Engine
Environment.NET / Windows64
Mono VersionNone
Viewer
Attached Files

- Relationships

-  Notes
There are no notes attached to this issue.

- Issue History
Date Modified Username Field Change
2010-01-16 12:49 seyfarth New Issue
2010-01-16 12:49 seyfarth Git Revision => 0.6.9.482dcb7
2010-01-16 12:49 seyfarth SVN Revision => 0
2010-01-16 12:49 seyfarth Run Mode => Grid (1 Region per Sim)
2010-01-16 12:49 seyfarth Physics Engine => BasicPhysics
2010-01-16 12:49 seyfarth Environment => .NET / Windows64
2010-01-16 12:49 seyfarth Mono Version => None


Copyright © 2000 - 2012 MantisBT Group
Powered by Mantis Bugtracker