Mantis Bug Tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0004475opensim[REGION] Script Functionspublic2009-12-30 21:232018-01-26 02:00
ReporterRevolution 
Assigned Tomelanie 
PrioritynormalSeverityminorReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version 
Target VersionFixed in Version 
Summary0004475: Adds llCollisionFilter
DescriptionThis adds llCollisionFilter and its respective functionality. WARNING: This patch is based of MY understanding of what this function does. If there is something wrong with how I implemented it, please tell me. I am NOT sure this is correct.
TagsNo tags attached.
Git Revision or version numbermaster as of 12-30-09
Run Mode Standalone (Multiple Regions)
Physics EngineODE
Environment.NET / Windows32
Mono VersionNone
Viewer
Attached Filespatch file icon 0001-Adds-llCollisionFilter.patch [^] (26,463 bytes) 2009-12-30 21:23 [Show Content]
patch file icon 0001-Readds-llCollisionFilter-and-adds-llPassCollision.patch [^] (25,516 bytes) 2009-12-31 09:41 [Show Content]

- Relationships
related to 0007941new llCollisionFilter not implemented 

-  Notes
(0014615)
melanie (administrator)
2009-12-30 21:29

This patch also contained llSetInventoryPermsMask, a god function that was not previously implemented.
In the future, please don't sneak in unrelated code.

Committed with minor changes necessitated by my rejection of the RETURN_AT_EDGE patch.
(0014616)
Revolution (reporter)
2009-12-30 22:07

Sorry, was going to submit a patch for all the god ones at once, but I forgot to take that one out of this patch. It won't happen again.
(0014617)
melanie (administrator)
2009-12-30 22:14

You can resubmit the other 2 patches. They weren't unacceptable because of content. They were just filled with ANSI color code garbage.
(0014618)
melanie (administrator)
2009-12-30 23:28

Had to revert this patch. It caused deserialization errors loading prims from database or rezzing from inventory.
(0014621)
Revolution (reporter)
2009-12-31 09:42

The new patch fixes the serialization errors and also adds llPassCollision.
(0014622)
nebadon (administrator)
2009-12-31 10:46

very cool Revolution, any chance you might take a stab at some of the missing LSL events? land_collison, land_collision_start, land_collision_end.. I am really dieing to get these events i need them to finish my Racer project, thanks for attempting to get these last few functions finished :)
(0014623)
Revolution (reporter)
2009-12-31 10:55

I'm working on it. Hoping to get alot of the rest of LSL stuff done before .6.9.

- Issue History
Date Modified Username Field Change
2009-12-30 21:23 Revolution New Issue
2009-12-30 21:23 Revolution File Added: 0001-Adds-llCollisionFilter.patch
2009-12-30 21:23 Revolution Git Revision => master as of 12-30-09
2009-12-30 21:23 Revolution SVN Revision => 0
2009-12-30 21:23 Revolution Run Mode => Standalone (Multiple Regions)
2009-12-30 21:23 Revolution Physics Engine => ODE
2009-12-30 21:23 Revolution Environment => .NET / Windows32
2009-12-30 21:23 Revolution Mono Version => None
2009-12-30 21:24 Revolution Status new => patch included
2009-12-30 21:29 melanie Status patch included => resolved
2009-12-30 21:29 melanie Resolution open => fixed
2009-12-30 21:29 melanie Assigned To => melanie
2009-12-30 21:29 melanie Note Added: 0014615
2009-12-30 22:07 Revolution Status resolved => feedback
2009-12-30 22:07 Revolution Resolution fixed => reopened
2009-12-30 22:07 Revolution Note Added: 0014616
2009-12-30 22:08 Revolution Status feedback => resolved
2009-12-30 22:08 Revolution Resolution reopened => fixed
2009-12-30 22:14 melanie Note Added: 0014617
2009-12-30 23:28 melanie Note Added: 0014618
2009-12-30 23:28 melanie Status resolved => patch feedback
2009-12-31 09:41 Revolution File Added: 0001-Readds-llCollisionFilter-and-adds-llPassCollision.patch
2009-12-31 09:42 Revolution Note Added: 0014621
2009-12-31 10:46 nebadon Note Added: 0014622
2009-12-31 10:55 Revolution Note Added: 0014623
2009-12-31 14:22 melanie Status patch feedback => resolved
2010-02-15 18:50 chi11ken Status resolved => closed
2018-01-26 02:00 djphil Relationship added related to 0007941


Copyright © 2000 - 2012 MantisBT Group
Powered by Mantis Bugtracker