Mantis Bug Tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0004461opensim[REGION] OpenSim Corepublic2009-12-23 21:232009-12-28 18:53
ReporterRevolution 
Assigned To 
PrioritynormalSeverityminorReproducibilityalways
StatusnewResolutionopen 
PlatformOSOS Version
Product Version 
Target VersionFixed in Version 
Summary0004461: Terrain editing has some rubber banding issues.
DescriptionWhen you edit terrain, the terrain will edit, then pop back to its original value. It will eventually clear itself out, but this makes it hard to edit terrain. This bug is caused by how the client view sends out the terrain, which comes from this void
public void SendLayerData(int px, int py, float[] map)
in LLClientView line 897. The ThrottleOutPacketType.Land needs to be tweaked or changed to something faster.
TagsNo tags attached.
Git Revision or version numberUpdated 12-23
Run Mode Standalone (Multiple Regions)
Physics EngineODE
Script Engine
Environment.NET / Windows32
Mono VersionNone
Viewer
Attached Files

- Relationships

-  Notes
(0014568)
Revolution (reporter)
2009-12-23 21:47

This is very obvious when editing terrain in a nearby region.
(0014582)
Zauber (reporter)
2009-12-25 14:23

Revolution, are you using SQLITE as the database plugin (default), and are you using mono version 2.4.3 or higher? There have been some breakages with SQLITE functionality under Mono 2.4.3
(0014585)
Revolution (reporter)
2009-12-25 16:30

Nope. Windows 7, MySQL.
(0014588)
greg0254 (reporter)
2009-12-25 21:10

I'm seeing the same thing, running under XP with MySQL.
(0014589)
Zauber (reporter)
2009-12-25 21:26
edited on: 2009-12-25 21:26

Revolution and Greg, can you test this by running opensimulator under the windows version of Mono instead of .Net, to see if it a bug specific to .Net? As well, can you do a test under SQLITE to see if it is occuring with that database backend as well?

(0014591)
Revolution (reporter)
2009-12-26 07:55

I will be gone for the next two days, but I'll be happy to do it when I get back.
(0014593)
greg0254 (reporter)
2009-12-26 10:54

Zauber, I have never run Mono, so would appreciate it if you could give me a link to a page that explains how to do this.
(0014604)
Revolution (reporter)
2009-12-28 18:52

This bug does occur on SQLite as well as MySql on Windows on .Net. Have not tested on Mono.
(0014605)
Revolution (reporter)
2009-12-28 18:53

Note: Harder to see this bug in the agent's current region in SQLite.

- Issue History
Date Modified Username Field Change
2009-12-23 21:23 Revolution New Issue
2009-12-23 21:23 Revolution Git Revision => Updated 12-23
2009-12-23 21:23 Revolution SVN Revision => 618
2009-12-23 21:23 Revolution Run Mode => Standalone (Multiple Regions)
2009-12-23 21:23 Revolution Physics Engine => ODE
2009-12-23 21:23 Revolution Environment => .NET / Windows32
2009-12-23 21:23 Revolution Mono Version => None
2009-12-23 21:47 Revolution Note Added: 0014568
2009-12-25 14:23 Zauber Note Added: 0014582
2009-12-25 16:30 Revolution Note Added: 0014585
2009-12-25 21:10 greg0254 Note Added: 0014588
2009-12-25 21:26 Zauber Note Added: 0014589
2009-12-25 21:26 Zauber Note Edited: 0014589
2009-12-26 07:55 Revolution Note Added: 0014591
2009-12-26 10:54 greg0254 Note Added: 0014593
2009-12-28 18:52 Revolution Note Added: 0014604
2009-12-28 18:53 Revolution Note Added: 0014605


Copyright © 2000 - 2012 MantisBT Group
Powered by Mantis Bugtracker