Mantis Bug Tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0004360opensim[REGION] Specific OpenSim Modulepublic2009-11-08 07:322010-02-15 18:50
ReporterSnoopy 
Assigned ToFly-Man- 
PrioritynormalSeveritycrashReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Versionmaster (dev code) 
Target Versionmaster (dev code)Fixed in Versionmaster (dev code) 
Summary0004360: Opensim search module- Crash probably caused by too many search pattern matches
DescriptionLog into OSGrid, open the search window and search for "rent" in the "land" or "all" tab. This causes a viewer crash. All other search patterns I did try did work properly.

I experience that with ossearch version 120.

The attached WinGridProxy session log contains the events that were produced during the search that did cause the crash.
TagsNo tags attached.
Git Revision or version number82554e9a89e4ca39c1522d539862f9fd6a2f2a7e
Run Mode Grid (1 Region per Sim)
Physics EngineODE
EnvironmentMono / Linux32
Mono Versiontrunk
Viewer
Attached Files? file icon GroupCrash.osd [^] (80,224 bytes) 2009-11-08 07:32
? file icon OpenSimSearch.Modules.dll [^] (28,672 bytes) 2009-12-14 07:14
patch file icon OpenSearch.patch [^] (1,760 bytes) 2009-12-14 11:57 [Show Content]

- Relationships
has duplicate 0004314closedFly-Man- Latest Search bin rev 120 crash the client 
related to 0003621closedFly-Man- User search results should be split into multiple packets 
child of 0003364closedFly-Man- [OSSEARCH] 

-  Notes
(0014126)
Fly-Man- (developer)
2009-11-08 08:24

Can you tell me which viewer you used to test this ?

As I see no issues when using Hippo, Meerkat and Emerald viewers
(0014127)
Snoopy (administrator)
2009-11-08 08:34

I did use the lastest stable Hippo and SL viewer versions.
(0014130)
Snoopy (administrator)
2009-11-08 11:45

OK, I did some more tests.

The same crash happens when I use windows (vista) and linux (ubuntu) versions of the viewers.

And as regions I did try searchs on 32 and 64 bit linux ubuntu regions as well as on Wright Plaza.

When you search in OSGrid for "land" with the string "rent" your viewer crashes.
(0014481)
Revolution (reporter)
2009-12-11 14:12
edited on: 2009-12-11 14:13

Here is a patch that works for my grid. It fixed the bug on my grid, but it has NOT been tested on the OSGrid. All this patch does is split up the ammount of search results sent at once. Hope this patch fixes this issue!

(0014482)
Teravus (administrator)
2009-12-11 14:14

Changing : to - because it makes the text appear more clearly on the IRC notify bot
(0014490)
Fly-Man- (developer)
2009-12-14 06:44

Work in Progress, I am about to review the patch and will see if it will help the search
(0014491)
Fly-Man- (developer)
2009-12-14 07:15

I added a DLL that i compiled, please check if this fixes the errors with the Search.

If this fixes it, I will release a new version on the Gforge SVN shortly
(0014493)
AdelleF (reporter)
2009-12-14 11:24

I have tested the DLL on one region and I can confirm that the viewer has not crashed using common search strings such as "free", "land" and "the".
(0014494)
Fly-Man- (developer)
2009-12-14 11:57

Reupload the Patch that Revolution did, without the whole file being rewritten
(0014513)
WhiteStar (reporter)
2009-12-15 17:20

Question:

Will this be applied to the GIT Repository ? as the OpenSimSearch.Module is included within the repo and the current rev is dated Oct.22.2009.
(0014514)
Revolution (reporter)
2009-12-15 17:25

It will be applied to the forge project.
(0014515)
WhiteStar (reporter)
2009-12-15 17:32

Understood Revolution, but it is part of the GIT Repo so for me to update my Binary packages and those which attach to OSG I'll have to pull it for the corrections. Because it is the GIT repo, why is it necessary to put it into Forge, seems somewhat redundant and would put systems out of step.
(0014516)
Revolution (reporter)
2009-12-15 17:45

The forge is it's 'official' location I believe, but I see your point. Anyone else have some input on this?
(0014536)
Fly-Man- (developer)
2009-12-18 05:49

As soon as I find time to update the Gforge repro with all the patches that I have. Then it will be open for the public to use it.

In the meantime, use the DLL that's with this Mantis
(0014569)
Snoopy (administrator)
2009-12-23 23:13

I have tested that patch with version 120 in the repository and it works.
(0014570)
melanie (administrator)
2009-12-24 11:03

Reviewed and approved :)
(0014636)
Fly-Man- (developer)
2010-01-02 07:13

Issue was fixed by the updating of the Gforge SVN by Melanie

- Issue History
Date Modified Username Field Change
2009-11-08 07:32 Snoopy New Issue
2009-11-08 07:32 Snoopy File Added: GroupCrash.osd
2009-11-08 07:32 Snoopy Git Revision => 82554e9a89e4ca39c1522d539862f9fd6a2f2a7e
2009-11-08 07:32 Snoopy SVN Revision => 0
2009-11-08 07:32 Snoopy Run Mode => Grid (1 Region per Sim)
2009-11-08 07:32 Snoopy Physics Engine => ODE
2009-11-08 07:32 Snoopy Environment => Mono / Linux32
2009-11-08 07:32 Snoopy Mono Version => trunk
2009-11-08 08:24 Fly-Man- Note Added: 0014126
2009-11-08 08:24 Fly-Man- Status new => feedback
2009-11-08 08:34 Snoopy Note Added: 0014127
2009-11-08 11:45 Snoopy Note Added: 0014130
2009-12-04 06:42 Fly-Man- Relationship added child of 0003364
2009-12-11 14:12 Revolution Note Added: 0014481
2009-12-11 14:12 Revolution File Added: Patch.patch
2009-12-11 14:13 Revolution Note Edited: 0014481
2009-12-11 14:14 Teravus Note Added: 0014482
2009-12-11 14:14 Teravus Summary Opensim search module: Crash probably caused by too many search pattern matches => Opensim search module- Crash probably caused by too many search pattern matches
2009-12-11 14:19 nebadon Status feedback => patch included
2009-12-14 06:43 Fly-Man- Assigned To => Fly-Man-
2009-12-14 06:43 Fly-Man- Target Version => master
2009-12-14 06:44 Fly-Man- Note Added: 0014490
2009-12-14 07:14 Fly-Man- File Added: OpenSimSearch.Modules.dll
2009-12-14 07:15 Fly-Man- Note Added: 0014491
2009-12-14 07:15 Fly-Man- Status patch included => patch feedback
2009-12-14 11:24 AdelleF Note Added: 0014493
2009-12-14 11:56 Fly-Man- File Deleted: Patch.patch
2009-12-14 11:57 Fly-Man- Note Added: 0014494
2009-12-14 11:57 Fly-Man- File Added: OpenSearch.patch
2009-12-15 17:20 WhiteStar Note Added: 0014513
2009-12-15 17:25 Revolution Note Added: 0014514
2009-12-15 17:32 WhiteStar Note Added: 0014515
2009-12-15 17:45 Revolution Note Added: 0014516
2009-12-16 15:27 Revolution Relationship added related to 0003621
2009-12-16 15:29 Revolution Relationship added related to 0004314
2009-12-18 05:49 Fly-Man- Note Added: 0014536
2009-12-23 23:13 Snoopy Note Added: 0014569
2009-12-24 11:03 melanie Note Added: 0014570
2009-12-24 11:03 melanie Status patch feedback => patch ready
2010-01-02 06:24 Fly-Man- Relationship replaced has duplicate 0004314
2010-01-02 07:13 Fly-Man- Status patch ready => resolved
2010-01-02 07:13 Fly-Man- Fixed in Version => master
2010-01-02 07:13 Fly-Man- Resolution open => fixed
2010-01-02 07:13 Fly-Man- Note Added: 0014636
2010-02-15 18:50 chi11ken Status resolved => closed


Copyright © 2000 - 2012 MantisBT Group
Powered by Mantis Bugtracker