Mantis Bug Tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0004007opensim[GRID] Inventory Servicepublic2009-08-13 19:192010-11-07 07:31
Reporterchi11ken 
Assigned Tochi11ken 
PrioritynormalSeverityminorReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version 
Target VersionFixed in Version 
Summary0004007: Master avatar cannot login to new standalone instance
DescriptionFrom a clean clone, I created a single region standalone sim, with a master user "Test User", password "test".

When I try to log in, the client says: "Login failed. The avatar inventory service is not responding. Please notify your login region operator."

On the region console, I see this:

15:49:15 - [LOGIN BEGIN]: XMLRPC Received login request message from user 'Test' 'User'
15:49:15 - [LOGIN]: XMLRPC Client is Snowglobe Release 1.23.4.123908, start location is last
15:49:15 - [LOGIN]: Authenticating Test User
15:49:15 - [USER DB]: Syncing useragent database: 1 agents stored
15:49:15 - [INVENTORY SERVICE]: Getting inventory skeleton for d474ba4a-047b-4580-b434-e05a313eaa89
15:49:15 - [LOGIN]: A root inventory folder for user d474ba4a-047b-4580-b434-e05a313eaa89 was not found. Requesting creation.
15:49:15 - [LOGIN]: A new inventory skeleton was successfully created for user d474ba4a-047b-4580-b434-e05a313eaa89
15:49:15 - [INVENTORY SERVICE]: Getting inventory skeleton for d474ba4a-047b-4580-b434-e05a313eaa89
15:49:15 - [LOGIN END]: Error retrieving inventory skeleton of agent d474ba4a-047b-4580-b434-e05a313eaa89 - System.Exception: A root inventory folder for user d474ba4a-047b-4580-b434-e05a313eaa89 could not be retrieved from the inventory service
  at OpenSim.Framework.Communications.Services.LoginService.GetInventorySkeleton (UUID userID) [0x001cf] in OpenSim/Framework/Communications/Services/LoginService.cs:1176
  at OpenSim.Framework.Communications.Services.LoginService.XmlRpcLoginMethod (Nwc.XmlRpc.XmlRpcRequest request, System.Net.IPEndPoint remoteClient) [0x0023a] in OpenSim/Framework/Communications/Services/LoginService.cs:225

If I create a new user and log in as that user, everything is fine.
TagsNo tags attached.
Git Revision or version number3669115d60f4e8fbd5032836b828f6ee40901c93
Run ModeStandalone (1 Region)
Physics EngineODE
Script Engine
EnvironmentMono / OSX
Mono Version2.4
Viewer
Attached Files

- Relationships

-  Notes
(0013094)
Ruakuu (reporter)
2009-08-30 13:32

This is happening to me too. I did a fresh install of version 0.6.6 for a linux box, creater the master avatar account, but can't login with it, if I create a new account and login it works fine.

When browsing to bin/Regions I notice that default.xml no longer exist, instead, there is this Regions.ini file. try to look for some info on the internet and I found out that this was a new way that opensim saves regions.

I try creating a new region next to the default one called Test1. This creates Test1.xml in the Regions folder and doesn't add anything to Regions.ini.

Is this using the .xml style and not the new Regions.ini?

I try redirecting the viewer to the second region I created on port 9001 but also can't connect with master av
(0013213)
aiaustin (developer)
2009-09-08 07:17
edited on: 2009-09-08 07:21

I too am trying to create a 0.6.6 system and cannot log back in with any avatar. I am making and testing the (very many) configuration files. I have arranged to run the (RO)BUST services and have amended the port for the inventory server to 8003 (from 8004) as instructed at the bottom of http://opensimulator.org/wiki/ROBUST [^]

But, all I see in the OpenSim.Services.ini(.example) file is an asset server section, nothing for the inventory server?

And I see upgrade comments about having to alter the MySQL database, in the "users" table, it says that the userInventoryURI field needs to be updated for all users. To what? And how is it best done safely?

The instructions also say to copy OpenSim.Server.ini.example to OpenSim.Server.ini and edit it, changing the two "ConnectionString" entries appropriately. I can only see one data base string parameter (in the 0.6.6 post fixes release version) for the asset server, and no section or string for the inventory server. So I suspect a missing inventory service section in OpenSim.Server.ini.example is the problem?

(0013214)
aiaustin (developer)
2009-09-08 07:43
edited on: 2009-09-08 07:45

I have tried a range of configurations to see if I can get things up with no joy. I have tried separate old style UGAIM services, with UGRM (for A and I) and now with UGRIM (R only for A) and I think I set the ports for the inventory server correctly (8004 for all modes except when trying A and I on R) which is then port 8003.

Note the avaar in question has an extensive inventory already and is master avatar on the initial 1000,1000 region. User server reports:

[LOGIN BEGIN]: XMLRPC Received login request message from user 'Ai' 'Austin'
[LOGIN]: XMLRPC Client is Opensim 1.23.4.123908, start location is home
[LOGIN]: A root inventory folder for user e24a9015-f5ca-452b-8c95-d32e34cb9d64 was not found. Requesting creation.
[LOGIN]: A new inventory skeleton was successfully created for user e24a9015-f5ca-452b-8c95-d32e34cb9d64
[LOGIN END]: Error retrieving inventory skeleton of agent e24a9015-f5ca-452b-8c95-d32e34cb9d64 - System.Exception: A root inventory folder for user e24a9015-f5ca-452b-8c95-d32e34cb9d64 could not be retrieved from the inventory service

(0014446)
mohax (reporter)
2009-12-08 11:23

Can confirm this bug from the 0.6.6 Windows MSI package. Creating account works fine, just not the 'Master Sandbox User'
(0014779)
kmkho (reporter)
2010-01-14 14:04

I had the same problem when installing 0.6.6 on two windows systems. However, I found that using the command "reset user password" in the server console and entering the same first/last/pass that I entered for the initial region configuration will allow me to log in as the master avatar. Hope this helps.
(0014780)
melanie (administrator)
2010-01-14 15:51

This is really a moot point since master avatar has been deprecated for nearly 6 months and will be removed in a few weeks.
(0015260)
mykael (reporter)
2010-04-04 08:37

Ummm. So when I first connect my client to my new standalone opensim region I don't have to provide the userid and password I provided when I defined the region? You might want to put this somewhere obvious, as it's news to me, and I'm a naive first time installer of the 0.6.6 package.

...erm. Nope. If I try and log in with any other userid, it says 'cannot authenticate avatar'.

Ah. I have to use the create command to create a user before I can log in with them. Y'all ain't getting no marks for obviousness here...
(0015303)
JeffKelley (reporter)
2010-04-08 01:19

I had this issue and it was a mis-configured StandaloneCommon.ini. The simulator could not connect to the database. Check the console for:

[ASSET CONNECTOR]: Unable to send asset (uuid) to asset server. Reason: Error: ConnectFailure

In OpenSim.ini, 'asset_plugin' and 'asset_source' are now useless. From 0.6.6, they are replaced by 'StorageProvider' and ConnectionString' in StandaloneCommon.ini.

StandaloneCommon.ini is included at the end of OpenSim.ini:
    Include-Standalone = "config-include/Standalone.ini"
(uncommented by default)

Edit StandaloneCommon.ini, set 'StorageProvider' and 'ConnectionString' to the values you were using for 'asset_plugin' and 'asset_source'. Do not forget to comment StorageProvider = "OpenSim.Data.SQLite.dll" if you use SQL.

This may solve your issue.
(0017251)
chi11ken (manager)
2010-11-07 07:31

Seems to work now with estate owner instead of master avatar.

- Issue History
Date Modified Username Field Change
2009-08-13 19:19 chi11ken New Issue
2009-08-13 19:19 chi11ken Git Revision => 3669115d60f4e8fbd5032836b828f6ee40901c93
2009-08-13 19:19 chi11ken SVN Revision => 0
2009-08-13 19:19 chi11ken Run Mode => Standalone (1 Region)
2009-08-13 19:19 chi11ken Physics Engine => ODE
2009-08-13 19:19 chi11ken Environment => Mono / OSX
2009-08-13 19:19 chi11ken Mono Version => 2.4
2009-08-30 13:32 Ruakuu Note Added: 0013094
2009-09-08 07:17 aiaustin Note Added: 0013213
2009-09-08 07:20 aiaustin Note Edited: 0013213
2009-09-08 07:21 aiaustin Note Edited: 0013213
2009-09-08 07:43 aiaustin Note Added: 0013214
2009-09-08 07:44 aiaustin Note Edited: 0013214
2009-09-08 07:45 aiaustin Note Edited: 0013214
2009-12-08 11:23 mohax Note Added: 0014446
2010-01-14 14:04 kmkho Note Added: 0014779
2010-01-14 15:51 melanie Note Added: 0014780
2010-04-04 08:37 mykael Note Added: 0015260
2010-04-08 01:19 JeffKelley Note Added: 0015303
2010-11-07 07:31 chi11ken Note Added: 0017251
2010-11-07 07:31 chi11ken Assigned To => chi11ken
2010-11-07 07:31 chi11ken Status new => closed
2010-11-07 07:31 chi11ken Resolution open => fixed


Copyright © 2000 - 2012 MantisBT Group
Powered by Mantis Bugtracker