Mantis Bug Tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0003883opensim[REGION] OpenSim Corepublic2009-07-13 03:412019-07-28 10:08
Reportermaster zephyr 
Assigned ToCodyCooper 
PrioritynormalSeverityminorReproducibilityalways
StatusresolvedResolutionfixed 
PlatformOSOS Version
Product Version 
Target VersionFixed in Version 
Summary0003883: Error loging Inconsistant between 32 and 64bit Some fail silently
DescriptionOn looking into another problem i noted that the problem i was trying to find was logged in the opensim.log but not in the 32bit lauch log.
I tested this using a file i know that fails (harmless).
To check i placed the file Opensim.Region.ReplaceableModules.MoneyModule.dll back into the bin folder (i know this to fail on launching region server in ether mode). Then ran the 32bit opensim launcher it fails silently. Then i ran same test w. opensim.exe launch (fails and also triggers m$ debug).
When looking at the 32bit launch log there is nothing logged at all but in the opensim.log test, it did log the error correctly.
Additional InformationI would have expected the exception to be recorded in ether mode in there x.logs.
This tends to make bug hunting a bit harder. This difference was found when looking for another problem and thought i should mention it in a dif. mantis.
Im not sure if this is just for one case of an exception error or if it also happens w. others as well. This happened to be one i think is reproducable.
I was running under win 32bit mode at rev 10k24. I have not tryed this on linux to see if the same is true there as well.
TagsNo tags attached.
Git Revision or version number
Run Mode Grid (Multiple Regions per Sim)
Physics EngineODE
Environment.NET / Windows32
Mono Versiontrunk
Viewer
Attached Files

- Relationships

-  Notes
(0012410)
master zephyr (reporter)
2009-07-13 04:05

Note: If you try this dont forget to remove the offending .dll after testing.
(0035510)
CodyCooper (reporter)
2019-07-28 10:08

This was a very early bug, as far as I can tell it has since been fixed in some later version.

- Issue History
Date Modified Username Field Change
2009-07-13 03:41 master zephyr New Issue
2009-07-13 03:42 master zephyr SVN Revision => 10k24
2009-07-13 03:42 master zephyr Run Mode => Grid (Multiple Regions per Sim)
2009-07-13 03:42 master zephyr Physics Engine => ODE
2009-07-13 03:42 master zephyr Environment => .NET / Windows32
2009-07-13 03:42 master zephyr Mono Version => trunk
2009-07-13 04:05 master zephyr Note Added: 0012410
2019-07-28 10:08 CodyCooper Note Added: 0035510
2019-07-28 10:08 CodyCooper Status new => resolved
2019-07-28 10:08 CodyCooper Resolution open => fixed
2019-07-28 10:08 CodyCooper Assigned To => CodyCooper


Copyright © 2000 - 2012 MantisBT Group
Powered by Mantis Bugtracker