Mantis Bug Tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0003838opensim[GRID] Asset Servicepublic2009-06-24 16:182011-08-02 06:08
ReporterStarflower 
Assigned To 
PrioritynormalSeveritymajorReproducibilityalways
StatusconfirmedResolutionopen 
PlatformOSOS Version
Product Version 
Target VersionFixed in Version 
Summary0003838: no transfer objects cannot be copied if have copy perm
Descriptionit is not possible to take copies of no transfer objects where the user has the copy perm and should be able to take a copy, even on their own parcel. this seems to indicate that no transfer currently implies no copy, though no copy is NOT set on the object. this appears to fundamentally break the perms system.
TagsNo tags attached.
Git Revision or version number
Run Mode Standalone (Multiple Regions)
Physics EngineBasicPhysics
Script Engine
EnvironmentUnknown
Mono VersionNone
Viewer
Attached Files

- Relationships

-  Notes
(0012261)
user903
2009-06-24 16:45

melanie committed related code in r9921

Allow "Take Copy" with copy only permissions if you own the object. Trans
is only required when taing an object you don't own, now.
Fixes Mantis 0003838

see more at - http://opensimulator.org/cgi-bin/viewvc.cgi?view=rev&revision=9921 [^]
(0012899)
Starflower (reporter)
2009-08-16 02:52

this doesn't seem to have made any difference since the latest upgrade. i still cannot take a copy of such an object.
(0019316)
makopoppo (manager)
2011-08-02 06:08

Issue still exists in OpenSim 0.7.2-dev (region is b7f81d3, asset server is OSGrid).

If you copy the item on the ground, it works. But if you try to copy the object in inventory, you can't.

I don't know if it is asset server issue or client-side issue though ...

- Issue History
Date Modified Username Field Change
2009-06-24 16:18 Starflower New Issue
2009-06-24 16:18 Starflower SVN Revision => 0
2009-06-24 16:18 Starflower Run Mode => Standalone (Multiple Regions)
2009-06-24 16:18 Starflower Physics Engine => BasicPhysics
2009-06-24 16:18 Starflower Environment => Unknown
2009-06-24 16:18 Starflower Mono Version => None
2009-06-24 16:45 user903 Checkin
2009-06-24 16:45 user903 Note Added: 0012261
2009-06-24 16:45 user903 Status new => resolved
2009-06-24 16:45 user903 Resolution open => fixed
2009-08-10 07:52 chi11ken Status resolved => closed
2009-08-16 02:52 Starflower Status closed => feedback
2009-08-16 02:52 Starflower Resolution fixed => reopened
2009-08-16 02:52 Starflower Note Added: 0012899
2011-08-02 06:08 makopoppo Note Added: 0019316
2011-08-02 06:08 makopoppo Status feedback => confirmed
2011-08-02 06:08 makopoppo Resolution reopened => open


Copyright © 2000 - 2012 MantisBT Group
Powered by Mantis Bugtracker