Mantis Bug Tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0003712opensim[REGION] OpenSim Corepublic2009-05-24 21:502010-09-12 10:47
Reporterpatnad 
Assigned ToFly-Man- 
PrioritynormalSeverityfeatureReproducibilityN/A
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version 
Target VersionFixed in Versionmaster (dev code) 
Summary0003712: [Feature] Request - LSL Http Server
DescriptionThere is a new feature that will hit soon the LL grid which is going to be very handy and will expend what we're able to do with LSL scripting.

I would like to contribute to this but I don't really know where to begin.

There is a couple of new LSL function to implement such as: llHTTPResponse, llRequestSecureURL, llReleaseURL

All details about this new feature can be found at: http://wiki.secondlife.com/wiki/LSL_http_server [^]
TagsNo tags attached.
Git Revision or version number
Run ModeStandalone (1 Region) , Standalone (Multiple Regions) , Grid (1 Region per Sim) , Grid (Multiple Regions per Sim)
Physics EngineBasicPhysics
EnvironmentUnknown
Mono VersionNone
Viewer
Attached Filespatch file icon UrlModule-incomingfix-unified.patch [^] (1,531 bytes) 2009-07-22 14:52 [Show Content]

- Relationships

-  Notes
(0011710)
melanie (administrator)
2009-05-25 00:53

I have started an implementation, but hit a snag and it's not currently functional. The LSL functions are implemented and return a URL (no secure URL, since we can't expect all sims to have externally valid SSL certs!), and should receive requeststs. That is where it stops, I'm not getting the requeststs into the region module that handles them. If that were sorted, the rest would be a snap.
(0012326)
Fly-Man- (developer)
2009-07-05 08:23

What's the current status on this ?
(0012376)
Fly-Man- (developer)
2009-07-11 08:24

Is there any news about the implementation or is this still a stub ??
(0012378)
melanie (administrator)
2009-07-11 10:25

This is not a stub. It's almost completely functional. I have hit a snag and asked for help, but no one has stepped up.
(0012381)
Fly-Man- (developer)
2009-07-11 17:31

Can you define snag and what the help would be that is needed ??

Because I think this could hopefully show potention to some new things
(0012554)
nornalbion (reporter)
2009-07-22 14:23

I have uploaded a patch which allows LSL scripts to receive HTTP requests. It does not fix the problem entirely, as it does not support responses.
(0012555)
melanie (administrator)
2009-07-22 14:35

Please create the patch as a "unified diff", rooted in the project directory. You can use "svn diff" on the command line, while in the base directory of the SVN checkout, to do this.
(0012556)
nornalbion (reporter)
2009-07-22 14:52

Sorry about that. I have uploaded a unified version of the patch.
(0012557)
user903
2009-07-22 15:16

melanie committed related code in r10068

Thank you, patnad, for a patch to advance the UrlModule's functionality.
Mantis 0003712

see more at - http://opensimulator.org/cgi-bin/viewvc.cgi?view=rev&revision=10068 [^]
(0014145)
patnad (reporter)
2009-11-10 10:23

Thanks for working on this, i really appreciate this new feature, let's hope it can be in a stable version very soon!
(0014153)
Fly-Man- (developer)
2009-11-11 01:50

Patnad, I think it's in the latest 0.6.7 release so you could try that one
(0014154)
patnad (reporter)
2009-11-11 04:18

Thumbs up :)
(0016647)
Fly-Man- (developer)
2010-08-27 18:24

The HTTP-in services have been added

If there's any other problems with HTTP-in, please create a new Mantis

- Issue History
Date Modified Username Field Change
2009-05-24 21:50 patnad New Issue
2009-05-24 21:50 patnad SVN Revision => 0
2009-05-24 21:50 patnad Run Mode => Standalone (1 Region) , Standalone (Multiple Regions) , Grid (1 Region per Sim) , Grid (Multiple Regions per Sim)
2009-05-24 21:50 patnad Physics Engine => BasicPhysics
2009-05-24 21:50 patnad Environment => Unknown
2009-05-24 21:50 patnad Mono Version => None
2009-05-25 00:53 melanie Note Added: 0011710
2009-07-05 08:23 Fly-Man- Note Added: 0012326
2009-07-11 08:24 Fly-Man- Note Added: 0012376
2009-07-11 08:24 Fly-Man- Status new => feedback
2009-07-11 10:25 melanie Note Added: 0012378
2009-07-11 17:31 Fly-Man- Note Added: 0012381
2009-07-22 14:22 nornalbion File Added: UrlModule-incomingfix.patch
2009-07-22 14:23 nornalbion Note Added: 0012554
2009-07-22 14:35 melanie Note Added: 0012555
2009-07-22 14:52 nornalbion File Added: UrlModule-incomingfix-unified.patch
2009-07-22 14:52 nornalbion Note Added: 0012556
2009-07-22 15:16 melanie File Deleted: UrlModule-incomingfix.patch
2009-07-22 15:16 user903 Checkin
2009-07-22 15:16 user903 Note Added: 0012557
2009-11-10 10:23 patnad Note Added: 0014145
2009-11-11 01:50 Fly-Man- Note Added: 0014153
2009-11-11 04:18 patnad Note Added: 0014154
2010-08-27 18:24 Fly-Man- Status feedback => resolved
2010-08-27 18:24 Fly-Man- Fixed in Version => master (dev code)
2010-08-27 18:24 Fly-Man- Resolution open => fixed
2010-08-27 18:24 Fly-Man- Assigned To => Fly-Man-
2010-08-27 18:24 Fly-Man- Note Added: 0016647
2010-09-12 10:47 chi11ken Status resolved => closed


Copyright © 2000 - 2012 MantisBT Group
Powered by Mantis Bugtracker