Mantis Bug Tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0003589opensim[REGION] OpenSim Corepublic2009-05-05 16:502009-06-21 02:27
ReporterSnoopy 
Assigned Tojustincc 
PriorityurgentSeverityminorReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version 
Target VersionFixed in Version 
Summary0003589: save oar fails for regions with many scripts and prims
DescriptionRunning "save oar" for my bigger regions with many scripts and prims fails. No error message is shown, but the resulting oar file is just 16 bytes long (see below). This is the case for my 3 biggest regions on my 32 and 64 bit servers.
Additional Information$ hexdump Dreamland.oar
0000000 8b1f 0008 0000 0000 0300 0002 0000 ffff
0000010
TagsNo tags attached.
Git Revision or version number
Run Mode Grid (Multiple Regions per Sim)
Physics EngineODE
Script Engine
EnvironmentMono / Linux32
Mono VersionOther
Viewer
Attached Files

- Relationships

-  Notes
(0011338)
Hinamori (reporter)
2009-05-07 00:33

ALso can confrim it. Same here. Only 16 bytes file. (rev. 9332)
(0011340)
justincc (administrator)
2009-05-07 07:33

I suspect that you're simply running out of memory, but please could you attach the entire OpenSim log section from the faulty save oar run. Thanks.
(0011342)
Snoopy (administrator)
2009-05-07 09:23

Well, "bad" news: Now it works, so I could not create that Opensim error log! ;)

Yes, probably it was caused by not having enough free main memory on my server.
(0011695)
thomax (reporter)
2009-05-24 01:02

ok, i can confirm this. and it's a serious bug.

more symptom:

i have a sim with 2 regions.
* save oar of the primary region (the one i created with installation) fails.
* the secondary region saves oar. this one has more prims and scripts than the primary.
* when i try to save oar from the primary region it just writes the 16bytes of the tar file and the console input is blocked.

greetings,

tx Oh
(0011698)
thomax (reporter)
2009-05-24 09:42

well,

i tracked it down to the lock in GetAsset in OpenSim/Region/Framework/Scenes/UuidGatherer.cs
in my case it was a old script (begin of 2008) which i was able to identify by the uuid. it was an old sit target script. i couldn't load it in-world and i guess the GetAsset() function has more passion on wait for godot..

i deleted the script in-world, because of the server side wait for yday i restarted the sim and was able to do the overdue save oar.

a timeout for the lock might help and if timeout got hit a error log entry would be nice. maybe with the uuid.


greetings,

tx Oh
(0011700)
Michelle Argus (reporter)
2009-05-24 11:16

how big is big?

 i had no problems saving 5324 prims + 305 scripts, it just needs a bit more time to complete
(0011705)
thomax (reporter)
2009-05-24 12:16

in my case it where about 1800 prims + 70 scripts. memory was about 10% (450mb).
(0011828)
justincc (administrator)
2009-06-01 09:03

This might be alleviated in r9753. Feedback appreciated.

- Issue History
Date Modified Username Field Change
2009-05-05 16:50 Snoopy New Issue
2009-05-05 16:50 Snoopy SVN Revision => 9395
2009-05-05 16:50 Snoopy Run Mode => Grid (1 Region per Sim)
2009-05-05 16:50 Snoopy Physics Engine => ODE
2009-05-05 16:50 Snoopy Environment => Mono / Linux32
2009-05-05 16:50 Snoopy Mono Version => Other
2009-05-07 00:33 Hinamori Note Added: 0011338
2009-05-07 07:33 justincc Note Added: 0011340
2009-05-07 07:33 justincc Status new => feedback
2009-05-07 09:23 Snoopy Note Added: 0011342
2009-05-24 01:02 thomax Run Mode Grid (1 Region per Sim) => Grid (Multiple Regions per Sim)
2009-05-24 01:02 thomax Note Added: 0011695
2009-05-24 01:02 thomax Priority normal => urgent
2009-05-24 01:02 thomax Product Version => 0.6.0+svn
2009-05-24 09:42 thomax Note Added: 0011698
2009-05-24 11:16 Michelle Argus Note Added: 0011700
2009-05-24 12:16 thomax Note Added: 0011705
2009-06-01 08:53 justincc Status feedback => assigned
2009-06-01 08:53 justincc Assigned To => justincc
2009-06-01 09:03 justincc Status assigned => resolved
2009-06-01 09:03 justincc Resolution open => fixed
2009-06-01 09:03 justincc Note Added: 0011828
2009-06-21 02:27 chi11ken Status resolved => closed


Copyright © 2000 - 2012 MantisBT Group
Powered by Mantis Bugtracker