Mantis Bug Tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0003333opensim[REGION] Specific OpenSim Modulepublic2009-03-25 04:442009-05-25 13:28
ReporterKDWycha 
Assigned ToFly-Man- 
PrioritynormalSeveritycrashReproducibilityalways
StatusclosedResolutionfixed 
PlatformOperating SystemOperating System Version
Product Version 
Target VersionFixed in Version 
Summary0003333: [OSSEARCH] Crashes Any Client When Searching For "Free" With SVN113 of OSSearch and R8862 OpenSim
DescriptionAs of 3/14/2009 I noticed with the latest revision of OpenSim doing a fresh SVN checkout and the latest OSSearch module I get logged out when searching for things such as "free" or "freebie" with the error "Unfortunately this session for the client on the server crashed. Any further actions taken will not be processed. Please relog."

After this you cannot move and are logged out. The error message from console is in the Additional Info section of this mantis.

Searching for things such as homestead do not crash the client. I have duplicated this with both Linden Viewer, Hippo Viewer and Cool Viewer.

I don't know if maybe people are putting !!!!'s or some sort of odd things in to get their stuff in top of search and that is crashing it or what since search results for "free" or "freebie" do not come up due to client crash.
Additional Information07:39:34 - [CLIENT]: Client thread for Kevin Paisley c2455288-c249-493a-a1bb-f07
b951b5ca7 crashed. Logging them out.
07:39:34 - System.NullReferenceException: Object reference not set to an instance of an object.

   at OpenSimSearch.Modules.OpenSearch.OpenSearchModule.DirPlacesQuery(IClientAPI remoteClient, UUID queryID, String queryText, Int32 queryFlags, Int32 category, String simName, Int32 queryStart)

   at OpenSim.Region.ClientStack.LindenUDP.LLClientView.ProcessInPacket(Packet Pack) in c:\opensim\OpenSim\Region\ClientStack\LindenUDP\LLClientView.cs:line 6838

   at OpenSim.Region.ClientStack.LindenUDP.LLPacketHandler.ProcessInPacket(LLQueItem item) in c:\opensim\OpenSim\Region\ClientStack\LindenUDP\LLPacketHandler.cs:line 558

   at OpenSim.Region.ClientStack.LindenUDP.LLClientView.ClientLoop() in c:\opensim\OpenSim\Region\ClientStack\LindenUDP\LLClientView.cs:line 746

   at OpenSim.Region.ClientStack.LindenUDP.LLClientView.RunUserSession() in c:\opensim\OpenSim\Region\ClientStack\LindenUDP\LLClientView.cs:line 846

07:39:34 - [CLIENT]: Got a logout request for Kevin Paisley in The Lost Pixel
TagsNo tags attached.
Git Revision or version number
Run Mode Grid (1 Region per Sim) , Grid (Multiple Regions per Sim)
Physics EngineODE
Script Engine
EnvironmentMono / Linux32, Mono / Linux64, .NET / Windows32
Mono VersionNone
Viewer
Attached Files

- Relationships
child of 0003364closedFly-Man- [OSSEARCH] 

-  Notes
(0010135)
KDWycha (reporter)
2009-03-25 13:35

I was just curious and typed in "arcade" and search worked as normal and my arcade showed up.

After that I wanted to test something so I typed "skins" and of course the client crashed again.

This is all in Search -> Places by the way.

It has to be something someone is putting in their parcel info making the search module crash and disconnecting the client.
(0010145)
KDWycha (reporter)
2009-03-26 10:17

This has also been confirmed by another user as well. They tried to search for "free" at Wright Plaza and it shut down their client as well. So I just wanted to add that it isn't just my sim or my client doing this :)
(0010146)
Starky Rubble (reporter)
2009-03-26 10:24

I just searched for Free at Wright running Hippo 5 on Vista and crashed
(0010165)
Fly-Man- (developer)
2009-03-27 14:36

I will have a look at it asap :)
(0010435)
KDWycha (reporter)
2009-04-05 17:56

Any idea when this may be fixed? Been over a week since Fly-Man said he will have a look at it :)
(0010927)
Fly-Man- (developer)
2009-04-22 12:21

KDWycha, I have not been able to reproduce the bug that was posted.

But I have cleaned up some of the code, so I will post a new version asap
(0010937)
KDWycha (reporter)
2009-04-22 13:33

I forgot to close this yesterday. It seems to have resolved itself. I think someone was putting odd characters in so they would be at the top of search but they probably got bored and closed their sims. Will reopen if or file new bug if this occurs again.
(0010938)
KDWycha (reporter)
2009-04-22 13:33

This issue seems to have resolved itself.

- Issue History
Date Modified Username Field Change
2009-03-25 04:44 KDWycha New Issue
2009-03-25 04:44 KDWycha SVN Revision => 8862
2009-03-25 04:44 KDWycha Run Mode => Grid (1 Region per Sim)
2009-03-25 04:44 KDWycha Physics Engine => ODE
2009-03-25 04:44 KDWycha Environment => .NET / Windows32
2009-03-25 04:44 KDWycha Mono Version => None
2009-03-25 13:35 KDWycha Note Added: 0010135
2009-03-26 10:17 KDWycha Note Added: 0010145
2009-03-26 10:24 Starky Rubble Note Added: 0010146
2009-03-27 14:34 Fly-Man- Summary [OSSearch] Crashes Any Client When Searching For "Free" With SVN113 of OSSearch and R8862 OpenSim => [OSSEARCH] Crashes Any Client When Searching For "Free" With SVN113 of OSSearch and R8862 OpenSim
2009-03-27 14:34 Fly-Man- Additional Information Updated
2009-03-27 14:36 Fly-Man- Note Added: 0010165
2009-03-30 13:19 Fly-Man- Run Mode Grid (1 Region per Sim) => Grid (1 Region per Sim) , Grid (Multiple Regions per Sim)
2009-03-30 13:19 Fly-Man- Environment .NET / Windows32 => Mono / Linux32, Mono / Linux64, .NET / Windows32
2009-03-30 13:19 Fly-Man- Mono Version None => Other
2009-03-30 13:19 Fly-Man- Status new => feedback
2009-03-30 13:19 Fly-Man- Projection none => minor fix
2009-03-30 13:22 Fly-Man- Status feedback => assigned
2009-03-30 13:22 Fly-Man- Assigned To => Fly-Man-
2009-03-30 13:31 Fly-Man- Relationship added child of 0003364
2009-04-05 17:56 KDWycha Note Added: 0010435
2009-04-22 12:21 Fly-Man- Note Added: 0010927
2009-04-22 13:33 KDWycha Note Added: 0010937
2009-04-22 13:33 KDWycha Mono Version Other => None
2009-04-22 13:33 KDWycha Status assigned => resolved
2009-04-22 13:33 KDWycha Resolution open => fixed
2009-04-22 13:33 KDWycha Note Added: 0010938
2009-05-25 13:28 Fly-Man- Status resolved => closed


Copyright © 2000 - 2012 MantisBT Group
Powered by Mantis Bugtracker