Mantis Bug Tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0003323opensim[REGION] Specific OpenSim Modulepublic2009-03-22 06:552009-04-02 12:26
ReporterFredM 
Assigned ToFly-Man- 
PrioritynormalSeveritycrashReproducibilityalways
StatusclosedResolutionfixed 
PlatformOperating SystemOperating System Version
Product Version 
Target VersionFixed in Version 
Summary0003323: [OSSEARCH] Exception: System.IO.FileNotFoundException: Could not load file or assembly 'OpenSim.Region.Environment
DescriptionGet new svn in. Simulator starts up fine without problem.

Clean shutdown of all servers.

Now restart all servers and it runs into (from crash log):

APPLICATION EXCEPTION DETECTED: System.UnhandledExceptionEventArgs

Exception: System.IO.FileNotFoundException: Could not load file or assembly 'OpenSim.Region.Environment, Version=0.0.0.0, Culture=neutral' or one of its dependencies.
File name: 'OpenSim.Region.Environment, Version=0.0.0.0, Culture=neutral'
  at (wrapper managed-to-native) System.Reflection.Assembly:GetTypes (bool)
  at System.Reflection.Assembly.GetTypes () [0x00000]
  at OpenSim.Region.Framework.ModuleLoader.LoadModules (System.String dllName) [0x00000]

Application is terminating: True

OpemSim crashes, all other servers remain running.

Kill all other servers to force them to quit...

Back to command line:
nant clean
svn up
./runprebuild.sh
nant

Copy ossearch modules into /bin and .dll. I think I have a problem with that because search is not working. If I leave the search module out from the /bin it seems to work normal.


TagsNo tags attached.
Git Revision or version number
Run Mode Grid (Multiple Regions per Sim)
Physics EngineODE
Script Engine
EnvironmentMono / Linux64
Mono VersionOther
Viewer
Attached Files

- Relationships
child of 0003364closedFly-Man- [OSSEARCH] 

-  Notes
(0010075)
master zephyr (reporter)
2009-03-22 09:08
edited on: 2009-03-22 09:27

the other thing (and yes that can too) is web stats = true .. the latter became less a problem after the update but i have seen Both not play right.
Removed both and the random crash problem stopped in windows.
Turn it or or putting the files back in.. just a matter of time.
No logs for it as it gen. an OS error thats useless.
On windows 32 UGAIM svn c#2008 exp build
current forge is http://forge.opensimulator.org/gf/project/ossearch/ [^] and did lessen this issue, webstats when hammered w. req also kills region server on windows. No usefull data to offer, error stops when both are removed

(0010077)
Fly-Man- (developer)
2009-03-22 11:40

Well, the latest binary files for Search don't have any other issues at this moment

So, i might suggest to do a full clean SVN checkout and try it again
(0010078)
FredM (reporter)
2009-03-22 11:56

Will get clean svn in tomorrow, then add ossearch module again and .dll

Will report here what it does. Thanks for now Fly-Man & Master
(0010086)
mikem (developer)
2009-03-22 16:44

It looks like your OSSearch binary is out of date. From the exception:

Could not load file or assembly 'OpenSim.Region.Environment

OpenSim.Region.Environment was renamed to OpenSim.Region.Framework and removed completely in r8316:

http://opensimulator.org/cgi-bin/viewcvs.cgi?limit_changes=0&view=rev&revision=8316 [^]

You will have to recompile the OSSearch DLL, and its source may need to be updated to use OpenSim.Region.Framework instead of OpenSim.Region.Environment.
(0010091)
FredM (reporter)
2009-03-23 11:54
edited on: 2009-03-23 12:10

mike,

thanks alot. The sourec of the OSSEARCH. Uhm, do I have this?

I have:
OpenSimSearch.Modules.dll
OpenSimSearch.Modules.dll.mdb

If I copy these files into /bin I run into the error. When I remove the OpenSimSearch.Modules.dll the simulator starts again but search fails (of course).
 
Should I copy these files into the opensimulator core and then run
./runprebuild.sh
nant

?

I guess I did this anyhow and did not work.

Maybe a question to Fly-Man:

What does the Modules/SearchModule/OpenSearch.cs do? Is this also to copy somewhere?

A question on the side: Why does the OSSEARCH not go into the core anyhow? I mean it is working well, if it works.

BTW: I had the files in svn 8243 and it worked there too. Just in case I will get the latest OSSEARCH files in.

(0010092)
FredM (reporter)
2009-03-23 14:42

Update on the issue.

Got new svn in and ossearch files. Search is working again! Yeah!

I can only add one event, not a second one anymore (won´t save in WI)
Event does not show on map.

Classified still does nothing, but not sure this ever worked.
(0010240)
Fly-Man- (developer)
2009-03-30 13:28

FredM, Classifieds are shared between OpenSimSearch and OpenSimProfile.

When OSP goes live, Classifieds will also work in the Search :)
(0010339)
Fly-Man- (developer)
2009-04-02 12:25

The OSSEARCH part is fixed, as soon as the OSPROFILE comes to life, the other bits will also work

- Issue History
Date Modified Username Field Change
2009-03-22 06:55 FredM New Issue
2009-03-22 06:55 FredM SVN Revision => 8839
2009-03-22 06:55 FredM Run Mode => Grid (Multiple Regions per Sim)
2009-03-22 06:55 FredM Physics Engine => ODE
2009-03-22 06:55 FredM Environment => Mono / Linux64
2009-03-22 06:55 FredM Mono Version => 1.9.1
2009-03-22 07:12 FredM Description Updated
2009-03-22 09:08 master zephyr Note Added: 0010075
2009-03-22 09:14 master zephyr Note Edited: 0010075
2009-03-22 09:27 master zephyr Note Edited: 0010075
2009-03-22 11:38 Fly-Man- Category [REGION] OpenSim Core => [REGION] Specific OpenSim Module
2009-03-22 11:38 Fly-Man- Summary Exception: System.IO.FileNotFoundException: Could not load file or assembly 'OpenSim.Region.Environment /?OSSEARCH? => [OSSEARCH] Exception: System.IO.FileNotFoundException: Could not load file or assembly 'OpenSim.Region.Environment
2009-03-22 11:40 Fly-Man- Note Added: 0010077
2009-03-22 11:56 FredM Note Added: 0010078
2009-03-22 16:44 mikem Note Added: 0010086
2009-03-23 11:54 FredM Note Added: 0010091
2009-03-23 11:54 FredM Note Edited: 0010091
2009-03-23 11:55 FredM Note Edited: 0010091
2009-03-23 11:56 FredM Note Edited: 0010091
2009-03-23 11:56 FredM Note Edited: 0010091
2009-03-23 11:58 FredM Note Edited: 0010091
2009-03-23 12:02 FredM Note Edited: 0010091
2009-03-23 12:06 FredM Note Edited: 0010091
2009-03-23 12:10 FredM Note Edited: 0010091
2009-03-23 14:42 FredM Note Added: 0010092
2009-03-30 13:28 Fly-Man- Note Added: 0010240
2009-03-30 13:28 Fly-Man- Status new => assigned
2009-03-30 13:28 Fly-Man- Assigned To => Fly-Man-
2009-03-30 13:31 Fly-Man- Relationship added child of 0003364
2009-04-02 12:25 Fly-Man- Status assigned => resolved
2009-04-02 12:25 Fly-Man- Resolution open => fixed
2009-04-02 12:25 Fly-Man- Note Added: 0010339
2009-04-02 12:26 Fly-Man- Mono Version 1.9.1 => Other
2009-04-02 12:26 Fly-Man- Status resolved => closed
2009-04-02 12:26 Fly-Man- Fixed in Version => 0.6.4


Copyright © 2000 - 2012 MantisBT Group
Powered by Mantis Bugtracker