Mantis Bug Tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0003156opensim[REGION] Script Functionspublic2009-02-14 03:542009-04-22 07:45
Reportermiddelink 
Assigned ToHomerHorwitz 
PrioritynormalSeverityminorReproducibilityalways
StatusclosedResolutionduplicate 
PlatformOSOS Version
Product Version 
Target VersionFixed in Version 
Summary0003156: llRemoveInventory(llGetScriptName()) doesnt work
DescriptionTrying to have a script remove itself from a prim fail silently. Removal of object, textures or other scripts works fine.

It prevents a self-rezzing object from removing the helper script from the object.

Under SL this method functions fine.
Additional Informationdefault
{
    state_entry()
    {
        llRemoveInventory(llGetScriptName());
    }
}
TagsNo tags attached.
Git Revision or version number
Run Mode Standalone (Multiple Regions)
Physics EngineODE
EnvironmentMono / Linux32
Mono Version2.0.1
Viewer
Attached Files

- Relationships
duplicate of 0002929closedjustincc llRemoveInventory(llGetScriptName()); Does not remove script 

-  Notes
(0009446)
wizardgynoid (reporter)
2009-02-14 13:08

Suggest upgrade of severity to "major"
If this function worked, it might be used as a workaround in regard to the "major" issue http://opensimulator.org/mantis/view.php?id=2853 [^]
If the Xscript engine is failing due to an overload of "active" scripts, then being able to "scrub" out the scripts would be a good workaround.
(0009849)
WordfromtheWise (reporter)
2009-03-05 15:30

any ideas ?
(0009855)
middelink (reporter)
2009-03-06 02:31

Well, i wish there was a way to close this issue, seeing its a dup of 2929... If anybody with enough rights is reading this, feel free.

As for the issue, its still there in the latest SVN...
(0009874)
HomerHorwitz (manager)
2009-03-07 12:50

Closing as duplicate

- Issue History
Date Modified Username Field Change
2009-02-14 03:54 middelink New Issue
2009-02-14 03:54 middelink SVN Revision => 0.6.2.8386
2009-02-14 03:54 middelink Run Mode => Standalone (Multiple Regions)
2009-02-14 03:54 middelink Physics Engine => ODE
2009-02-14 03:54 middelink Environment => Mono / Linux32
2009-02-14 03:54 middelink Mono Version => 2.0.1
2009-02-14 04:06 HomerHorwitz Relationship added duplicate of 0002929
2009-02-14 13:08 wizardgynoid Note Added: 0009446
2009-03-05 15:30 WordfromtheWise Note Added: 0009849
2009-03-05 15:30 WordfromtheWise Status new => feedback
2009-03-06 02:31 middelink Note Added: 0009855
2009-03-07 12:50 HomerHorwitz Duplicate ID 0 => 2929
2009-03-07 12:50 HomerHorwitz Status feedback => resolved
2009-03-07 12:50 HomerHorwitz Resolution open => duplicate
2009-03-07 12:50 HomerHorwitz Assigned To => HomerHorwitz
2009-03-07 12:50 HomerHorwitz Note Added: 0009874
2009-04-22 07:45 cfk Status resolved => closed


Copyright © 2000 - 2012 MantisBT Group
Powered by Mantis Bugtracker