Mantis Bug Tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0002972opensim[REGION] Scripting Enginepublic2009-01-09 16:552010-09-12 10:47
ReporterTommy Timewarp 
Assigned ToFly-Man- 
PrioritynormalSeveritymajorReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version 
Target VersionFixed in Versionmaster (dev code) 
Summary0002972: Script state and other data is not saved for items returned to inventory
DescriptionIn preface to my following statement... I hear this is a known issue so I would like to lobby for the content creators that this is one of 3 or 4 fixes that would generate lots more interest in SL'ers migrating to Legend City and other economy based grids as they pop up.

Scripts are not saving script data when taken into inventory and rezzed again. This effectively resets the script when it is taken into inventory or I assume when the sim is reset. My rezzers, holodecks and update servers are a good examples of what won't work at all because of this. Plus countless other gadgets and huds that depend on this memory. Here is an example script. The first time you touch this script it fails, from then on it should say -passed- until the script is reset. This is not the case. When taken into inventory all variables are reset to zero effectively resetting the script. The next time you rez it it will say "the variable storage failed" on the first touch.

//////////Variable storage test program///////////////

string test;

default
{
    state_entry()
    {
        if (test == "")
            test = "the variable storage failed";
    }

    touch_start(integer total_number)
    {
        llSay(0,test);
        test = "-passed-";
    }
}

//END

Additional InformationI hear this is a known issue so I would like to lobby for the content creators that this is one of 3 or 4 fixes that would generate lots more interest in SL'ers migrating to Legend City and other economy based grids as they pop up.
TagsNo tags attached.
Git Revision or version number
Run Mode Grid (Multiple Regions per Sim)
Physics EngineBasicPhysics
EnvironmentUnknown
Mono VersionNone
Viewer
Attached Files

- Relationships
duplicate of 0002313closedFly-Man- state_entry is called when an object is rezzed 

-  Notes
(0016644)
Fly-Man- (developer)
2010-08-27 18:17

Using the same script as the issue creator has provided,

Object notifies first that variable is empty

then when clicked, variable is filled.

When taken into inventory and rezzed again, clicking it shows that variable isn't lost

- Issue History
Date Modified Username Field Change
2009-01-09 16:55 Tommy Timewarp New Issue
2009-01-09 16:55 Tommy Timewarp SVN Revision => 0
2009-01-09 16:55 Tommy Timewarp Run Mode => Grid (Multiple Regions per Sim)
2009-01-09 16:55 Tommy Timewarp Physics Engine => BasicPhysics
2009-01-09 16:55 Tommy Timewarp Environment => Unknown
2009-01-09 16:55 Tommy Timewarp Mono Version => None
2009-03-06 16:47 idb Relationship added duplicate of 0002313
2010-08-27 18:17 Fly-Man- Status new => resolved
2010-08-27 18:17 Fly-Man- Fixed in Version => master (dev code)
2010-08-27 18:17 Fly-Man- Resolution open => fixed
2010-08-27 18:17 Fly-Man- Assigned To => Fly-Man-
2010-08-27 18:17 Fly-Man- Note Added: 0016644
2010-09-12 10:47 chi11ken Status resolved => closed


Copyright © 2000 - 2012 MantisBT Group
Powered by Mantis Bugtracker