Mantis Bug Tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0002928opensim[REGION] Physics Enginespublic2008-12-28 05:502009-01-25 18:23
Reporternlin 
Assigned ToTeravus 
PrioritynormalSeveritymajorReproducibilityalways
StatusclosedResolutionfixed 
PlatformOperating SystemOperating System Version
Product Version 
Target VersionFixed in Version 
Summary0002928: NINJA Physics no longer working after r7878
DescriptionThe original NINJA Physics patch submitted in 0002874 worked as intended but used C# 3.0 syntax for some accessors, causing a build break on VS2005. Mantis 0002922 (r7878) changed the accessors to C# 2.0 syntax but unfortunately also changed the semantics of the NINJA Physics code, resulting in NINJA Physics no longer working.

Attached patch fixes this by removing the accessors and declaring public fields instead.
TagsNo tags attached.
Git Revision or version number
Run ModeStandalone (1 Region)
Physics EngineODE
Script Engine
EnvironmentMono / Linux32
Mono Version1.2.6
Viewer
Attached Filespatch file icon ninjafix.patch [^] (3,780 bytes) 2008-12-28 05:50 [Show Content]

- Relationships
related to 0002922closedTeravus Build break with Visual Studio 2005 
related to 0002874closedTeravus NINJA Physics - patch to allow joints for OpenSim 

-  Notes
(0008518)
Fly-Man- (developer)
2008-12-28 05:54

See http://opensimulator.org/mantis/view.php?id=2922 [^] for a quick and dirty solution that was already submitted by Teravus.

This seems to make some things work again
(0008519)
nlin (developer)
2008-12-28 05:55

The fix in 0002922 changes the semantics of the code in NINJA Physics so it doesn't work as intended anymore. The fix applied here should make everything compilable and working again. Please let me know if there are further problems!

- Issue History
Date Modified Username Field Change
2008-12-28 05:50 nlin New Issue
2008-12-28 05:50 nlin File Added: ninjafix.patch
2008-12-28 05:50 nlin SVN Revision => 7880
2008-12-28 05:50 nlin Run Mode => Standalone (1 Region)
2008-12-28 05:50 nlin Physics Engine => ODE
2008-12-28 05:50 nlin Environment => Mono / Linux32
2008-12-28 05:50 nlin Mono Version => 1.2.6
2008-12-28 05:54 Fly-Man- Note Added: 0008518
2008-12-28 05:55 nlin Note Added: 0008519
2008-12-28 05:57 nlin Status new => patch included
2008-12-28 05:59 nlin Relationship added related to 0002922
2008-12-28 05:59 nlin Relationship added related to 0002874
2008-12-28 06:22 nlin Summary Fix NINJA Physics after C# 2.0 build break fix => NINJA Physics no longer working after r7878
2008-12-28 06:22 nlin Description Updated
2008-12-28 08:30 Teravus Status patch included => resolved
2008-12-28 08:30 Teravus Resolution open => fixed
2008-12-28 08:30 Teravus Assigned To => Teravus
2009-01-25 18:23 chi11ken Status resolved => closed


Copyright © 2000 - 2012 MantisBT Group
Powered by Mantis Bugtracker