Mantis Bug Tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0002869opensim[REGION] Scripting Enginepublic2008-12-18 12:552010-02-15 18:40
ReporterTeravus 
Assigned To 
PrioritynormalSeverityminorReproducibilityrandom
StatusclosedResolutionopen 
PlatformOSOS Version
Product Version 
Target VersionFixed in Version 
Summary0002869: META - Script-Engine Events - Event Loss, event lag
DescriptionThis meta bug will collect event issues as children to bring them under one roof in the hopes that it can produce something reproducable to fix it.
TagsNo tags attached.
Git Revision or version number
Run Mode Standalone (Multiple Regions) , Grid (Multiple Regions per Sim)
Physics EngineBasicPhysics, ODE
EnvironmentUnknown, Mono / Linux32, Mono / OSX, .NET / Windows32
Mono VersionNone
Viewer
Attached Files

- Relationships
related to 0002904closedRalfHaifisch not all scripts are executed - i.e. putting new regions in opensim instance stops script execution (partly) 
parent of 0002697closed Listeners in Attachments become slow or freeze entirely, often disabling arrow key control inputs too 
parent of 0002777closedFly-Man- Script Events - broken arrow key controls for vehicles (sailboats) 
parent of 0002778closedTeravus 7633 scripts act strange 
parent of 0002786closedM1sha SCRIPT EVENTS -Weirdness with the sail boat prim 
parent of 0002853closedWWWench several XEngine scripts break or run on restart 
parent of 0002824closedFly-Man- XEngine only initializes scripts in the first region that loads 
parent of 0002930closed SVN7882 scripts allmost broken  
parent of 0002935closedDiva Scripts no running 
parent of 0002944closedRevolution Event loss/lag with touch and collision detection 

-  Notes
(0008437)
RalfHaifisch (reporter)
2008-12-25 02:48

ups... havent noticed the tags...

yes - it is now showstopper, but not minor nor random reproducable. i guess i figured out the condition to reproduce and its stopping scripts, what means that running a region makes not to much sense - and since xengine does not telle about limits and failure like DotNetEngine, it´s allways a poker what has happend after a new start.
(0008581)
HomerHorwitz (manager)
2008-12-31 05:24

Please note: This is a meta issue, intended to "collect event issues as children to bring them under one roof in the hopes that it can produce something reproducable to fix it."

Collecting several issues under one parent I would indeed consider as of minor severity. And as at least one child has random reproducabilty, this hopefully complete collection of issues can only be reproduced random, either.

The children themselves can have different status, of course.
(0010564)
Tharidos (reporter)
2009-04-09 06:31
edited on: 2009-04-09 06:37

I have deleted all vehicle scripts and did a register cleaning. After that all was working normal again. I have tried this now 5 times and it still works. On 4 other servers with the same versions and OS, i do not have this issue. It's only on 1. The problems appears after i place a vehicle script. and restarted the server. After deleting that object and script the porblem still was there, but after a clean registry errors direct after a hard computer restart it worked.

Another thing i noticed is that after i deleted all folder in the sciptenginefolder in the bin, and started opensim all scipts where waiting.

Maybe some else can try this also and let us know what there experiences are.


- Issue History
Date Modified Username Field Change
2008-12-18 12:55 Teravus New Issue
2008-12-18 12:55 Teravus SVN Revision => 0
2008-12-18 12:55 Teravus Run Mode => Standalone (Multiple Regions) , Grid (Multiple Regions per Sim)
2008-12-18 12:55 Teravus Physics Engine => BasicPhysics, ODE
2008-12-18 12:55 Teravus Environment => Unknown, Mono / Linux32, Mono / OSX, .NET / Windows32
2008-12-18 12:55 Teravus Mono Version => None
2008-12-18 12:55 Teravus Summary META: Script-Engine Events - Event Loss, event lag => META - Script-Engine Events - Event Loss, event lag
2008-12-18 12:55 Teravus Relationship added parent of 0002697
2008-12-18 12:59 Teravus Relationship added parent of 0002777
2008-12-18 12:59 Teravus Relationship added parent of 0002778
2008-12-18 13:00 Teravus Relationship added parent of 0002786
2008-12-18 13:01 Teravus Relationship added parent of 0002824
2008-12-18 13:04 Teravus Relationship added parent of 0002853
2008-12-24 12:06 idb Relationship deleted parent of 0002824
2008-12-24 12:07 idb Relationship added parent of 0002824
2008-12-24 15:24 RalfHaifisch Relationship added related to 0002904
2008-12-24 20:31 WWWench Note Added: 0008436
2008-12-25 02:48 RalfHaifisch Note Added: 0008437
2008-12-26 14:07 Teravus Target Version => 0.6.2
2008-12-28 14:04 WWWench Note Added: 0008528
2008-12-29 01:17 RalfHaifisch Relationship added parent of 0002930
2008-12-29 04:06 RalfHaifisch Relationship added parent of 0002935
2008-12-31 05:24 HomerHorwitz Note Added: 0008581
2009-01-01 10:13 Gerhard Relationship added parent of 0002944
2009-01-26 02:39 WWWench Note Added: 0009024
2009-01-26 03:29 WWWench Note Added: 0009028
2009-01-27 05:31 WWWench Note Added: 0009040
2009-01-27 05:56 WWWench Note Added: 0009041
2009-01-27 07:31 WWWench Note Added: 0009042
2009-02-03 05:27 WWWench Note Added: 0009125
2009-02-03 05:29 WWWench Note Edited: 0009125
2009-02-04 22:47 WWWench Note Deleted: 0008528
2009-02-04 22:47 WWWench Note Deleted: 0009024
2009-02-04 22:47 WWWench Note Deleted: 0009028
2009-02-04 22:47 WWWench Note Deleted: 0009125
2009-02-04 22:47 WWWench Note Deleted: 0009040
2009-02-04 22:48 WWWench Note Deleted: 0009042
2009-02-04 22:48 WWWench Note Deleted: 0009041
2009-02-04 22:48 WWWench Note Deleted: 0008436
2009-04-09 06:31 Tharidos Note Added: 0010564
2009-04-09 06:35 Tharidos Note Edited: 0010564
2009-04-09 06:37 Tharidos Note Edited: 0010564
2009-10-11 12:35 Peter13 Status new => resolved
2010-02-15 18:40 chi11ken Status resolved => closed


Copyright © 2000 - 2012 MantisBT Group
Powered by Mantis Bugtracker