Mantis Bug Tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0002531opensim[REGION] OpenSim Corepublic2008-11-02 15:182014-07-29 13:40
Reportermirceakitsune 
Assigned Tomirceakitsune 
PrioritynormalSeverityminorReproducibilityalways
StatusclosedResolutionfixed 
PlatformPentium 4OSWindows XP Media CenterOS VersionSP3 32bit
Product Version 
Target VersionFixed in Versionmaster (dev code) 
Summary0002531: Avatar gets an invalid inventory entry if attempting to take a copy of an object in a neighboring sim
DescriptionAn avatar trying to take a copy of an object sitting in a neighboring region will get an inventory entry with the object's name but the object cannot be rezzed from the inventory, which likely means that entry is broken and the copy of the object is taken incorrectly. Likely happens for Take too.
Steps To ReproduceSit in a region then move your camera into a neighboring simulator. Right-click an object there that allows you to take copies of it and select Take Copy from the pie menu. You will get an inventory entry under the Objects part of the inventory but if you attempt to rez it from there nothing happens, and that entry will never work.
Additional InformationMost likely happens because attempting to take a prim from a neighboring sim in your inventory while not sitting in it gives the avatar a null UUID or something instead of that inventory item pointing to the UUID of the asset belonging to the prim you just took.
TagsNo tags attached.
Git Revision or version number
Run Mode Grid (1 Region per Sim)
Physics EngineODE
Environment.NET / Windows32
Mono VersionNone
Viewer
Attached Files

- Relationships

-  Notes
(0006812)
melanie (administrator)
2008-11-02 15:24

as fsr as i understand, child agents cannot perform inventory transactions
(0006813)
mirceakitsune (reporter)
2008-11-02 15:27

Does that mean this cannot be fixed? This will be needed later on when giving inventory to someone by dragging the inventory entry in their Profile window for example (I think). If specifically taking a copy of a prim to inventory from a neighboring sim isn't possible however maybe at least it should be denied and explained in a popup message, so people don't get bad inventory entries since that isn't normal, if that's possible. I think on the LL grid it should normally work though..
(0012455)
mirceakitsune (reporter)
2009-07-15 09:46

Can still confirm in r10027.
(0012456)
melanie (administrator)
2009-07-15 09:50

Here is what happens:

The "take" is sent by the client to the sim the object is in (through the child agent)

The child agent performs the inventory transaction correctly

The child agent sends an inventory item update to the viewer

The Viewer displays the inventory item

The user attempts a rez into their current sim

The item is not in that sim's cache of the user's inventory

The rez fails.

If the user relogs and clears cache, the item will become usable.

When the inventory system is converted to ROBUST and the new protocol, this will no longer happen. The current protocol doesn't support this, and cannot easily support it.
(0020501)
mirceakitsune (reporter)
2011-12-12 05:32

I tested this again in r/17539 GIT, between my sim and another region on OSGrid. I took a copy of an object from the other sim, and this time got a valid inventory entry, which rezzed properly in my simulator. This means the issue should be resolved now. Can anyone else confirm so we can be sure?

- Issue History
Date Modified Username Field Change
2008-11-02 15:18 mirceakitsune New Issue
2008-11-02 15:18 mirceakitsune SVN Revision => 7057
2008-11-02 15:18 mirceakitsune Run Mode => Grid (1 Region per Sim)
2008-11-02 15:18 mirceakitsune Physics Engine => ODE
2008-11-02 15:18 mirceakitsune Environment => .NET / Windows32
2008-11-02 15:24 melanie Note Added: 0006812
2008-11-02 15:27 mirceakitsune Note Added: 0006813
2009-07-15 09:46 mirceakitsune Note Added: 0012455
2009-07-15 09:50 melanie Note Added: 0012456
2011-12-12 05:32 mirceakitsune Note Added: 0020501
2011-12-12 05:33 mirceakitsune Mono Version => None
2011-12-12 05:33 mirceakitsune Status new => resolved
2011-12-12 05:33 mirceakitsune Fixed in Version => master (dev code)
2011-12-12 05:33 mirceakitsune Resolution open => fixed
2011-12-12 05:33 mirceakitsune Assigned To => mirceakitsune
2014-07-29 13:40 chi11ken Status resolved => closed


Copyright © 2000 - 2012 MantisBT Group
Powered by Mantis Bugtracker