Mantis Bug Tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0002484opensim[REGION] OpenSim Corepublic2008-10-28 00:022019-02-05 09:01
Reporterlmmz 
Assigned To 
PrioritynormalSeverityblockReproducibilityalways
StatusnewResolutionreopened 
PlatformOSOS Version
Product Version 
Target VersionFixed in Version 
Summary0002484: r6994 - changes to a linkset are not always saved unless linkset is taken into INVENTORY
DescriptionSeveral times, I have added or removed prims from a linkset, then logged off, assuming the changes were persistent. If I happen to restart the region before logging back in, I see that the changes to the linkset did not persist. Taking the object into INVENTORY and re-rezzing it seems to be force the linkset changes to be written.
TagsNo tags attached.
Git Revision or version number
Run Mode Grid (Multiple Regions per Sim)
Physics EngineODE
EnvironmentMono / Linux32
Mono VersionNone
Viewer
Attached Files

- Relationships
child of 0002870new META - Linking issues 

-  Notes
(0006711)
mirceakitsune (reporter)
2008-10-31 03:34

Haven't experienced the issue yet but as a workaround, instead of bothering with taking it in inventory and re-rezzing just shift-drag the prim and delete what you dragged. A newly re-created version of the linkset is created at the initial position when you shift-drag the object and that certainly fixes it... its how I make sure a linkset always updated correctly.
(0006853)
lmmz (reporter)
2008-11-03 15:48

thx for the tip.
(0007093)
idb (manager)
2008-11-13 02:27

There has been a recent change http://opensimulator.org/mantis/view.php?id=2597 [^]
Has that fixed this problem too?
(0007095)
rjs (reporter)
2008-11-13 03:26

I experienced this just recently. Logged off, restarted the server, and a linked prim that had been removed reappeared.

Might want to leave this one open for just a bit as it was a latter revision just a day or so ago that I was working with.

Thank you,
--rjs
(0007118)
rjs (reporter)
2008-11-14 14:03
edited on: 2008-11-14 14:05

Hello,

This is not resolved on this end for sure. I was waiting to see if this would happen again. It did. After a server restart, update to 7300 which is where this is at the moment, I found that deleted prims came back and indeed were linked again.

Testbed:
Debian 4.0 stable - mono v1.9.1 - MySQL 5 - ODE .71 source compile - SVN 7300

Grid Server w/multiple simulators

Thank you,
rjs

(0007119)
melanie (administrator)
2008-11-14 14:13

any link/delink should set HasGroupChanged on the SOG in question. that seems to be missing in places.
(0011450)
lmmz (reporter)
2009-05-12 21:08

Still occurs in r9535. I can create a linkset, unlink one piece of the set, log off, restart the region, log back on and the unlinked piece of the set is relinked to the set. Deleted pieces do not seem to return, however.
(0011581)
lmmz (reporter)
2009-05-17 13:04

Still happening in 9561.
(0011811)
lmmz (reporter)
2009-05-31 18:50

still happening in 9740.
(0011854)
lmmz (reporter)
2009-06-01 22:31

this seems like a serious bug, which could bite a builder in the butt if he /she did not know about the issue. anyone want to take a crack at it?
(0011861)
user903
2009-06-02 01:19

melanie committed related code in r9760

Explicitly set the changed status of the prim groups affected in a delink
Mantis 0002484

see more at - http://opensimulator.org/cgi-bin/viewvc.cgi?view=rev&revision=9760 [^]
(0011869)
lmmz (reporter)
2009-06-02 09:46

Will test! THX!
(0011871)
lmmz (reporter)
2009-06-02 10:16

This doesnt seem to be fixed for me on 9761. Linksets are not preserved if the region is restarted before I login again. Mel, do you have a certain repo of steps you would like me to test?
(0011873)
melanie (administrator)
2009-06-02 11:38

The change I made will cause UNlinking to persist, Linking is untouched. It causes the normal persistence save, so it may take a qhile for the sim to actually save the prim link sets. If you don't wait long enough, there will not be time for that to happen.
(0012219)
lmmz (reporter)
2009-06-21 12:30

What is the communities recommendation for this Mantis?
(0019222)
makopoppo (manager)
2011-07-30 04:43

Since there is no feedback nor additional informations from the reporters, closing it for now. If you still feel this is problem, please reopen it.
(0019228)
melanie (administrator)
2011-07-30 06:31

This is very much still an issue and it's a major one.
(0022565)
SignpostMarv (reporter)
2012-09-09 11:07

A little over a year since the last issueyness, is it still an issue?
(0025629)
lmmz (reporter)
2014-03-28 14:47
edited on: 2014-03-28 14:47

I think this can be closed. Parent issue exists for reporting further.

(0025639)
AliciaRaven (manager)
2014-03-29 07:01

I dont think this should be closed. Most of the issues linked to the parent are all closed, this is the only one still open that is about persistance. Today i have seen this problem. I changed some textures and rescaled some prims and after a server restart they had gone back to their previous state. 99% of the time its works ok, seems to be a intemitant problem, but still there.

Im using linux (ubuntu) with the 0.7.6 release version. Could this have been fixed in dev code maybe?

Thanks :)
(0034175)
tampa (reporter)
2019-02-05 09:01

Is this still a problem on master? Shutdown should properly store all changes, some larger changes may fail due to amount of queries sent, but this is much less an issue these days no?

- Issue History
Date Modified Username Field Change
2008-10-28 00:02 lmmz New Issue
2008-10-28 00:02 lmmz SVN Revision => 6994
2008-10-28 00:02 lmmz Run Mode => Grid (Multiple Regions per Sim)
2008-10-28 00:02 lmmz Physics Engine => ODE
2008-10-28 00:02 lmmz Environment => Mono / Linux32
2008-10-31 03:34 mirceakitsune Note Added: 0006711
2008-11-03 15:48 lmmz Note Added: 0006853
2008-11-13 02:27 idb Note Added: 0007093
2008-11-13 03:26 rjs Note Added: 0007095
2008-11-14 14:03 rjs Note Added: 0007118
2008-11-14 14:05 rjs Note Edited: 0007118
2008-11-14 14:11 rjs Status new => confirmed
2008-11-14 14:13 melanie Note Added: 0007119
2008-12-18 13:12 Teravus Relationship added child of 0002870
2009-05-12 21:08 lmmz Note Added: 0011450
2009-05-17 13:04 lmmz Note Added: 0011581
2009-05-31 18:50 lmmz Note Added: 0011811
2009-06-01 22:31 lmmz Note Added: 0011854
2009-06-01 22:31 lmmz Status confirmed => feedback
2009-06-02 01:19 user903 Checkin
2009-06-02 01:19 user903 Note Added: 0011861
2009-06-02 09:46 lmmz Note Added: 0011869
2009-06-02 10:16 lmmz Note Added: 0011871
2009-06-02 11:38 melanie Note Added: 0011873
2009-06-21 12:30 lmmz Note Added: 0012219
2011-07-30 04:43 makopoppo Mono Version => None
2011-07-30 04:43 makopoppo Note Added: 0019222
2011-07-30 04:43 makopoppo Status feedback => closed
2011-07-30 04:43 makopoppo Resolution open => suspended
2011-07-30 06:31 melanie Status closed => feedback
2011-07-30 06:31 melanie Resolution suspended => reopened
2011-07-30 06:31 melanie Note Added: 0019228
2011-07-30 06:32 melanie Status feedback => new
2012-09-09 11:07 SignpostMarv Note Added: 0022565
2014-03-28 14:47 lmmz Note Added: 0025629
2014-03-28 14:47 lmmz Note Edited: 0025629 View Revisions
2014-03-29 07:01 AliciaRaven Note Added: 0025639
2019-02-05 09:01 tampa Note Added: 0034175


Copyright © 2000 - 2012 MantisBT Group
Powered by Mantis Bugtracker