Mantis Bug Tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0002313opensim[REGION] Scripting Enginepublic2008-10-02 04:132010-09-12 10:47
ReporterChristopher Yeoh 
Assigned ToFly-Man- 
PrioritynormalSeverityminorReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version 
Target VersionFixed in Versionmaster (dev code) 
Summary0002313: state_entry is called when an object is rezzed
Descriptionthe state_entry event in the default state is called in addition to on_rez being called (and beforehand) when an object is rezzed. It should not be called when an object is rezzed (at least the LL servers don't do it)
TagsNo tags attached.
Git Revision or version number
Run ModeStandalone (1 Region)
Physics EngineBasicPhysics
EnvironmentMono / Linux32
Mono VersionNone
Viewer
Attached Files

- Relationships
has duplicate 0003262closedFly-Man- script states are not saved when an object is rezzed from inventory 
has duplicate 0002972closedFly-Man- Script state and other data is not saved for items returned to inventory 

-  Notes
(0005605)
melanie (administrator)
2008-10-02 05:56

Since we don't have script state persistence in inventory, all scripts will restart from the beginning when rezzed. Therefore, state_entry is correct. The actual behavior is as if the reset script button was pushed right after rez.

So, this is design behavior until the underlying issue (XML format) is solved.
(0007872)
Teravus (administrator)
2008-12-14 00:30

Isn't this resolved by changing to XEngine?
(0007910)
melanie (administrator)
2008-12-14 08:39

No. XEngine has state in world, but not in inventory.
(0016643)
Fly-Man- (developer)
2010-08-27 18:14

On_rez state in a object now works, on_rez is being used when a prim is rezzed out of inventory

- Issue History
Date Modified Username Field Change
2008-10-02 04:13 Christopher Yeoh New Issue
2008-10-02 04:13 Christopher Yeoh SVN Revision => 6585
2008-10-02 04:13 Christopher Yeoh Run Mode => Standalone (1 Region)
2008-10-02 04:13 Christopher Yeoh Physics Engine => BasicPhysics
2008-10-02 04:13 Christopher Yeoh Environment => Mono / Linux32
2008-10-02 05:56 melanie Note Added: 0005605
2008-12-14 00:30 Teravus Note Added: 0007872
2008-12-14 06:23 sdague Status new => feedback
2008-12-14 08:39 melanie Note Added: 0007910
2009-03-06 16:46 idb Relationship added has duplicate 0003262
2009-03-06 16:47 idb Relationship added has duplicate 0002972
2010-08-27 18:14 Fly-Man- Mono Version => None
2010-08-27 18:14 Fly-Man- Status feedback => resolved
2010-08-27 18:14 Fly-Man- Fixed in Version => master (dev code)
2010-08-27 18:14 Fly-Man- Resolution open => fixed
2010-08-27 18:14 Fly-Man- Assigned To => Fly-Man-
2010-08-27 18:14 Fly-Man- Note Added: 0016643
2010-09-12 10:47 chi11ken Status resolved => closed


Copyright © 2000 - 2012 MantisBT Group
Powered by Mantis Bugtracker